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ABOUT THIS USER GUIDE

This user guide describes how to use Lighthouse and is current as of 2023.10.

When using a minor release, there may or may not be a specific version of the user

guide for that release.

The current Lighthouse user guide, and other guides can always be found here on

the website.

Note: OPERATIONS MANAGER support may be partial for earlier releases.
Partial support may currently involve:

Mass node Enrollment using ZTP

Enrollment via USB drive

All template types are supported.

About This User Guide
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LIGHTHOUSE OVERVIEW

Lighthouse allows you to centrally access, manage, and monitor a network of
Opengear console servers. Lighthouse is a virtual machine that can be hosted on
various platforms like VMware or Hyper-V (on customer hardware) or on supported

cloud providers (AWS or Azure).

Console servers connect to a central Lighthouse instance over an OpenVPN tunnel,
and are accessed, managed, and monitored via services transported over the VPN

tunnel. The console server is referred to as the node.

LIGHTHOUSE ARCHITECTURE

Lighthouse is an API-driven platform with an HTMLS5 interface that provides secure
access to remote networks regardless of how devices are connected or how a user

interacts with the system.

In combination with select Opengear Appliances, Lighthouse can push and manage
Docker containers to each remote location to provide additional functionality and

automation.

* An enterprise user connected to an IP network with a route to an enrolled

Opengear device can access any other enrolled Opengear device (via IP).

» Devices attached to Opengear nodes can use IP routed connectivity to other

devices attached to other Opengear nodes.

* Network automation and configuration tools deployed on centrally located

servers can use IP routed connectivity to devices and systems attached to

Lighthouse Overview
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Opengear nodes. For example vCenter is the configuration tool and it is used to

provision eSXI server instances attached to Opengear nodes.

Nodes connect to a central Lighthouse instance over an OpenVPN tunnel, and are

accessed, managed, and monitored via services transported over the VPN tunnel.

- r'y
(] (4]
<« —

Primary B Smmm— —> Secondary
Lighthouse — > Lighthouse

Remote / < \ Remote

Operator — Operator

Enrolled Node
E 3
—» Web Ul (HTTPS), CLI (SSH) — —

—> Lighthouse VPN (OpenVPN) Enrolled Node

Lighthouse Multi-Instance

-
N

Enrolled Node

Note:This diagram depicts High Availability. If there is no dependent

Lighthouse, the setup remains the same but without the dependent elements.

Lighthouse Overview
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THE LIGHTHOUSE VIRTUAL MACHINE REQUIREMENTS

Lighthouse deploys as an application running in a Linux-based virtual machine
(VM). To run a Lighthouse VM, the host computer must be able to run a VM manager

and at least one full 64-bit Linux-based virtual machine.

The Lighthouse binary is available in Open, VMware and Hyper-V specific Virtual
Machine formats. VM managers such as Boxes, KVM and VirtualBox can make use
of the open format. Lighthouse binaries are also available for cloud hosting services

including Amazon’s AWS, and Microsoft Azure.

NetOps Modules are released independently of Lighthouse software or Operations
Manager firmware. These releases are shipped to Amazon's ECR Public Gallery,
where they can be fetched by Lighthouse then deployed to all activated nodes by
Lighthouse. NetOps modules can also be downloaded off the Opengear FTP site,

and uploaded manually on Lighthouse.
To host Lighthouse, the VM needs to be configured to support:

* A minimum 50GB SCSI disk. Start with more if you think your network will
expand. Additional space may be required depending on your feature usage on

Lighthouse and the scale of the network.

* 1 x network interface card, preferably paravirtualised (virtio, vmxnet3), Realtek

rtI8139, or Intel e1000 are also supported, bridged.

* VGA console for initial setup.

To dimension CPU and RAM resources, follow these guidelines:

Lighthouse Overview
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Note:CPU and RAM utilization increase with the number of enrolled nodes,

network utilisation and storage.

For small deployments (Up to 500 nodes), allocate at a minimum:

* 2 x 64-bit CPU cores.

+ 8GB RAM.

For medium deployments (between 500 and 1000 nodes), allocate at the minimum:
* 4 x 64-bit CPU cores.

* 16GB RAM.

For large deployments (more than 1000), allocate allocate at the minimum:

* 4 x 64-bit CPU cores.

* 32GB RAM.

Note:In general it is recommended that you add more memory than you

assume you need.

For large deployments, please contact us for guidance on the deployment options,

including low and zero-touch Enroliment.

LIGHTHOUSE TO NODE INTERACTIONS

When a node is enrolled to Lighthouse, a Virtual Private Network (VPN) tunnel is
established between Lighthouse and the node. This provides secure encrypted IP
networking, which is resilient to changes in the underlying network (such as node

failover to cellular).

Lighthouse Overview
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Lighthouse interacts with the node over the VPN tunnel, mostly via the node's REST

APl and SSH. Nodes notify Lighthouse of changes to their configuration and status.

The node web Ul is accessible directly through Lighthouse, and is proxied via the
VPN:; this allows secure user access to the node even if it is behind a firewall with no
direct HTTPS access.

USING MULTIPLE LIGHTHOUSES

Lighthouse offers a form of high availability with the Multiple Instance feature. The
Multiple Instance feature allows you to set up dependent instances of Lighthouse.
The dependent Lighthouses automatically receive updates from the primary

Lighthouse instance, and maintains connections to all of its remote nodes.

The dependent Lighthouse will also replicate various values from the primary

Lighthouse to ensure in the event of a failover, all information is up to date.

Dependent instances are read-only. They may be used to view Lighthouse
information specific to that instance, and to connect to its nodes via pmshell.
Configuration changes must be performed on the primary Lighthouse instance,

which will then update the information displayed on the dependent instance.
The multiple instance feature has the following limitations:

 If external network addresses on the primary or secondary Lighthouses are
updated after a dependent Lighthouse has been enrolled, it may break

replication.

* Only Opengear nodes with a version that supports multiple instance will connect
to the dependent instance. Nodes that don't support multiple instances will

behave normally on the primary lighthouse.

Lighthouse Overview
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* Up to ten dependent instances can be enrolled

* Dependent Lighthouse instances are read-only.Ensure that you re-configure
instance specific settings such as hostname, external endpoints, and time zone
on a dependent instance before adding the dependent instance to the primary

Lighthouse in a normal way through UlI.

* Only dependent Lighthouse instances with zero nodes can be enrolled to the

primary Lighthouse.

* Removing a dependent Lighthouse instance will initiate a factory reset of the

removed Lighthouse.

Note:Dependent Lighthouse user interfaces are read-only.

EULA AND GPL

The current Opengear end-user license agreement and the GPL can be found at

http://opengear.com/eula.

Lighthouse Overview
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INSTALLING LIGHTHOUSE

To install Lighthouse you require:

* A virtual machine (VM) that can support a 50GB disk at the minimum and
* The correctimage file.

Lighthouse Virtual Machines Availability

Lighthouse VM is available in several formats on our secure ftp sites, from where
you can download and verify the checksums and install the appropriate files. Ensure

you use the correct upgrade file for your upgrade.

* lighthouse-23.10.0-ovf.zip - An Open Volume Format file inside a PKZip
archive. This is for use with virtual machine managers such as KVM and Virtual

Box.

* lighthouse-23.10.0-vmx.zip - A VMware configuration file inside a PKZip

archive. This is for use with virtual machine managers from VMware.

* lighthouse-23.10.0.ova - An Open Virtual Appliance file. This is for use with
virtual machine managers such as VM and Virtual Box as well as for use with

virtual machine managers from VMware.

* lighthouse-23.10.0-hyperv.zip - A Hyper-V configuration file with Powershell

script inside a PKZip archive. This is for use in Microsoft Hyper-V deployment.
* lighthouse-23.10.0.azure.zip - A Microsoft Azure file, for deploying on Azure.

* lighthouse-aws-bootstrap.sh, and the lighthouse-23.10.0.aws.raw.tar image

- A shell script for deploying on AWS.

* lighthouse-23.10.0.lh_upg - An upgrade file.

Installing Lighthouse
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lighthouse-23.10.0.aws.lh_upg - Upgrade on AWS.

lighthouse-23.10.0.azure.zip - Upgrade on Azure.

There are also SHASUMS files to verify the downloaded files.

Note:The latest format for the files is as follows:

lighthouse-<year>.<month>.<release/patchnumber>

INSTALLING LIGHTHOUSE VM ON VMWARE

This section describes how to install Lighthouse VMs on VMware hosts including:

* VMware vSphere 6.0 client on Windows
* VMware Workstation Player on Windows

* VMware Workstation Pro on Windows

VMWARE VSPHERE 6.0 CLIENT ON WINDOWS

This procedure was tested using the VMware Sphere Client 6.0 running on Windows
7 Enterprise SP 1.

REQUIREMENTS
Ensure the following preconditions are met before you start installation:

* VMware vSphere 6.0 is installed and running on available hardware.

* Access to a Windows computer on which the VMware vSphere 6.0 client is

installed.

Installing Lighthouse
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* The installed client application must be able to connect to and manage the

VMware vSphere 6.0 instance.

* Finally, a copy of the Lighthouse binary in Open Volume Format is required, the
.ovf file, either copied to the Windows computer running the VMware vSphere 6.0

client or available via a URL.

LAUNCH THE VSPHERE CLIENT AND CONNECT TO A VSPHERE
INSTANCE.

1. Launch the VMware vSphere Client. The simplest way is to use the Start Menu

shortcut added during installation.
Start > All Programs > VMware > VMware vSphere Client

The VMware vSphere Client opens a login window.

= VEware vSphere Chent

vmware

Viware vSphere”
Client

L] All viphere features introduced in vSphers 5.5 and beyond are
avadable only hrough the vSphere Wb Chent. The: raditional
wSphere Chent will continue to operate, supporting the same:
feature set ag vophere 5.0.

To directly manage a singhs host, enber the IP address or host name.
To manage multiple hosts, enter the IF address or name of &

wilarber Sarver,
IP sddress [ Name:  [es =
e Pt I
Pacssweond: |

Installing Lighthouse
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Select the IP address or name of the VMware vSphere instance where

Lighthouse will be installed from the IP address/Name drop-down list.

Enter the User name and Password required to gain management privileges to

the selected VMware vSphere instance.
Click Login or press Return.

The login window displays progress text in the bottom left corner:
Connecting

Loading inventory

Loading main form

Displaying main form

The vSphere main form window opens.

IMPORT THE LIGHTHOUSE VM OPEN VOLUME FORMAT (.OVF)
IMAGE

To import the Lighthouse VM:

1.

From the vSphere Client menu bar, choose File > Deploy OVF Template.
The Deploy OVF Template window displays, with the first stage, Source, pre-

selected.

If the file Opengear Lighthouse VM.ovf is on a remote computer via a URL,
enter the URL in the Deploy from a file or URL field. Otherwise, click Browse.
An Open dialog displays.

a. Navigate to the directory containing the file Opengear Lighthouse VM.ovf.

b. Select Opengear Lighthouse VM.ovf and click Open.

Installing Lighthouse
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. The Deploy OVF Template window opens again, with the Opengear

Lighthouse VM.ovf file listed in the Deploy from a file or URL combo-box. Click
Next.

The OVF Template Details stage displays, showing basic information about the

Lighthouse VM encapsulated by the .ovf file. Click Next.

The Name and Location screen displays with the Name field pre-populated and
pre-selected. The default name is Opengear Lighthouse VM. To change this,

enter a new name. Click Next.

The Disk Format screen displays which data-store the Lighthouse VM’s virtual
disk uses, how much free space the virtual disk has available and which

provisioning scheme is being used. Click Next.

The Network Mapping screen shows which destination or inventory network the

Lighthouse VM’s virtual network is mapped to. Click Next.

The Ready to Complete screen displays, listing the basic properties of the
about-to-be-deployed virtual machine. To be able to power-up the new virtual
machine after deployment, select the Power on after deployment checkbox.
Click Finish.

The Deploying Opengear Lighthouse VM progress dialog displays.

[+ 57% Deploying Opengear Lighthouse V4 HiE E
Deploying Opengear Lightheuse WM

Dephoying disk 1 of 1 fram
C Wsers | Adiministrator \Doouments ronman.oviOpengear Lighthouse
Wel\Opengear_Lighthouse Vi-disk 1. vmdk

B seconds remaining

I™ Close this dislog when completed

Once deployment has finished the Deployment Completed Successfully alert
displays. Click Close.

The new virtual machine is now deployed and displays in the inventory list.

Installing Lighthouse
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LAUNCH LIGHTHOUSE

The vSphere Client provides several ways of launching a Virtual Machine hosted on
a vSphere instance. Begin by selecting the Lighthouse VM from the vSphere
Client’s inventory list. The selected VM can then be launched by doing one of the

following:
* Select Inventory > Virtual Machine > Power > Power On.
* Press Ctrl-B.

* Click the Power On the virtual machine link in the Basic Tasks section of the
Getting Started tab. This option requires the Getting Started tab be front-most.

If it is not already the front-most tab, make it active by clicking it.
* Select Inventory > Virtual Machine > Open Console and then:
» Click Power On in the console tool bar, or
¢ Choose VM > Power > Power On from the console menu bar, or

e Press Ctrl-B.

Note:Only the fourth option above results in the running virtual machine being
accessible from within the vSphere Client. The first three boot the Lighthouse
VM and run it as a headless system, that is, with no display on a monitor.

However, you can access Lighthouse via the web Ul or SSH.

ACCESS THE CONSOLE OF A RUNNING BUT HEADLESS
LIGHTHOUSE INSTANCE

If direct interaction with a running but headless *Opengear Lighthouse VM* is

required, open a console window.

Installing Lighthouse
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Select the running Opengear Lighthouse VM in the vSphere Client’s inventory list,

then do one of the following:
* Select Inventory > Virtual Machine > Open Console or

* Right-click and select Open Console from the context menu that displays.

VMWARE WORKSTATION PLAYER ON WINDOWS AS
HOST

Follow these steps when VMware Workstation Player is installed on the host
Windows machine. VMware-ready virtual machine files are stored in
C:\Users\%USERNAME%\Virtual Machines\. This is the location selected by
default by VMware Workstation Player. If another location is preferred, adjust this

procedure as required.
Prepare the Lighthouse VM file for import into VMware Workstation Player:

1. Move the lighthouse-23.10.0-vmx.zip archive to
C:\Users\%USERNAME%\Virtual Machines\.

2. Right-click the archive and select Extract All from the contextual menu.

3. A Select a Destination and Extract Files dialog opens. By default, the location
is the same folder as the archive is in: C:\Users\%USERNAME%\Virtual

Machines\. Leave this as the destination folder.

4. Uncheck the Show Extracted Files When Complete checkbox and then click

Extract.

5. Afolder called lighthouse is created inside C:\Users\%USERNAME%\Virtual

Machines\.
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IMPORT THE OPENGEAR LIGHTHOUSE VM FILE INTO VMWARE
WORKSTATION PLAYER

1. Launch VMware Workstation Player.
2. Click Open a Virtual Machine.
3. Navigate to C:\Users\%USERNAME%\Virtual Machines\lighthouse\.

VMware Workstation Player points to Libraries > Documents and includes
C:\Users\%USERNAME%\My Documents\.

Assuming this is the case, double-click Virtual Machines and then double-click

Lighthouse.

4. If only one file, Lighthouse, is visible, double-click on it to add the Lighthouse
virtual machine to the VMware Workstation 12 Player virtual machines list. If

more than one file displays, double-click Lighthouse.vmx.

5. The Lighthouse virtual machine is added to the VMware Workstation 12 Player

virtual machines list.

6. With Opengear Lighthouse VM selected in the VMware Workstation 12 Player

virtual machine list, click Play Virtual Machine to boot Lighthouse.

VMWARE WORKSTATION PRO ON WINDOWS AS HOST

This procedure assumes VMware Workstation Pro is already installed on the host
Windows machine and that VMware-ready virtual machine files are stored in
C:\Users\%USERNAME%\Virtual Machines\. If another location is preferred,

adjust the steps as needed.

IMPORT THE LIGHTHOUSE VM FILE INTO VMWARE WORKSTATION
PRO

Step 1. Preparation:
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This step prepares the Lighthouse VM File for Import Into VMware Workstation Pro.

1.

Move the lighthouse-23.10.0.zip archive to C:\Users\%USERNAME%\Virtual

Machines\.

Right-click the lighthouse-23.10.0-vmx.zip archive and select Extract All from

the contextual menu.

A Select a Destination and Extract Files dialog opens. The location is the
same folder as the PKZip archive is in: C:\Users\%USERNAME%\Virtual

Machines\. Leave this as the destination folder.

Uncheck the Show Extracted Files When Complete checkbox and then click

Extract.

A folder called lighthouse is created inside C:\Users\%USERNAME%\Virtual

Machines\.

Step 2. Import Lighthouse VM File:

1.

2.

Click Open a Virtual Machine.
Navigate to C:\Users\%USERNAME%\Virtual Machines\lighthouse\.

VMware Workstation Pro points to Libraries > Documents and this library
includes C:\Users\%USERNAME%\My Documents\. Double-click Virtual

Machines and then double-click Lighthouse.

If only one file, Lighthouse, displays, double-click the file to add the Lighthouse
virtual machine to the VMware Workstation Pro virtual machines list. If more than

one file displays, double-click Lighthouse.vmx.

The Lighthouse virtual machine is added to the VMware Workstation Pro virtual

machines list.
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6. With the Opengear Lighthouse VM selected in the My Computer listing and the
subsequent Opengear Lighthouse VM tab open, click Power on this virtual

machine to boot Lighthouse.

INSTALLING LIGHTHOUSE VM ON HYPER-V ON
WINDOWS

This section describes how to install Lighthouse VMs on Hyper-V on Windows:
* Hyper-V running on Windows 10 or Windows Server 2016
* VirtualBox deployments

LOCAL DEPLOYMENT ON HYPER-V

This procedure assumes Hyper-V is already installed on a Windows 10/Windows
Server 2016 host machine and the required Zip archive, lighthouse-23.10.0-
hyperv.zip is in C:\Users\%USERNAME%$\Downloads.

1. Unzip lighthouse-23.10.0-hyperv.zip.

2. Navigate to the extracted folder. Make sure lighthouse.vhd and lighthouse_

virtual_machine_registration.ps1 are in the folder.
3. Right-click and choose Run with Powershell to execute the Powershell script.

4. Leave the host name empty when prompted to deploy Lighthouse to local

machine.

5. Launch Hyper-V Manager. Lighthouse should be registered as a new VM image

under Virtual Machine.

6. Select Lighthouse from the list and click Start in the Action Panel to boot
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Opengear Lighthouse.

REMOTE HYPER-V DEPLOYMENT WITH PRE-AUTHENTICATED
USER

In this scenario, the user who performs Lighthouse deployment does not have local
access to Hyper-V installed on Windows 2016. However, user has access to a

Windows 10 which can manage the Hyper-V server remotely.

This procedure assumes Hyper-V is installed on Windows Server 2016 (or later)
host machine and the required Zip archive lighthouse-23.10.0-hyperv.zip is in
C:\Users\%USERNAME%$\Downloads. Windows 10 is already configured to

manage Hyper-V on Windows Server 2016.

Note:Windows 10 and Windows Server 2016 must have the same user (same
password) created. The user who performs the deployment must have
permission to both execute the Powershell script and deploy the image on

Hyper-V.

1. Login to Windows 10 with the user mentioned above.
2. Unzip lighthouse-23.10.0-hyperv.zip.

3. Navigate to the extracted folder. Make sure lighthouse.vhd and lighthouse_

virtual_machine_registration.ps1 are in the folder.

4. Right-click and choose Run with Powershell to execute the Powershell script.

. Enter the fully qualified domain name for Windows Server 2016 when prompted

to deploy Lighthouse to the remotely-managed Windows Server 2016 machine.
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6. Launch Hyper-V Manager. Lighthouse should be registered as a new VM image

under Virtual Machine for Windows Server 2016.

7. Select Lighthouse from the list and click Start in the Action Panel to boot

Opengear Lighthouse.

VIRTUALBOX DEPLOYMENTS

Lighthouse can be installed on the following hosts:
* VirtualBox on Windows as host

 VirtualBox on macOS as host

* VirtualBox on Ubuntu as Host

¢ VirtualBox on Fedora Workstation as host

VIRTUALBOX ON WINDOWS AS HOST

Note:We recommend that VirtualBox users customize their instances and
change their network cards to one other than e1000. We also suggest virtio for

better performance.

This procedure assumes VirtualBox is already installed on the host machine and the
required PKZip archive, lighthouse-23.10.0-ovf.zip is in
C:\Users\%USERNAME%$%\Downloads.

1. Unzip lighthouse-ovf. It may appear as lighthouse-23.10.0-ovf.zip depending

on the Windows Explorer preference settings).

2. Right-click the lighthouse-ovf archive and select Extract all from the context

menu.
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3. The Select a Destination and Extract Files dialog opens. The destination is
C:\Users\%USERNAME%\Downloads\Lighthouse-ovf.

4. Uncheck the Show extracted files when complete checkbox and edit the

destination by removing Lighthouse-ovf from the path.
5. Click Extract.

6. Afolder called lighthouse-ovf is created inside
C:\Users\%USERNAME%\Downloads\.

7. Launch VirtualBox.
8. The Oracle VM VirtualBox Manager window displays.
9. Choose File > Import Appliance.
10. The Appliance to Import dialog opens.
11. Click Expert Mode.
12. The Appliance to import dialog changes from Guided Mode to Expert Mode.

13. Click the icon of a folder with an upward pointing arrow superimposed. This icon

is to te far right of the Appliance to import field.h

14. The Open File dialog displays with C:\Users\% USERNAME%\Documents as

the current folder.

15. Navigate to C:\Users\%USERNAME%\Downloads\Lighthouse.ovf\Opengear
Lighthouse VM\.

16. Select the file Opengear Lighthouse VM and click Open.

17. Double-click the text vm in the Name row and Configuration column to make it
editable.

18. Type Opengear Lighthouse VM and press Enter.

19. Click Import.
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A new virtual machine, called Opengear Lighthouse VM is added to the list of

virtual machines available to Virtual Box.
Select Opengear Lighthouse VM from the list.

Select Machine > Settings or click the Settings icon in the VirtualBox Manager

toolbar or press Control+S.
The Opengear Lighthouse VM - Settings dialog displays.

Click the System option in the list of options running down the left-hand side of

the dialog.

The dialog shows the System options available as three tabs: Motherboard,
Processor, and Acceleration. Depending on the underlying hardware platform,
Acceleration may be greyed-out and unavailable. The Motherboard tab is

preselected.
In the Motherboard tab, select the Hardware Clock in UTC Time checkbox.
Click OK or press Return

Select Opengear Lighthouse VM from the list and click Start in the Oracle VM
VirtualBox Manager toolbar to boot Lighthouse. Double-clicking Opengear

Lighthouse VM in the list also boots Lighthouse.

Note:Selecting the Hardware Clock in UTC Time checkbox is necessary
because Lighthouse expects the hardware clock to be set to UTC, not local
time. Unlike other Virtual Machine Managers, Virtual Box both exposes this

option as a user-adjustable setting and does not set it to UTC by default.

VIRTUALBOX ON MACOS AS HOST

VirtualBox should already installed on the host macOS machine and the required

PKZip archive, lighthouse-23.10.0-ovf.zip is in ~/Downloads.
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. Unzip lighthouse-23.10.0-ovf.zip.

This creates a folder Lighthouse-ovf in ~/Downloads that contains the following
files and folders:

Lighthouse-owf
L Opengear Lighthouse VM
|— Opengear Lighthouse VM.ovf
L Opengear_Lighthouse_VM-disk1.vmdk

Launch Virtual Box. The Oracle VM VirtualBox Manager window displays.

Select File > Import Appliancel or press Command+l.

The Appliance to Import dialog sheet slides down from the Oracle VM

VirtualBox Manager toolbar.

Click Expert Mode.
The Appliance to Import dialog sheet changes from Guided Mode to Expert
Mode.

Click the icon of a folder with an upward pointing arrow superimposed. This icon

is to the far-right of the Appliance to Import field.

The Open File dialog sheet slides down from the Oracle VM VirtualBox

Manager toolbar. This sheet opens with ~/Documents as the current folder.

Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.

. Select Opengear Lighthouse VM and click Open. (Depending on the Finder

Preferences settings, the file may present as Opengear Lighthouse VM.ovf.)

Double-click the text vm in the Name row and Configuration column to make it
editable.

Type Opengear Lighthouse VM and press Return.
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Click Import.
A new virtual machine, called Opengear Lighthouse VM is added to the list of

virtual machines.
Select Opengear Lighthouse VM from the list.

Choose Machine > Settings. Or click the Settings icon in the VirtualBox

Manager toolbar. The Opengear Lighthouse VM Settings dialog displays.

Click the System option in the dialog’s toolbar.

The dialog shows the System options available as three tabs: Motherboard,
Processor, and Acceleration. (Depending on the underlying hardware platform,
Acceleration may be greyed-out and unavailable). The Motherboard tab is

preselected.
In the Motherboard tab, select the Hardware Clock in UTC Time checkbox.
Click OK or press Return.

Select Opengear Lighthouse VM from the list and click Start in the Oracle VM
VirtualBox Manager toolbar to boot Lighthouse. Double-clicking Opengear

Lighthouse VM in the list also boots Lighthouse.

Note:Selecting the Hardware Clock in UTC Time checkbox is necessary
because Lighthouse expects the hardware clock to be set to UTC, not local
time. Unlike other Virtual Machine Managers, Virtual Box both exposes this

option as a user-adjustable setting and does not set it to UTC by default.

Note:By default, VirtualBox stores virtual machines in ~/VirtualBox VMs. If this
is the first virtual machine setup by VirtualBox, it creates the VirtualBox VMs

folder in the current user’'s home-directory and a folder — Opengear Lighthouse
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VM — inside the VirtualBox VMs folder. The Opengear Lighthouse VM folder
contains the files and folders which make up Lighthouse when run under Virtual

Box.

VIRTUALBOX ON UBUNTU AS HOST

Before beginning the procedure, make certain that VirtualBox and all required

support files are installed on the host machine and the PKZip archive, lighthouse-

23.10.0-ovf.zip is in ~/Downloads.

1.

Unzip lighthouse-23.10.0-ovf.zip. This creates a folder, Lighthouse-ovf in

~/Downloads that contains the following files and folders:

Lighthouse-ovf
L Opengear Lighthouse VM
— Opengear Lighthouse VM.ovf
L Opengear_Lighthouse_VM-disk1.vmdk

Launch Virtual Box.

The Oracle VM VirtualBox Manager window displays.

Choose File > Import Appliance.

The Appliance to import dialog opens.

Click Expert Mode.

The Appliance to Import dialog changes from Guided Mode to Expert Mode.

Click the icon of a folder with an upward pointing arrow superimposed. This icon

is positioned to the right of the Appliance to Import field.

A file-navigation dialog, Choose a Virtual Appliance to Import, opens with

~/Documents as the current folder.
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Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.
Select Opengear Lighthouse VM.ovf and click Open.

Double-click the text vm in the Name row and Configuration column to make it
editable.

Type Opengear Lighthouse VM and press Return.

Click Import.
A new virtual machine, called Opengear Lighthouse VM is added to the list of

virtual machines available to Virtual Box.

Select Opengear Lighthouse VM from the list and click Start in the Oracle VM
VirtualBox Manager toolbar to boot Lighthouse. Double-clicking Opengear

Lighthouse VM in the list also boots Lighthouse.

Note:VirtualBox stores virtual machines in ~/VirtualBox VMs. If this is the first
virtual machine setup by VirtualBox it creates the VirtualBox VMs folder in the
current user’s home-directory and a folder Opengear Lighthouse VM inside

the VirtualBox VMs folder. Inside Opengear Lighthouse VM are the files and

folders which make up Lighthouse when run under Virtual Box.

VIRTUALBOX ON FEDORA WORKSTATION AS HOST

Before beginning, make certain that VirtualBox and all required support files are

already installed on the host machine and the PKZip archive, lighthouse-23.10.0-

ovf.zip is in ~/Downloads.
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. Unzip lighthouse-23.10.0-ovf.zip. This creates a folder Lighthouse.ovf in

~/Downloads that contains the following files and folders:

Lighthouse.ovf
L Opengear Lighthouse VM

— Opengear Lighthouse VM.ovf
L Opengear_Lighthouse_VM-disk1.vmdk

Launch Virtual Box.

The Oracle VM VirtualBox Manager window displays.

Choose File > Import Appliance or press Control-I.

The Appliance to Import dialog opens.

Click Expert Mode.
The Appliance to Import dialog changes from Guided Mode to Expert Mode.

Click the icon of a folder with an upward pointing arrow superimposed. This icon
is to the far right of the Appliance to Import field.

The Open File dialog opens with ~/Documents as the current folder.
Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.
Select Opengear Lighthouse VM and click Open.

Double-click the text vm in the Name row and Configuration column to make it
editable.

. Type Opengear Lighthouse VM and press Return.

Click Import.
A new virtual machine, called Opengear Lighthouse VM is added to the list of

virtual machines available to Virtual Box.

Installing Lighthouse



\ LIGHTHOUSE

Access Portal

11. Select Opengear Lighthouse VM from the list and click Start in the Oracle VM
VirtualBox Manager toolbar to boot Lighthouse. Double-clicking Opengear

Lighthouse VM in the list also boots Lighthouse.

Note:VirtualBox stores virtual machines in ~/VirtualBox VMs. If this is the first
virtual machine setup by VirtualBox, it creates the VirtualBox VMs folder in the
current user’s home-directory and a folder Opengear Lighthouse VM inside

the VirtualBox VMs folder. Inside Opengear Lighthouse VM are the files and

folders which make up Lighthouse when run under Virtual Box.

INSTALLING LIGHTHOUSE VM ON LINUX HOSTS

This section describes how to install Lighthouse VMs on Linux hosts:

¢ Ubuntu
e Fedora Workstation

* RHEL

VIRTUAL MACHINE MANAGER (KVM) ON UBUNTU AS
HOST

Virtual Machine Manager and all required support files should be installed on the
host machine and the .tar archive, lighthouse-23.10.0-raw.hdd.tar is in

~/Downloads.

1. Expand lighthouse-23.10.0-raw.hdd.tar. This extracts lighthouse-23.10.0-

raw.hdd in ~/Downloads.

2. Launch Virtual Machine Manager.
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. Click New at the top left of the Virtual Machine Manager window (or choose File >

New Virtual Machine). The Source Selection window opens.
Click Select a file. A Select a Device or ISO File dialog slides into view.
Navigate to ~/Downloads/.

Select the file lighthouse-23.10.0-raw.hdd and click Open in the top right-corner
of the dialog. A Review window opens providing basic information about the

virtual machine or box, as Boxes calls them, to be created.
Click Create in the top right corner of the Review window.

A new virtual machine instance, Opengear_Lighthouse_VM-disk1, is created

and presented in the Boxes window.

To rename the virtual machine instance, right-click on the machine instance and
choose Properties from the contextual menu that displays. Click anywhere in the

Name field to select and edit the name. Click the Close box to save the changes.

BOXES ON FEDORA WORKSTATION AS HOST

Boxes and all required support files should be installed on the host machine and

lighthouse-23.10.0-ovf.zip is in ~/Downloads.

1.

Unzip lighthouse-23.10.0-ovf.zip. This creates a folder Lighthouse.ovf in
~/Downloads that contains the following files and folders:
Lighthouse.ovf
L Opengear Lighthouse VM

|— Opengear Lighthouse VM.ovf
L Opengear_Lighthouse_VM-disk1.vmdk
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. Launch Boxes.

. Click New in the Boxes window title bar. The Source Selection window opens.
. Click Select a File. A Select a Device or ISO File dialog opens.

. Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/.

. Select the file Opengear_Lighthouse_VM-disk1.vmdk and click Open in the
top right-hand corner of the dialog. A Review window opens providing basic
information about the virtual machine (or ‘box’, as Boxes calls them) to be

created.
. Click Create in the top right corner of the Review window.

. A new virtual machine instance, Opengear_Lighthouse_VM-disk1 is created

and presented in the Boxes window.

. Torename the virtual machine instance, right-click on the machine instance and
choose Properties from the contextual menu that displays. Click anywhere in the

Name field to select and edit the name. Click Close to save the changes.

BOXES ON RHEL AND COMPATIBLE DISTRIBUTIONS

CentOS should be installed, complete with the Gnome desktop environment as the

host operating system. CentOS includes the full complement of KVM-centric

virtualization tools including the GUI-based virtualization management tools Boxes

and virt-manager and the shell-based virtualization management tool virsh.

This procedure assumes Boxes is used to setup and manage the Lighthouse VM

and that the required PKZip archive, lighthouse-23.10.0-ovf.zip is in

~/Downloads.

To install Lighthouse on CentOS:
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1. Unzip lighthouse-23.10.0-ovf.zip.
This creates a folder Lighthouse.ovf in ~/Downloads that contains the following

files and folders:

Lighthouse.ovf
L Opengear Lighthouse VM

— Opengear Lighthouse VM.ovf
L Opengear_Lighthouse_VM-disk1.vmdk

2. Launch Boxes
3. Click New in the Boxes title bar.
4. Navigate to ~/Downloads/Lighthouse.ovf/Opengear Lighthouse VM/

5. Select Opengear Lighthouse VM and click Open. A new virtual machine, called
Opengear LighthouseVM is added to the list of virtual machines available to

Boxes.

INSTALLING IN THE CLOUD

This section describes how to install Lighthouse on supported cloud environments:

e Azure

« AWS.

INSTALLING IN AZURE

To use the Microsoft Azure environment:

1. Login to the Microsoft Azure portal at https://portal.azure.com

2. Under Azure Services, click the Storage Accounts icon.
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. Create a new storage account with at least 50GB storage space.

. Navigate to the newly created storage account, click Containers under Data

Storage and create a new blob container.

. Download a Lighthouse VHD image, the latest Lighthouse image can be found in
a zip file at the following URL.: https://ftp.opengear.com/download/lighthouse

software/current/lighthouse/azure.

. Copy the Lighthouse VHD image into the Azure storage container. (Using
AzCopy is recommended, as the VHD image is large and the upload can take a

long time to complete through the Microsoft Azure portal.)

a. If you haven’t already, install AzCopy following instructions provided by

Microsoft. Click here to read the instructions on Microsoft’s website
b. Generate a SAS token to use in your AzCopy commands

i. While viewing the newly created storage container, click Shared access

signature under Settings.
i. Under Permissions, enable Read, Write and Create.
iii. Setvalid start and end date.
iv. Click Generate SAS and connection string at the bottom of the page.

v. Copy the Blob SAS token and Blob SAS URL, as you will not be able to

view these again.

. Copy the Lighthouse VHD image into the Azure storage container using the
following format, make sure to fill in the path to your local Lighthouse VHD image
and your Blob SAS URL generated during the previous step: . /azcopy copy

<path to local image file> "<blob sas url>"
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A SAS token can also be created using Azure CLI. Click here to read the instruc-

tions on Microsoft's website.

Create an image:
a. Inthe Azure Portal, under Azure Services, click the Images icon.

b. Click Create to create a new image, make sure that the location is the same as
your storage account, the OS type is set to Linux and VM generation is set to
Gen 1.

c. Click Browse on the Storage blob field and select the Lighthouse VHD file

you uploaded during a previous step.
d. Click Create to create the image.

Go to the newly created image and click Create VM. Ensure the selected image

is correct.
Choose the desired virtual machine instance size.

Enter the details for the Microsoft Azure admin user with either password OR

SSH key authentication.

Note:If SSH key authentication is selected, the user will be created

without a password and will be unable to access the Ul.

Select the inbound ports enabled for the Lighthouse instance (SSH, HTTPS).

Navigate to the next page of configuration (Disks) and select the desired storage

Installing Lighthouse



https://learn.microsoft.com/en-us/azure/storage/blobs/storage-blob-user-delegation-sas-create-cli#create-a-user-delegation-sas-for-a-container
https://learn.microsoft.com/en-us/azure/storage/blobs/storage-blob-user-delegation-sas-create-cli#create-a-user-delegation-sas-for-a-container

\ LIGHTHOUSE

Access Portal

option for the boot disk.

13. Go to the Review page and after validation passes, click Create.

14.

15.

16.

Go to the Virtual Machines page, select the virtual machine and open the Serial

Console. Lighthouse should now be deploying on Microsoft Azure.

To allow nodes to enroll in Lighthouse, you will need to add the following firewall
rules on the Networking page under Settings on the virtual machine you

deployed:

a. Add arule to allow UDP connections from any source to port 1194 on the

instance's internal network address (10.0.0.x).

b. Add arule to allow UDP connections from any source to port 1195 on the

instance's internal network address (10.0.0.x).

c. HTTPS and SSH should already be allowed from the initial setup If not, add

them.

d. Other ports may need to be opened, depending on feature usage. For

example:

i. SNMP (UDP/161 or TCP/161) — SNMP Management

ii. OpenVPN (UDP/1195) — Lighthouse Multiple Instance VPN
iii. HTTPS (TCP/8443) — Alternate REST API port

Confirm that the Azure instance public IP address has been added to external

endpoints in Settings > System > Administration.
SET A PASSWORD ON LIGHTHOUSE VIA SSH

If you are logged into Lighthouse via SSH keys, you will need to set a password to

login via GUI. Use the ogpasswd utility to do this.

ogpasswd -u lh admin -p MySecretPassword
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Note:Your username must be the same as the Microsoft Azure admin user

created in step 10

INSTALLING IN AMAZON WEB SERVICES

To use Lighthouse with Amazon Web Services (AWS), you will first need to create
an Amazon Machine Image (AMI) containing Lighthouse in the AWS region that you
want to deploy Lighthouse in. A temporary Linux “build-box” EC2 instance should be

used to create a private Lighthouse AMI.

Note:This is a one-time procedure. The AMI can be used to create multiple
instances of Lighthouse, and upgrades can be performed through the
Lighthouse Web Ul.

1. Create an account on AWS with an IAM user, a key pair and an access key.

* The IAM user should have, at a minimum, permissions to create, attach,
delete, and snapshot EBS volumes as well as create an Amazon Machine
Image (AMI).

 If you are using IAM Identity Center, you can use an IAM Identity Center user
with the same permissions instead. Consult Amazon documentation for more

information if required.
2. Create an AWS EC2 Linux instance, with the following settings:
* Amazon Linux 2 or Amazon Linux 2023

* t2.small instance type with default (8 GiB) root volume
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* 50GB gp3 volume

Consult Amazon documentation for more information if required.

3. Create a Lighthouse AMI, using the 1ighthouse-aws-bootstrap.sh script

(usage information can be displayed by using the -h option) on the EC2 instance

created in the previous step. The steps are detailed below.

Connect via SSH to your instance on AWS using the username ec2-user
and the private key you created previously. All subsequent steps must be

performed on the instance.

Configure AWS using the following command:

aws configure

Provide the access key and region details (other settings may be left
unchanged). If you are using IAM Identity Center, you will need to instead
configure using aws configure sso, and setthe CLI Profile Name to be

default.

Download the aws-bootstrap script:
wget http://ftp.opengear.com/download/lighthouse
software/current/lighthouse/aws/lighthouse-aws-

bootstrap.sh

Run the lighthouse-aws-bootstrap.sh script as follows:

bash ./lighthouse-aws-bootstrap.sh -n Lighthouse -r
https://ftp.opengear.com/download/lighthouse
software/current/lighthouse/aws/lighthouse-
23.10.0.aws.raw.tar

Note: lighthouse-23.10.0.aws.raw.tar is the sample file. You must download

the latest file for your version of Lighthouse
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* Wait while the Lighthouse AMI is created. This can take some time (up to 30

minutes).

» After the AMI has been created, terminate the Linux EC2 instance to avoid

incurring additional costs.

Running the bootstrap script - Example

$ bash ./lighthouse-aws-bootstrap.sh -n Lighthouse -r \

> http://ftp.opengear.com/download/lighthouse
software/current/lighthouse/aws/lighthouse-23.10.0.aws.raw.tar
Downloading image...

Image size is 54049899008 bytes (51 GiB)

Creating volume...

Attaching volume vol-09fb0b463f5a5%eaf to EC2 instance...
Cloning image onto volume...

0+852971 records in

0+852971 records out

54049899008 bytes (54 GB, 50 GiB) copied, 845.072 s, 64.0 MB/s
Creating snapshot of volume...

Waiting for snapshot snap-0£83746856d985070 to complete...
Creating AMI from snapshot snap-0£83746856d985070...

Done!

Cleaning up...

LIMITATIONS

AWS support is currently limited to:
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* All standard Lighthouse operations

* Running on the AWS platform

* Providing aws-cli tools for interaction with AWS

* Loading the provided SSH key for the root user

* Running custom scripts on startup (see above)

* Providing a root password via userdata (see above)
At this time Lighthouse does not support:

* Using AWS's database services

* Using AWS's redis services

» Using any of AWS's scalability functionality

Note:If you want to deploy Lighthouse across different AWS regions an AMI will
be needed in each region. Amazon supports copying AMIs between regions and

offers a walkthrough of the necessary steps to do this.

LAUNCH A LIGHTHOUSE INSTANCE ON AWS

Once the Lighthouse AMI has been created, it will display in the Amazon Machine

Images (AMls) section of the EC2 Management Console.

To create a new Lighthouse EC2 instance, select the Lighthouse AMI then "Launch

instance from AMI".

Instance Type

Lighthouse should run on a general purpose instance type, such as M5.

Installing Lighthouse


https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/CopyingAMIs.html#ami-copy-steps
https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/CopyingAMIs.html#ami-copy-steps

\ LIGHTHOUSE

Access Portal

Note:If an instance type that supports "burstable" CPU such as T2 is used,
please ensure that unlimited CPU is selected, to avoid operational problems
caused by CPU throttling.

Key Pair

EC2 requires a key pair to be specified when launching instances.

Network Settings
A security group should be created. Lighthouse requires some ports to be open:

* SSH (TCP/22) — Secure Shell. Access should be limited to just your corporate

network.

* HTTPS (TCP/443) — Lighthouse Web Ul and REST API. This is used by both web

browsers and nodes (eg, for call-home enroliment).

* OpenVPN (UDP/1194) — Lighthouse VPN. This is used to communicate with

nodes once they are enrolled.
* Other ports may need to be opened, depending on feature usage. For example
° SNMP (UDP/161) — SNMP Management
° OpenVPN (UDP/1195) — Lighthouse Multiple Instance VPN

° HTTPS (TCP/8443) — Alternate REST API port

Storage

By default, the root volume will be around 53 GiB. This may be sufficient, depending
on your intended usage. It is easier to specify more storage now, but more can be
added later.

Advanced Details

Installing Lighthouse



\ LIGHTHOUSE

Access Portal

An initial root password must be set in the UserData section.

password=topSecretPasswordl23

If the user does not specify the root password in the Advanced Details section they

can set the root password using the ogpasswd utility.

SET A PASSWORD FOR THE ROOT USER ON LIGHTHOUSE

If you are logged into Lighthouse via SSH keys, you will need to set root password to

login via GUI. Use the "ogpasswd" utility to do this.

ogpasswd -u root -p MySecretPassword

FINAL STEPS

When done, the EC2 Linux instance can be shut down and removed or saved for

creating future instances.

Note:The root password must be specified in the Advanced Details.

ADDING DISK SPACE TO LIGHTHOUSE

Additional physical volumes can be added to the volume group as required, and the
logical volumes extended using Ivextend and resize2fs to take advantage of the

additional space.

Before you add disk space:
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* Ensure you take a backup of Lighthouse

* In the case of a multiple instance Lighthouse installation, consider upgrading all

instances, not merely the primary instance.

ADDING A NEW DISK TO AWS

Launch a Lighthouse instance as per our guidelines or your own deployment

processes and note the instance ID.
To add a volume to an AWS Lighthouse without having to shut down the Lighthouse:

1. Inthe AWS web console, go to Volumes and create a new 50GB volume in the

same availability zone as your LH instance.

2. Once the volume is created, select it and click the Actions button and select
Attach Volume.

3. Enter the LH instance ID for the instance field and /dev/xvdb (or /dev/xvdd,

/dev/xvde and so on) as the device and click Attach.

When you SSH into the LH you should be able to see the new volume as

/dev/xvdb (or whatever device name you gave it).

ADDING A NEW DISK - QEMU SPECIFIC INSTRUCTIONS

Launch a gemu Lighthouse instance as per our guidelines or your own deployment.

To add a volume to the instance:

1. Shutdown the instance with the following command:

shutdown -h now
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2. Create a new disk for the LH. You can use a different number for “count” which is
in MiB.
dd if=/dev/zero of=/tmp/new lh disk.lh hdd bs=1024k
count=256
gemu-img convert -p -f raw -O gcow2 /tmp/new 1lh disk.lh

/tmp/new 1lh disk.gcow2

3. Restart your gemu instance but make sure to add the new gcow?2 disk to the
command.
Here is an example of what you should add to your gemu command when
launching the instance:

-drive if=scsi, file=/tmp/new 1lh disk.gcow2

Note:This is just an example. You should specify the disk in a similar way to
how you specified the primary Lighthouse disk. and you should make sure that
the new disk is specified last, otherwise your disk will appear out of order when

you boot the Lighthouse.

4. Once the LH boots you should have a new /dev/sdX device and the 'unused_

disks' command should report that disk when you log in.

ADDING A NEW DISK - AZURE

Launch the LVM Lighthouse instance as per our guidelines or your own deployment.

To add a volume to the instance, use the following link to attach a new disk to your
Lighthouse VM. Stop before you reach the section, "Connect to the Linux VM to

mount the new disk."

https://docs.microsoft.com/en-us/azure/virtual-machines/linux/attach-disk-portal
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ADDING A NEW DISK - HYPER-V

1. Launch the LVM Lighthouse instance as per our guidelines or your own

deployment. To add a volume to the instance:
2. Shutdown your Hyper-V Lighthouse instance.
3. Open your Hyper-V manager.
4. Navigate to the VM list and locate your Lighthouse VM.
5. Right click on the instance and click Settings.
6. Click on the SCSI controller.
7. Select Hard drive on the right and click Add.
8. Select Virtual hard disk and click New.

9. Follow the prompts and select the options that best suit your needs and

environment.
10. Once you've created the disk, click Apply in the VM settings window.

11. Restart the Lighthouse.

ADDING A NEW DISK - VIRTUALBOX

Launch the LVM Lighthouse instance as per our guidelines from the .ova file or

your own deployment. To add a volume to the instance:

1. Shutdown the Lighthouse instance.
2. Inthe VirtualBox Ul, locate your Lighthouse instance and right-click it.

3. Select Settings.
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Select Storage on the left.
Click the Controller: SCSI in the disk list.

You will see two small icons, both with a green '+' symbol. Hover your mouse over

the one that says Adds a hard disk and click it.

Click the Create icon.

. Follow the prompts to create a new disk image.

Select the new disk image and click the Choose button.
Click Ok to exit the VM settings window.

Restart Lighthouse.

INCREASE THE LH_DATA LOGICAL VOLUME

. Add the new disk to the LH VM (platform dependent, see above).

Log into the shell on Lighthouse. you should see the new "unused" disk listed in
the welcome message. This is the case for any non-system disks aren't currently

being used by the LVM system.

Create a partition on the new disk:
fdisk /dev/sdb (or /dev/xvdb, or /dev/ (sd|xvd)X
NOTE: Be sure specify the correct disk, it might be /dev/xvdb on AWS.

Type 'n"and ENTER to create a new partition.
Type 'p' and ENTER to create a primary parition.
Continue hitting ENTER to accept the defaults to use the whole disk.

Type 'w'and ENTER to write the changes and exit fdisk.
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8. Add the new partition as a physical volume (assuming you are now using
/dev/sdb1, note that

/dev/xvdbl will now be mapped to /dev/sdb1 so make sure you use sdb1).

pvcreate /dev/sdbl

9. Extend the volume group with the new physical volume.
vgextend lhvg /dev/sdbl

10. Assuming the new disk gives you at least 2GB of extra space, expand the 1h
data logical volume.
lvextend -L +2G /dev/mapper/lhvg-lh data

11. Update the file system of the |h_data disk to use the extra space.

resize2fs /dev/mapper/lhvg-1lh data

12. When you log into the shell, the disk should no longer be listed as "unused".

FIRST BOOT OF THE LIGHTHOUSE VM

Note: This section does not apply to Azure or AWS.

During boot, two screens open.

1. The first screen prompts to Select Lighthouse boot mode and displays four

options:

* Graphics console boot

» Graphics console recovery mode
 Serial console boot

» Serial console recovery mode
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Graphics console boot is preselected and should not be changed. After

the first boot has completed a message displays:

Welcome to Lighthouse. This is software version:

2023.10.0

. The final step in the initial setup displays:

To complete initial setup, please set a new root password.

Press ENTER to continue.

. After pressing Enter, a prompt displays:

Enter new root password:

. Enter a password and press Enter. Keep in mind that non-US-English keyboards

are not supported in the graphics console.

Note: It is recommended that you set a temporary password at this
point and change it to a very strong high-entropy password as soon
as possible using the WebUI.

. The confirm prompt displays:

Confirm given password

. Re-enter the password and press Enter. Multiple configuration notices appear

ending with a login prompt:

lighthouse login:
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7. Enterroot and press Enter. A password prompt displays:

Password:

8. Enter the newly-set password and press Enter. A standard bash shell prompt

displays with the list of static, DHCP, and IPv6 addresses.

netl 192.168.0.1/24
netl:dhcp 192.168.1.186/24
netl fe80::a00:27ff:fe39:daa3/64

root@lighthouse:~#
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SETTING UP LIGHTHOUSE

This section describes how to set up Lighthouse to monitor and manage your

network.

LOADING LIGHTHOUSE

This section describes the initial setup stages for a new Lighthouse VM, from login,

to setting external addresses, to setting the clock.

TO LOAD LIGHTHOUSE

1. Open a new browser window or tab, then enter one of the following:

https://192.168.0.1/

https://[DHCP-supplied address]/

or an IPv6 address, for example:

https://[fe80::a00:27ff:fe39:daa3/64].

2. Press Return. The Lighthouse Login page loads. A warning message displays
because of the default self- signed certificate. You can ignore this at first load,
and later install your own valid certificate using SETTINGS > SERVICES

>HTTPS Certificate to remove the warning message.
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LIGHTHOUSE IP ADDRESSES

When the Lighthouse VM is booted and running, it can be reached at:
¢ The static address, 192.168.0.1, or

* The address it is assigned by any DHCP server it finds. Type ifconfig command
to see which IP address the VM has been allocated by DHCP.

» Static IP address on another subnet, requiring IP address, mask, gateway.

Only the first two options are available out-of-the-box. The static IP on another

subnet has to be configured first.

If there is no DHCP, and Lighthouse is not reachable on the default address
192.168.0.1 then, the static IPv4 address can be changed from the console using

the ogsetnetwork.sh command.

root@lighthouse:~# ogsetnetwork.sh --help

Usage:

ogsetnetwork.sh [Use options below to configure a static IP]

-a, —-—-address Static IP address to set
-n, —--netmask Netmask for IP address
-g, —-—-gateway Network gateway address
-d, --dnsl Chosen DNS server #1

-D, --dns2 Chosen DNS #2

Example:
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ogsetnetwork.sh -a 192.168.1.24 -n 255.255.255.0 -g 192.168.1.1

Tip: Type ogset<tab> and tab completion will give you the full command.

LOGGING INTO LIGHTHOUSE

To login to Lighthouse:
1. Enter a username in the Username field. The first time you log in, the username
will be root.

2. Enter the password in the Password field. See "First Boot of the Lighthouse VM"

on page 61 for more information.

3. Click Log In or press Enter. The Lighthouse Dashboard loads.

When you log in, the standard Lighthouse menus, options and panes display:
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\, LIGHTHOUSE & Feedback @ AddMode @ Systern and Subscriptions @ He lp Bl Logout

22.10.0p0

) nad DASHBOARD

CURRENT NODE STATUS CELLULAR HEALTH STATUS

= MANAGE

[2] conFIGURE

(5 SETTINGS

ENROLLED NODES

{

* The primary menu options - MONITOR, MANAGE, CONFIGURE, and
SETTINGS

» Alight/dark mode toggle on the bottom left of the interface. This control allows

you to modify the appearance of the dashboard for low light situations.

* System menu options Add Node, Help, System & Subscriptions, and Log Out

on the header.

* Various panes - some column headings have Arrow Icons next to them. Click to

toggle between ascending and descending order.
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Note:The elements that appear on the Dashboard page depend on the
privileges granted to the currently logged in user. In this guide, screenshots

represent what the root user sees.

For root users, the Dashboard displays the following panes; Enrolled Nodes,

Cellular Health Status, and Current Node Status.

Click Cellular Health to go to MANAGE > NODES > Node Web Ul page where you

can view the Cellular Health column with information on each node.
Note:The Cellular Health only displays if Cellular Health reporting is enabled.

Click Current Node Status to go to the appropriate page, that is, Connected,

Disconnected, or Pending Node pages.

SETTING THE LIGHTHOUSE HOSTNAME

To set the hostname for a running Lighthouse instance:

1. Select SETTINGS > SYSTEM > Administration.

2. Edit the Hostname field as desired. Hostnames must follow the naming

conventions
* ASCII alphanumerical characters plus - and .

¢ Maximum 64 characters
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%J%l‘é;]l‘lDUSE Feedback @ AddNode (D System and Subscriptions @ Help & Logout

SECURE PROVISIONING ADMINISTRATION

IP ACCESS
Hostname &

P SETTINGS lighthouse

NETWORK CONMECTIONS SSH Port @
USER MANAGEMENT -
MNOTIFICATIONS
SE ES

DATE & TIME ORDER ADDRESS APIFORT VPN PORT

SYSTEM

- ' 197.1RB.7E4.140) 443 1195 -
Administration + 92.168.254.140 443 Q4 g

Factory Reset

@ Add External Network Address

3. Click Apply.

ADDING EXTERNAL IP ADDRESSES MANUALLY

Adding a Lighthouse instance’s external IP address or addresses manually to a
Lighthouse instance’s configuration is an optional step. In general, these should not
be changed expect by a network support engineer. For more information on the

network ports used by Lighthouse, see this link on the network architecture.
Note:IP addresses can be IPv4, IPv6 or DNS names.

To add a single external address:
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1. Select SETTINGS > SYSTEM > Administration.

, LIGHTHOUSE -
\ 22.10.0p0 & Feedback

ADMINISTRATION

SECURE PROVISIONING

IP ACCESS
Hostname 3

<P SETTINGS lighthouse
NETWORK CONNECTIONS SSHPort @

USER MANAGEMENT

® AddNode (@ System and Subscriptions @ Help & Logout

MNOTIFICATIONS

EXTERNAL NETWORK ADDRESSES

SERVICES
DATE & TIME ORDER ADDRESS

SYSTEM

Administration 92.168.254.140

@ Add External Network Address

MULTI-

Apply

2. Inthe Address field of the External Network Addresses section, enter an IP

address or DNS name.

3. Change the API Port, VPN Port, or Multi-Instance VPN Port if the ports used

on the entered IP address are different from the default settings.

4. Click Apply.

To add further external addresses to a Lighthouse instance’s configuration:

1. Click the + button. A second row displays in the External Network Addresses

section.
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2. Inthe Address field, enter an IP address.

3. Change the API Port, VPN Port, or Multi-Instance VPN Port if the ports used

on the entered IP address are different from the default settings.

4. Click Apply.

To change the order in which manually added IP addresses are sent to remote

nodes:

1. Click the up and down arrows in the Order column to change the order in which

the IP addresses are listed.

2. Click Apply.

If external IP addresses are manually added to a Lighthouse configuration, these
addresses are sent to a remote node during enroliment. If no external IP address is

manually added, default external IP addresses are used.

The external IP addresses are sent to a remote node during Enrollment in the order

configured on the SETTINGS > System > Administration page.

THE LIGHTHOUSE SSL CERTIFICATE

Lighthouse ships with a private SSL Certificate that encrypts communications
between it and the browser. Most browsers will display a warning message when

first trying to access Lighthouse.
Note:If you plan to use the Lighthouse multiple instance feature, the
certificate will be used on all instances. In this case, we recommend using a

wildcard certificate.

To examine this certificate or generate a new Certificate Signing Request:
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1. Select SETTINGS > SERVICES > HTTPS Certificate. The details of the
Current SSL Certificate appear.

2. Below this listing is a Certificate Signing Request form, which can be used to

generate a new SSL certificate.

SET THE LIGHTHOUSE INTERNAL CLOCK

Lighthouse and Node system times need to be in sync. Enroliment can fail if there is
a significant difference between the Lighthouse and the node. It is recommended

that you use an NTP server to automatically manage date and time.

If using multiple instances, configure the time zone for the secondary instances
before adding them as secondary instance. The only way to change the time zone

after adding a secondary instance is to use the CLI.

To set the time zone:

1. Select SETTINGS > DATE & TIME > Time Zone.

2. Select the Lighthouse instance’s time-zone from the Time Zone drop-down list.
3. Click Apply.

Set time automatically

It is highly recommended that you use an NTP Server to automatically manage date

and time:
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1. Select SETTINGS > DATE & TIME > Automatic Settings.

% Il-'l %FEIIIIJHDUSE B Feedback @ AddMNode (D System and Subscriptions (@ Help B Logout

AUTOMATIC SETTINGS

NTP SETTINGS

=

REMOTE NTP SERVER LIST

Apply

DATE & TIHE

2. Click the Enabled checkbox.
3. Click on + Add Server.
4. Enter a working NTP Server address in the NTP Server Address field.

5. Click Apply.

SETTING UP NETWORKING REQUIREMENTS

This section outlines the basic steps to setup networking requirements for

Lighthouse including:

* Lighthouse Session Settings
* MTU of the Lighthouse VPN tunnel

¢ Network connection
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* SNMP Manager Settings
* SNMP Service
* Cellular Health Settings

* Lighthouse MIBs

EXAMINE OR MODIFY THE LIGHTHOUSE SESSIONS

To modify Web and CLI session settings select SETTINGS > SERVICES > Session
Settings.

« Web Session Timeout: This value can be set from 1 to 1440 minutes.

* CLI Session Timeout: This value can be set from 1 to 1440 minutes or setitto 0
to disable the timeout. Changes take effect the next time a user logs in via the
CLL.

* Enable additional Enroliment-only REST API port: This port defaults to 8443.
Enabling this API allows users who are using NAT for the Lighthouse to expose
an external port publicly only for nodes that are attempting to enroll to the
Lighthouse, and not for the other functionality available from the REST API. After

this option is disabled, all endpoints should be accessible as per normal usage.

EXAMINE OR CHANGE THE MTU OF THE LIGHTHOUSE
VPN TUNNEL

The Maximum Transmission Unit (MTU) setting can be configured for traffic

through the Lighthouse VPN in an attempt to solve MTU path discovery problems.
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The maximum transmission unit (MTU) is the size, in bytes, of the largest packet

supported by a network layer protocol, including both headers and data.

To modify the MTU of the Lighthouse VPN tunnel select SETTINGS > SERVICES >
Lighthouse VPN.

Allowed values are between 1280 and 1500.

\_ ,L-ﬂl %‘j‘]—;'DUSE & Feedback & Add Node (@ System and Subscriptions @ Help & Log out
22.10.0p!

LIGHTHOUSE VPN

N
NETWORK CONNECTIONS

To see the network connections available to Lighthouse:
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1. Select SETTINGS > NETWORK CONNECTIONS > Network Interfaces.

(&) moNmor NETWORK INTERFACES

2 MANAGE

A Editing these settings may break connectivity

CONFIGURE

NAME < TYPE STATUS DETAILS
9 serTines
N ; Enabled and Pv4 Static s
NETWORK CONNECTIONS default-conn- Ethernet . o e /
unning 192.168.0.1/24
Network Interfaces . _ Enabled and Pv4 DHCP s
default-conn-2 Ethernet K . . 4
running 172.31.10.76/20
USERMANAGEMENT
R Enabled and PvB Automatic 5
default-conn-3 Ethernet ) i 4
starting Unavailable

SERVICES

2. The Details column displays connections of three types:
a. Static interfaces
b. DHCP IPv4 interfaces and by default,
c. An automatic IPv6 connection.

3. Click the Editicon to view the status and change the connection details such as

the following on the Static interfaces:
* IPv4 Address
* [Pv4 network Mask

* Gateway

Primary DNS Server

Secondary DNS Server

Note:Editing the network settings may break connectivity.

Setting up Lighthouse



\ LIGHTHOUSE

Access Portal
EDIT A NETWORK INTERFACE
1. Select SETTINGS > NETWORK CONNECTIONS > Network Interfaces.
2. Click the Edit icon to the right of the network interface to be modified.
3. Make the desired changes.

4. Click Apply.

% ..LJ GHTHDUSE Feedback @ AddMode (D System and Subscriptions (D Help B Log out

Y NETWORK INTERFACES

<P SETTINGS

MNETWORK CONMNECTIONS PvE Autamatic
P — T Et T E | P fd0T:2218: 1350 fe: 200 Fa

Note:Do not change the Connection Type of default network interfaces. If a
default interface is not required, edit the interface and uncheck the Enabled
checkbox.

Instead, disable the interface which will not be used by unchecking the Enabled
checkbox. If default-static and default-DHCP are changed to the same
configuration method (that is, if both are set to Static assignment or both are

set to DHCP) neither interface works.

Setting up Lighthouse



\ LIGHTHOUSE

Access Portal

CONFIGURE SNMP MANAGER SETTINGS

Administrative users can configure the Simple Network Management Protocol
(SNMP) Manager settings. The SNMP Manager allows SNMP TRAP/INFORM
messages to be sent from Lighthouse to a configured server any time a node

connection status is changed.
To enable the SNMP Manager:

1. Select SETTINGS > SERVICES > SNMP Manager.

“ SNMP MANAGER

Console Gateway
HTTPS Certificate SETTINGS

Enable @

Manager Protocol @

TCP -
Manager Address @
Node Firmware Upgrade
Routed Management Fabric Manager Port ®
162
Version ®

vl

SNMP V1&V2C
DATE & TIME

Community &

o am

2. Under the Settings section, select the Enable checkbox.
3. Inthe Manager Protocol, select UDP, or UDP over IPv6, TCP, or TCP over IPv6.

4. Enter the Manager Address to receive SNMP messages.
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5. Enter the Manager Port.

6. From the SNMP protocol Version select v1 or v2c or v3.
Depending on the selected SNMP Version, complete the following steps.
For v1, enter the SNMP Community to use for messages.
For v2c:
1. Select TRAP or INFORM as the SNMP Message Type.
2. Enter the SNMP Community to use for messages.
For v3:
1. Choose TRAP or INFORM as the SNMP Message Type.

2. Specify an optional Engine ID for sending an SNMP TRAP message. If left blank,
the auto-generated Engine ID from the SNMP Service will be used. An Engine ID is
not needed for an SNMP INFORM message.

3. Enter the SNMP v3 Engine ID and desired Configure SNMP Manager Settings.

4. Enter the Username to send the messages as, select the Authentication
Protocol, either MD5 or SHA, and enter the SNMP user’s Authentication

Password.
5. Choose a Privacy Protocol, either DES or AES, and enter a Privacy Password.

For all three SNMP versions, trigger TRAP/INFORM notifications by checking either
or both of the Node Connection Status and the Node Cellular Heath Status
checkboxes. Click Apply.

When a node connection status changes, a nodeStatusNotif notification is sent,

populated with data about the node's connection status, address and name.
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For information on Structure of notifications for Opengear nodes, refer to OG-
LIGHTHOUSE-MIB.mib.

EXAMINE OR MODIFY SNMP SERVICE

Administrative users can configure SNMP settings under SETTINGS > SERVICES
> SNMP Service.

Lighthouse supports both v1/v2 and v3 SNMP versions, which can be running at the
same time. The SNMP service is not enabled by default. The SNMP service starts
after it has been configured correctly. If the user does not provide an Engine ID, an
auto-generated ID displays. Lighthouse Health statistics (load/uptime/memory

usage, etc.) can be retrieved.

% LI E'EJF,!JI‘_'DUSE & Feedback @ Add Mode (D System and Subscriptions @ Help B Log out
NOTIFICATIDNS

SNMP SERVICE

SERVICES

(=]

SNMPVI& V2C
DATE & TIME
To enable SNMP Service:
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1. Select the Enable checkbox.
2. Choose from the v1/v2c and v3 checkboxes.
3. Fillin the appropriate information for the SNMP versions.

4. Click Apply.

CELLULAR HEALTH SETTINGS

Administrative users can control the cellular health reporting settings under
SETTINGS > SERVICES > Cellular Health Reporting.

CELLULAR HEALTH REPORTING

When cell health checks are enabled, the network carrier, IMEI, IMSI| and ICCID of
the downstream SIM being utilized are part of the information that is displayed in

Lighthouse for managed nodes

If a managed node has the modem disabled/off, an appropriate status is shown in
Lighthouse for the node.

* Check the Enable box to enable Cellular Health monitoring.

* Ifrequired, adjust the signal quality ranges corresponding to Good, Bad, and
Moderate. This will change the Cellular Health information displayed in various

node lists and on the Dashboard.
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* Adjust how frequently Lighthouse will check the signal quality.

* Finally, you can run a periodic Cellular Connectivity Test which will make sure

the cellular can actually connect. This will use cellular data.

CELLULAR HEALTH DASHBOARD

The current health status of enrolled nodes can be viewed from the Cellular Health
Dashboard: MONITOR > Dashboard. Click on a segment of interest to open the
Node Web Ul page which displays Node health information:
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DASHEOARD

CURRENT NODE STATUS

ENROLLED NODES

CELLULAR HEALTH STATUS

LIGHTHOUSE MIBS

Lighthouse management information bases (MIBs) can be found in

lusr/share/snmp/mibs/.
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Lighthouse can be configured to expose managed node information such as node
name, node model number, node port label, license status, etc. via SNMP. The MIBs

turn the SNMP data into text, that is more readable to human readers.

Some generic information about Lighthouse version and nodes count can be found

at:

ogLhVersion
ogLhMNodes
ogLhNodesTotal
ogLhMNodesPending
ogLhNodesConnected
oglLhNodesDisconnected
ogLhNodesTable with detailed information about nodes.

Available information for an enrolled Opengear node

ogLhNodesTable:

ogLhMNodelndex
ogLhNodeName
ogLhNodeModel
ogLhNodeProductType
ogLhMNodeVpnAddress
ogLhNodeSerialNumber
ogLhMNodeUptime
ogLhNodeConnStatus

ogLhNodePortsTable:
ogLhPortindex
ogLhPortLabel
ogLhPortlD

ogLhNodelnterfacesTable:
ogLhNodelnterfacelndex
ogLhNodelnterfaceName
ogLhNodelnterfaceAddress

Available information for an enrolled third-party node
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ogLhThirdPartyNodesTable:

ogLhThirdPartyNodelndex
ogLhThirdPartyNodeSSHPort
ogLhThirdPartyNodeName
ogLhThirdPartyNodeModel
ogLhThirdPartyNModeProductType
ogLhThirdPartyModeAddress
ogLhThirdPartyNodeSerialNumber
ogLhThirdPartyNodelUptime
ogLhThirdPartyNodeConnStatus

ogLhThirdPartyNodePortsTable:
ohLhThirdPartyPortindex
ogLhThirdPartyPortLabel
ogLhThirdPartyPortConnectionMethod
ogLhThirdPartyPortMode
ogLhThirdPartyRemotePort
ogLhThirdPartyPortLinelD

To query licensing information:
oglLhLicenseStatus:
oglLhLiclnstalled
oglLhLicSupported
ogLhLicExpiry
oglLhLicStatus
ogLhLicFeatureName

To query enrolled node cellular health information:

ogLhNodeCellularHealth

SNMP commands such as snmpwalk or snmpgetretrieve Lighthouse specific

information.
Setup: SNMP is configured with version 1 and public is community string
Lighthouse public IP address is 192.168.1.1

All MIBs, including Lighthouse MIB are available in /lusr/share/snmp/mibs
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EXAMPLES OF LIGHTHOUSE MIB QUERIES USING SNMP:

Walk through the entire ogLighthouseMib using name:

snmpwalk -m ALL -vl1 -c public 192.168.1.1 ogLighthouseMib
snmpwalk -m ALL -M /usr/share/snmp/mibs -vl -c public 192.168.1.1

ogLighthouseMib

Walk through the entire ogLighthouseMib using the OID directly:

snmpwalk -m ALL -M /usr/share/snmp/mibs -vl -c public 192.168.1.1

1.3.6.1.4.1.25049.18.1

Get the total nodes enrolled in Lighthouse:

snmpget -m ALL -vl -c public 192.168.1.1 ogLhNodesTotal.O

snmpwalk -m ALL -vl -c public 192.168.1.1 ogLhNodesTotal

Get serial number with enrolled node having VPN address 192.168.128.2:

snmpwalk -m ALL -vl1 -c public 192.168.1.1
ogLhNodeSerialNumber.192.168.128.2
snmpget -m ALL -vl -c public 192.168.1.1

ogLhNodeSerialNumber.192.168.128.2

Get cellular health for all enrolled nodes:

snmpwalk -m ALL -c public -v 1 192.168.124.143 ogLhNodeCellularHealth
OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.2 = INTEGER:
good (4)

OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.3 = INTEGER:
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good (4)

OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.4 = INTEGER:

bad (2)

OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.5 = INTEGER:
unknown (0)

OG-LIGHTHOUSE-MIB: :ogLhNodeCellularHealth.192.168.128.6 = INTEGER:

bad (2)

SETTING UP MULTIPLE INSTANCES OF
LIGHTHOUSE

This chapter discusses the licensing, setup, configuration, promoting and
disconnecting of secondary instances, and upgrading of a multiple instance

Lighthouse.
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Enrolled Node
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—» Lighthouse VPN (OpenVPN) Enrolled Node

Lighthouse Multi-Instance
(OpenVPN) S
—

Enrolled Node

The multiple instance functionality allows you to set up secondary or dependent
instances of Lighthouse that automatically receive updates from a primary

Lighthouse instance and maintains connections to all its remote nodes.

Secondary instances are read-only. They may be used to view Lighthouse
information specific to that instance using ogconfig-cli, and to connect via

pmshell.

Configuration changes must be performed on the primary instance, which will then
update the information displayed on the secondary instance. For more details, see

Lighthouse Architecture in "Lighthouse Overview" on page 19
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SETTING UP A MULTIPLE INSTANCE

Lighthouse supports up to 10 secondary instances for each primary Lighthouse

instance. A secondary instance is also known as a dependent instance.
Before you attempt to set up a multiple instance:

» Start with what will be the primary instance and one or more Lighthouse
instances to act as secondary. All instances must have the same version of

Lighthouse.

» Configure the networking information for each instance (hostname, external

endpoints, network addresses, REST API port).
» Configure the time settings of each instance.
* Ensure you have a subscription active on your primary Lighthouse.
To set up a multiple instance feature on the primary Lighthouse:

1. On the primary Lighthouse, click Configure > MULTIPLE INSTANCE >

Dependent Lighthouse Instances.

B manace v DEPENDENT LIGHTHOUSE INSTANCES

CONFIGURE

@ c

DESCRIPTION HOSTNAME v STATUS DETAILS

CONFIGURATION TEMPLATING

MULTIPLE INSTANCE
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2. Click Add. Enter the following details of a Lighthouse instance to enroll it as a
secondary instance:
Description
Network address
Network port
Username
Password
In the VPN Network Range enter a valid, unused network subnet to use as the
dependent Ihvpn address range. See "Configuring Subnets for a Multiple

Instance Lighthouse" on page 92.

Q UsHTHoUSE 8 Focdiock  © AddNode System and Subscrptions @ Holp 8 Log ot

NEW DEPENDENT LIGHTHOUSE

HULTIPLE INSTANCE

Note:The secondary Lighthouse instance must be able to reach the primary
instance on UDP Port 1195.
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3.
4. Click Apply.

5. Dependent Lighthouse Enrollment displays status as it moves from Pending >

Registered > Enrolled.

6. When the VPN connection is established between primary and secondary
Lighthouse, this page will display Connected with the time since the last status
change and Disconnected when the connection is lost. Any errors in the

Enrollment process will display in the status column.

ENABLING ALTERNATE REST API PORTS

If you are planning to use the alternate REST API ports, you will need to make sure
this option is enabled on both the primary and dependent Lighthouse servers, prior
to Enrollment of the dependent(s). Lighthouse will prevent the Enroliment of a
dependent Lighthouse instance if there is a mismatch in these settings. If this
occurs, the message "Lighthouse is using Alternate API port" will be displayed on

the Dependent Lighthouse Instances page.
To fix the issue, either

* Enable the Alternate REST API port on both Lighthouse servers, or

» Disable the Alternate REST API port on both Lighthouse servers, then delete the

failed Lighthouse Enroliment and try again.
The Alternate REST API Port is configured as follows:

1. Select Settings > Services > Session Settings. The page displays:
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@ System and Subscriptions @ Help @ Logout

% LIGHTHOUSE B Feedback  ® Add Node

22.10.0p0
SESSION SETTINGS

v O
A

Apply

2. Select Enable additional enroliment-only REST API port.

Note:The alternate REST API Port for enrollment is 8443

CONFIGURING SUBNETS FOR A MULTIPLE INSTANCE
LIGHTHOUSE

A Lighthouse with multiple instance support requires multiple separate subnets for

Lighthouse VPN connections:

¢ Between each instance and its nodes

* Between the primary and dependent Lighthouses.

Note:Each subnet must not overlap any subnet in use by another

Lighthouse instance.

CONFIGURING THE SUBNETS

To configure the subnet between the primary Lighthouse and its nodes:
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1. Select SETTINGS > SERVICES > Lighthouse VPN on the primary Lighthouse.

B manace

LIGHTHOUSE VPN
CONFIGURE

A Editing these settings will interrupt node connections, it may take a few minutes for them to be restored
" serTings
NETWORK CONNECTIONS VPN Network Range
ADDRESS SPACE CIDR SUBNET MASK CALCULATED NODE CAPACITY
USERMANAGEMENT
SERVICES 192.168.128.0 9 8180
Cellular Health Reporting Tunnel MTU @
1400
Routed Management Fabric Network Range
ADDRESS SPACE CIDR SUBNET MASK
10.0.0.0 19

Apply

2. Enter the Address Space and CIDR Subnet Mask. The Calculated Node

capacity displays the addressable nodes based on the network.

Note:A secondary Lighthouse is read-only and cannot be modified. The
SETTINGS > SERVICES > Lighthouse VPN page displays the subnet used by

this Lighthouse instance, but it cannot be modified directly.

3. To configure the subnet between each secondary Lighthouse and its nodes

select CONFIGURE > MULTIPLE INSTANCE > Dependent Lighthouse
Instances.
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4. The Dependent Instances page displays. Click on the name of the dependent

Lighthouse to be modified.

(@) moNiToR

-5 manace
S CONFIGURE

NROLLMENT

MULTIPLE INSTANCE

() Honmor

5 MANAGE

(=] coNFIGURE

NODE OLLMENT

MULTIPLE INSTANCE

@ e

DEPENDENT LIGHTHOUSE INSTANCES

EDIT DEPENDENT LIGHTHOUSE
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Other information that is specific to dependent Lighthouse should be configured
before enrolling but can be modified on the primary Lighthouse via ogconfig-
cli.

Instance specific information includes:

Hostname

Time zone

Networking

External interfaces

The instance specific information is available on both the primary and secondary

Lighthouses but it is read-only on the secondary Lighthouse.

Configurations of all Lighthouse instances are stored in 1ighthouse

configurations.

These can be viewed via ogconfig-cli. The primary instance will have a value

of Primary forits role, and dependent instances have the value Secondary.

The following is an example of the ogconfig-c1i session:

. root@lighthouse:~# ogconfig-cliogcfg> print lighthouse con-
figurations[0].rolelighthouse configurations[0O].role (string):
'Primary'ogcfg> print lighthouse configurations[l].rolelight-

house configurations[0].role (string): 'Secondary'

Alternatively, the command /usr/bin/is secondary will outputn fora

primary Lighthouse or y for a secondary.

. You can modify the configuration of secondary lighthouses from the primary
Lighthouse. For example, to update the hostname of the secondary Lighthouse,

run the following commands on the primary Lighthouse:
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ogconfig-cli

set lighthouse configurations[l].hostname new name

push

DISCONNECTING A DEPENDENT INSTANCE

To disconnect dependent Lighthouse instances from the primary Lighthouse:

Instances, and click the instance name.

right of the page.

NODE ENROLLMENT EDIT DEPENDENT LIGHTHOUSE
Edit T
Description
byronbay

DEPENDENT LIGHTHOUSE VPN
CONFIGURATION TEMPLATING

MULTIPLE INSTANCE

Dependent Lighthouse 192.168.92.0 24 254
Instances

The range for VPN tunnels between the dependent Lighthouse and nodes
A Warning: Editing these settings may break the connectivity between dependent Lighthouse and nodes
AUTOMATION GATEWAY

DEVICE PROVISIONING

o o

ADDRESS SPACE CIDR SUBNET MASK CALCULATED NODE CAPACITY

ACTIONS

Click CONFIGURE > MULTIPLE INSTANCE > Dependent Lighthouse

The dependent Lighthouse displays. Click the Unenrol Instance icon in the top

# Unenroll Instance

3. Click Yes in the message that asks you to confirm.

4. You must manually remove the connection to the dependent Lighthouse from

each connected node. Click the Delete link in the Console Server.
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PROMOTING A DEPENDENT INSTANCE

When a primary Lighthouse is no longer reachable, a dependent Lighthouse
instance can be promoted to primary. The new primary can then be used to setup a

dependent Lighthouse if required.

Note:This should only be performed if the primary Lighthouse has no chance of
returning, the procedure is not reversible and will break all node connections
with the previous primary instance. The previous primary instance must be

factory reset before it can be used again.

To promote a dependent instance to primary, login as root on the secondary

instance via console or ssh and run

promote-secondary-lighthouse

Remove all dead connections from node side using the node's web Ul. The
Promotion tool deletes connection between primary and dependent instance but

does not touch node connections.

The new primary can then be used to enroll a dependent Lighthouse if required.

Note:If the previous primary becomes accessible again, it will not be able to

connect to its enrolled nodes or the previous secondary Lighthouses.

* All scheduled firmware upgrades are cancelled in the event of a dependent

Lighthouse promotion, and will need to be rescheduled.

* Firmware files are not replicated among the multiple instance cluster and must be

re-uploaded to the new primary after promotion.
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UPGRADING A MULTIPLE INSTANCE LIGHTHOUSE

Lighthouse must be upgraded in succession. For example, to upgrade to a version
that is several releases newer than your current release, you will need to install all

the major releases in between to install the newest one.

Before a multiple instance upgrade is attempted, compatibility and status checks are

performed on primary/secondary instances to pre-empt possible failure points.

Secondary Lighthouse upgrades are performed in parallel (not in a queue) to speed

up the overall process of rolling upgrades.

Where there are multiple instances of Lighthouse, when a system upgrade is being
performed the status of dependent instances is flagged in the System Upgrade
page.

When the primary Lighthouse is updated, any secondary Lighthouses will be

updated in a rolling fashion after the primary has successfully booted. If any

Lighthouse fails to successfully update along the way, the update will stop.
UPGRADING DEPENDENT MULTIPLE INSTANCES OF LIGHTHOUSE
To upgrade a Multiple Instance Lighthouse:

When the primary Lighthouse is upgraded any secondary Lighthouses will be
upgraded in a rolling fashion after the primary has successfully booted. If any

Lighthouse fails to successfully upgrade along the way, the upgrade will stop.

Click the Dependent Lighthouses link (red text) to view the upgrade process status
for dependent Lighthouse nodes. Click View Job Details link to see details of the

update progress and any problems.
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MULTI_INSTANCE DEPENDENT UPGRADER

A_Ptndlnq JOB INFO

13 minutes 11 seconds
No nodes associated with this ||nt:

2021-01-20T00:58:03 (Z

_ N

SysSIEm

During a system upgrade, notification/status elements are flagged in the following

scenarios:

* When an upgrade is attempted, a pass/fail notification on the instance.

* When an upgrade is attempted on a secondary instance, a pass/fail notification

on the associated primary instance.

Information about the upgrade progress and status is visible in the Lighthouse Jobs

page.

UPGRADING LIGHTHOUSE

Lighthouse can be upgraded usinga .1h upgimage file. Note the following

conditions:

* AWS requires .aws.1lh upg and Microsoft Azure requires .azure.lh upg.All

other platforms use the standard .Ih_upg file.

* Incremental upgrades to Lighthouse using 1h upg files are only supported from

20.Q3.x and not earlier releases.

Note: Upgrades do not overwrite existing configurations or user files, however it is recom-
mended that you perform a Configuration Backup before you upgrade a Lighthouse.
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After the upgrade is complete, the Lighthouse instance reboots. It is unavailable

during the reboot process.
About the Upgrade Process
Lighthouse performs the following high-level steps to upgrade to the new version

1. Validates the upgrade image, and takes a backup of the current root filesystem

and snapshot of data volume
2. Reboots into the new root filesystem (from the upgrade image)
3. Performs data migrations and system re-configurations
4. Commits the changes on success, or reverts on failure

5. For Multiple Instance only, after a successful Primary upgrade: After a 10 minute

delay, secondary instances are automatically upgraded in sequence.

Lighthouse uses LVM snapshots to manage storage during upgrade and data
migration. If a failure occurs, the snapshot is used to revert the system to its

previous state.

PREPARE TO UPGRADE LIGHTHOUSE

While upgrading Lighthouse is a simple process, the following tasks are best

practices to ensure a successful upgrade.

* Read the release notes, in particular any known issues or special requirements

for the new version
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Provide a sufficiently large maintenance window to start and complete the
upgrade. Larger networks and more complex configurations will take more time.

You canrun g-stat to check the job queue status.

Download the correct upgrade image.

The current release can be found here: Opengear FTP
Archived releases are available here: Archives Opengear FTP

Verify the image integrity by checking against SHASUMS. For example, on Linux
$ shalsum lighthouse-23.10.0.1lh upg
0£52c30a212566030a1742b6e3d5bf9316d89%abd lighthouse-
23.10.0.1h upg

Before starting the upgrade, generate a Technical Support Report. This can

assist Opengear support with diagnosing upgrade issues.

Use the df command to display disk usage by filesystem.
root@lighthouse:~# df /mnt/data/

Ensure that you have enough disk space in /mnt/data. If you have less than
20% disk space available, clean up unnecessary files, or add disk space (see
"Adding Disk Space to Lighthouse" on page 56). If disk space is added to the

primary instance, add additional space all secondary instances also.

Take a Configuration Backup on the Primary Lighthouse. This can be used to

restore the system in the event of failure during upgrade.

Do not make any configuration changes during the upgrade process (includes

secondary upgrades).

Consider taking a Virtual Machine backup. If the Lighthouse storage has been
increased (by adding additional physical volumes to LVM) then these must be

included in the backup, and all storage volumes must be in sync.
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* You can also consider running some technical checks before starting the upgrade
to check job queues, memory, temporary filesystem (tmpfs), database integrity,

and multiple instance status.

UPGRADING THE SYSTEM FROM WITHIN LIGHTHOUSE

Lighthouse must be upgraded in succession. For example, to upgrade to a version
that is several releases newer than your current release, you will need to install all
the major releases in between to install the newest one. If you are running a Multiple
Instance Lighthouse cluster, the upgrade must be performed through the Primary
Lighthouse instance. After the upgrade is complete, the Lighthouse instance reboots

automatically. Lighthouse is unavailable during the reboot process.
To upgrade a Lighthouse instance’s system using the Lighthouse Ul:

1. Select SETTINGS > SYSTEM > System Upgrade.
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2. Select the Upgrade Method, either Fetch image from HTTP/HTTPS Server or
Upload Image.

\- !-J%I'AR:{DUSE Feedback @ AddMode @ System and Subscriptions @ Help & Logout

SYSTEM UPGRADE

P ACCESS

P SETTINGS ® Remember to perform a system snapshot using the system hyper

-

Fetchimage from HTTP/HTTPS Server

DATE & TIME

SYSTEM
ADVANCED OPTIONS

2

L Perform Upgrade

3. Ifupgrading via Fetch image from HTTP/HTTPS Server:

a. Enterthe URL for the system image in the Image URL text-entry field.

b. Click Perform Upgrade.

4. Orifupgrading via Upload Image:
a. Click the Choose file button.

b. Navigate to the directory containing the appropriate upgrade image file.
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c. Selectthe upgrade image file and press Return.

d. Click Perform Upgrade.

The Advanced Options section, which expands to present an Upgrade Options
text-entry field, should only be used if a system upgrade is being performed as part

of an Opengear Support call.

Once the upgrade has started, the System Upgrade page displays feedback as to

the state of the process.

A system upgrade attempt returns the error System version was not higher than
the current version if the selected image file is not a more recent version than the

installed version.

UPGRADING THE LIGHTHOUSE SYSTEM VIA THE LOCAL
TERMINAL

Lighthouse includes a shell-based tool — sysflash — that allows a user with

administrative privileges to upgrade the instance’s system from the local terminal.

Note:Before using sysflash, we recommend that you check available disk
space when manually uploading . 1h upgrade files. We also suggest you use

/mnt/nvram as the path.

To upgrade Lighthouse instance’s system using the Lighthouse local terminal:
1. Select MANAGE > LIGHTHOUSE > local terminal.

2. Atthe [hostname] login: prompt, enter an administrator username and

press Return.
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3. Atthe password: prompt, enter the administrator’s password and press
Return.

4. Touse sysflashwitha .1h upgfile available viaan HTTP or HTTP server:
At the local terminal bash shell prompt, enter a URL. It must be URL-encoded:
sysflash http[s]%$3A%2F%2Fdomain.tld%2Fpath%$2Fto%2Ffirmware-

upgrade- image.lh upg
5. Press Return.
To use sysflash with a.lh_upg file available via the local file system:

1. Atthe local terminal bash shell prompt enter:

sysflash /path/to/system-upgrade-image.lh upg.

2. Press Return.

Note: sysflash includes several flags that allow for variations in the standard
system upgrade process. These flags should not be used unless directed to do

so by Opengear Support.

List the flags by running either of the following at a local terminal bash shell prompt:
sysflash -hor

sysflash —--help

For more information on sysflashSee the Command line tools chapter.

TROUBLESHOOTING THE UPGRADE PROCESS

There are two main reason why an upgrade fails:
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* Migration failures
Lighthouse will return to the pre-upgrade state. An example of such a failure is
malformed data in the database, which does not conform to more stringent

schema checks in the new version.

* System level failures
This would include environmental issues such as power loss during the upgrade.
If such an issue prevented Lighthouse from rolling back to the previous state,

Lighthouse may be left in an unusable state.
Recovering from a failed upgrade

If Lighthouse is in an unusable state (either as a result of upgrade problems, or any

other catastrophic failure), you can

* Promote a Secondary Lighthouse

This requires multiple instances of Lighthouse. If the primary Lighthouse instance
is unreachable, one of the existing secondary instances can be promoted to
become the new primary Lighthouse instance.

The old primary Lighthouse instance should be replaced with a fresh installation
of Lighthouse. This can then be enrolled as a secondary to the newly promoted

primary Lighthouse.

* Restore a Configuration Backup
Deploy a Lighthouse instance with the version you are upgrading from. Restore

the configuration backup taken before the failed upgrade.

* Manually retry via the CLI if a secondary upgrade fails.
Determine the reason for the upgrade failure and resolve the issue before
retrying the upgrade. Assistance from Opengear technical support may be

required.
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TROUBLESHOOTING A FAILED SECONDARY LIGHTHOUSE UPGRADE

To retry the secondary upgrade, first list the secondaries and identify the IDs of
the secondary lighthouses that need to be retried by running the retry

secondary upgrades list command.

retry secondary upgrades list command willlistall the secondary

lighthouses and their current status,as in the example below:

root@lighthouse:~# retry secondary upgrades list

ID UUID Hostname Firmware Version Fw Status Lighthouse Status
2 lighthouse configurations-2 lighthouse-2 22.11.2 not updated
UpgradeFailed

3 lighthouse configurations-3 lighthouse-3 23.10.0 updated
Enrolled

4 lighthouse configurations-4 lighthouse-4 22.11.2 not updated

UpgradeFailed

In the example above, the Lighthouses with IDs 2 and 4 have failed to upgrade
(note that the “Enrolled” status is the desired status). To retrigger an upgrade for
those lighthouses run the following command. Ensure that the lighthouse IDs are

comma separated:
retry secondary upgrades trigger -1 2,4

The method above is the recommended way but there is a shortcut to retrigger all

failed secondary upgrades by running the command below:

retry secondary upgrades trigger --failed

Note:Only one secondary will upgrade at a time.
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You should be able to view the secondary upgrade progress in the primary

Lighthouse Ul as you would for a normal upgrade.

CONTACT SUPPORT

In the unlikely event that Lighthouse does not automatically recover, or your
troubleshooting efforts fail, contact Opengear support for advice. Provide the

following:

* If yourinstance is usable, download a Technical Support Report (from the Help

menu) and share it with our team.

» Share the configuration backup taken before the upgrade process .

UPGRADE NETOPS MODULES

NetOps Modules are released independently of Lighthouse software or Operations

Manager firmware.

NetOps releases are uploaded to Opengear's file server, where they can be fetched

by Lighthouse then deployed to all activated nodes by Lighthouse.
Node upgrades may be carried out through either the Lighthouse Ul or the CLI.

PROCEDURE for Lighthouse Ul
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1. Login to the Lighthouse web Ul as a Lighthouse Administrator or the root user.

2. From the menu, select SETTINGS > Services > NetOps Modules.Select either

Online or Offline.

¢ sETTINGS

NETOPS SERVICES

TWORK CONMECTIONS -
o
USER MANAGEMENT
NOTIFIC
OMLINE DFFLINE
SERVICES
)

HetOps Modules

3 Click the © Synchronize icon. A message displays with the status.

@ System and Subscriptions (@ Help & Logout

% :I:-:“l%ll-rﬂ.-fll-mUSE Feedback @ Add Node

7" SETTINGS
NETOPS SERVICES

MET I.

USER MANAGEMENT

NOTIFICATIONS

SERVICES

NetOps Modules
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4. From the menu, select CONFIGURE NODES > NetOps Modules > Manage

Modules.

5. Click the Redeploy icon.
PROCEDURE for Lighthouse CLI

Replace root and default with a Lighthouse Administrator or root credentials, then

run the following:

USERNAME=root
PASSWORD=default
/etc/scripts/netops sync handler

token=$ (curl -k -L -d '

{"username" :"'SUSERNAME'", "password" :"'SPASSWORD'"} '
"https://127.0.0.1/api/v3.0/sessions/" | python -c 'import sys, json;
print json.load(sys.stdin) ["session"]")

curl -k -L -H "Content-Type: application/json" -H "Authorization:
Token S$token"

"https://127.0.0.1/api/v3.0/netops/modules/dop/redeploy"

CONFIGURATION BACKUP

Before performing a factory reset or system upgrade, you may want to backup the

current Lighthouse configuration. To do so:
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1. Select SETTINGS > SYSTEM > Configuration Backup.

2. If desired, check Encrypt backup. Enter and confirm a password.

3. Under the Advanced section, specify the paths to any User Files you also wish

to include in the backup.

4. Click Download Backup and save this file. The filename consists of a timestamp

and 1h bak extension, for example: 1ighthouse-20190710100325.1h
bak

CONFIGURATION RESTORE

To restore the configuration and user files you backed up using Configuration

Restore:
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1. Select SETTINGS > SYSTEM > Configuration Restore.

2. Locate the file you downloaded when you performed the Configuration Backup.

3. If you chose Encrypt backup when creating the backup, enter the Backup

Password.
4. Click Restore Backup.
5. A Configuration Restore Confirmation dialog opens, click Yes.

6. Lighthouse will restore the backup and any included user files and restart.

CONSIDERATIONS IF USING MULTIPLE INSTANCES

» Before Lighthouse 23.04.1: Existing Secondary Lighthouse instances will not be

synced with the primary, and will need to be deleted and re-enrolled again.

* Lighthouse 23.04.1 and later: The newly restored primary should re-establish
contact with the existing secondary instances. The databases may be out of sync

at first, but will be re-synced automatically.
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SUBSCRIBING TO LIGHTHOUSE

Lighthouse has a flexible, simplified subscription model that allows you to add
extended functionality if required. The Systems and Subscriptions option on the
main menu provides information on your subscriptions including the type of

subscriptions, the validity and the number of days before expiry.

Feedback @ AddNode (@ System and Subscriptions @ Help & Logout

REST APl version:
CONSOLE GATEWAY v3.7

Hostname:
Smart Group Filtering @ ec2-54-79-207-48.ap-southeast-2.compute.amazonaws.com

Select Smart Group... Current user: -
root

Lighthouse Enterprise
Managed Device Filtering Automation Edition - Startup
Select Managed Device Filter... Valid until Oct 14 2025 -
1093 days left

Lighthouse Enterprise

Free Text Search @ Startup

Search... * Valid until Oct 14 2025

1093 days left

View Details =

Click View Details. The Subscriptions page displays.
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Feedback @ AddNode (@ System and Subscriptions @ Help &l Logout

SUBSCRIPTIONS

SUBSCRIPTIONS SUBSCRIPTION ASSIGNMENT

LIGHTHOUSE ENTERPRISE - START UP

-

Node assignments Valid until Oct 14 2025

9/10 available 1093 days left

= Update Subscription

LIGHTHOUSE ENTERPRISE: AUTOMATION EDITION - START
upP

Valid until Oct 14 2025

Node assignments

9110 available

= Update Subscription

You can also click Show Details for more information about activation.
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LIGHTHOUSE ENTERPRISE: AUTOMATION EDITION - GIGA

Node assignments Valid until 2 Aug 2025

1000/1000 available 300 days left

= Update Subscription

Hide Details ~

USING AUTOMATION EDITION FEATURES

To use these features you will first need to activate modules on compatible nodes.

There are 2 ways you can activate modules on nodes:

Enrollment Bundles will allow you to activate specific modules on all nodes that are enrolled
with the bundle.

Configuration Templating will allow you to push Automation Edition module configuration to

your applicable enrolled nodes.

The subscriptions available are:

* The Enterprise Edition Subscription provides base functionality to enroll, monitor,

and manage nodes.

* The Enterprise Automation Edition provides base functionality plus the advanced

NetOps features - Automation Gateway and Secure Provisioning.
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You can apply the extra functionality to selected nodes only, giving you the flexibility
to use different subscriptions for different nodes.

Subscription licensing is clearly displayed on the Ul. Users can see the active
subscriptions, the node count supported, assigned nodes, and time left on the

subscription.

For more information on subscription tiers, see "Enroliment Bundles" on page 139.

ADDING A NEW SUBSCRIPTION TO LIGHTHOUSE

Lighthouse has a flexible, simplified subscription model that allows you to add

extended functionality if required.
Note:Contact sales@opengear.com with a request for the type of subscription,

including the number of nodes you wish to apply the subscription to. You will

receive an encrypted .zip file named subscription.zip.
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TO ADD A SUBSCRIPTION

1. Select Systems and Subscriptions. A summary displays, click View

Details.The Subscriptions page displays.

MONITOR

Evaluation Mode

Currently running in evaluation mode. There is alimit of 5 enrolled nodes. There are 31 days remaining for evaluation
SUBSCRIPTIONS

SUBSCRIPTIONS SUBSCRIPTION ASSIGNMENT

B manace

LIGHTHOUSE ENTERPRISE A LIGHTHOUSE ENTERPRISE: AUTOMATION EDITION - EVALUATION
MANAGED DEVICES

D You do not have a Lighthouse Enterprise subscription

Contact sales to purchase a subscription Node assignments Valid until 15 Apr 2023
2/5 available 31 days left
® Add Subscription avallal Y

LIGHTHOUSE

Evaluation Subscription in use
CONFIGURE @

To continue using Lighthouse past evaluation expiry, Contact sales to
purchase a subscription

® Add Subscription

Show Details v

Edit Smart Groups

o am (

2. Click Add Subscription.

3. The New Subscription dialog displays. Click Choose file and select the required
zip file and click Apply.

NEW SUBSCRIPTION

Subscription file @

Choose File | ae small 1.zip

Setting up Lighthouse



\ LIGHTHOUSE

Access Portal

4. The success message displays, and the subscription displays.

& MONITOR
SUBSCRIPTIONS N 6 x

Detalls saved successfully

SUBSCRIPTIONS SUBSCRIPTION ASSIGNMENT

LIGHTHOUSE ENTERPRISE LIGHTHOUSE ENTERPRISE: AUTOMATION EDITION - SMALL
g You do not have a Lighthouse Enterprise subscription L
=5 MANAGE Contact sales to purchase a subscription Node assignments Valid until T Mar 2024
N 22125 available 352 days left
MANAGED DEVICES avala :
NODES

Show Details v

® Opengear 2023 | Customer Support

ASSIGNING SUBSCRIPTIONS TO NODES

Lighthouse has a flexible, simplified subscription model that allows users to mix and
match functionality where required. Users can reassign nodes to different
subscriptions in order to optimize Automation Edition features on their network. For

example, if the user:
* Previously had two license tiers, but only paid to renew one license tier

¢ Purchased an Automation Edition license for the first time, and wants the extra

functionality on some of their nodes

* Wants to swap which nodes have access to the extra functionality available in an

Automation Edition license

Setting up Lighthouse



\ LIGHTHOUSE

Access Portal

VIEW SUBSCRIPTIONS IN THE LIGHTHOUSE Ul

To see subscriptions:

1. Select SETTINGS > Systems > Subscriptions.

SUBSCRIPTIONS

SUBSCRIPTIONS SUBSCRIPTION ASSIGNMENT

O NODEID & NAME MODEL SUBSCRIPTION TYPE

Lighthouse Enterprise: Automation
nodes-2 im7208-2 1M7208-2 J b

Edition
e e Lighthouse Enterprise: Automation
O nodes-3 m7208-2 IM7208-2 -
Edition
o o Lighthouse Enterprise: Automation
@] nodes-4 m7208-2 IM7208-2
Edition
- Lighthouse Enterprise: Automation
] nodes-1 nodes-1 ’

Edition

NETOPS

Add

modules

Add

modules

Add

modules

Add

modules

ASSIGNED

0ct 172022 11:52

PMUTC

Oct 172022 11:52

PMUTC

0ct 172022 11:52

PMUTC

Oct 172022 11:52

PMUTC

ltems per page

10

The Subscriptions page displays. Select Subscription Assignment.

FILTER BY
Smart Group Filtering @

Select Smart Group.
Subscription
All

Unsubscribed

Automation Edition

Enterprise

Free Text Search ®

Search x

The Subscriptions page displays details of the subscriptions and allows you to

search using smart group filters, subscription, or free text searches.

The page also allows you to update, replace or add new subscriptions.

TO ASSIGN NODES TO SUBSCRIPTIONS

Select SETTINGS > System > Subscriptions > Subscription Assignments.

The Subscriptions Assignments page displays details of the nodes including:

¢ Node Id
* Node name

* Subscription Type
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* Current NetOps module deployment to assigned nodes
» Date of Assignment
TO ASSIGN A SUBSCRIPTION
1. Select SETTINGS > System > Subscriptions > Subscription Assignment

2. Display the required nodes using the Filter pane, either by using the Filters,

Subscription, or Free text options.
3. To assign a subscription to a node click the ‘-_'Assign button. The Assign

Subscription dialog displays.

ASSIGN SUBSCRIPTION

IM7208-2

nodes-2 Lighthouse Enterprise: Automation Edition 7

IM7208-2 -
Lighthouse Enterprise: Automation Edition Lighthouse Enterprise

10
Confirm Assignment

4. Select the required subscription from the leftmost panel using the 4—_'Assign
button.

5. Click Confirm Assignment

TO CHANGE A NODE'S SUBSCRIPTION

1. Select SETTINGS > Systems > Subscriptions > Subscription Assignment

2. Display the required nodes using the Filter pane, either by using the Labels or

Free text options.
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3. To change subscription on a node click the 4:'Assign button on the row. The
Assign Subscription dialog displays.
4. Select the required subscription from the right panel.

5. Click Confirm Assignment to change the node's subscription. A message box

displays indicating the effect of changing the subscription.

ASSIGN SUBSCRIPTION TO 1 NODE

VACM-AWS-1-0D183BB111ESCCF22-3
nodes-3 Lighthouse Enterprise 7

VACM s

Lighthouse Enterprise Lighthouse Enterprise: Automation Edition 1000

Confirm Assignment

Note:Another way of removing a node from a subscription is to unenrol the

node. The subscription will then become available to be assigned to another

node.

SHUT DOWN OR RESTART LIGHTHOUSE

The following sections describe the process to shutdown or restart Lighthouse.

This includes finding instance version, returning to factory setting, and shutting

down or restarting a running version of Lighthouse.
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FINDING THE CURRENT LIGHTHOUSE INSTANCE
VERSION

There are two ways to find the current Lighthouse version.
Using Lighthouse
1. Click System & Subscriptions on the Lighthouse banner.
2. The Details menu displays, listing the Lighthouse instance’s:
» Current version
* REST API version
* Hostname, and

e Current user.

Via the local Lighthouse shell

1. Click MANAGE > LIGHTHOUSE > Local Terminal

2. Atthe [hostname] login: prompt, enter an administrator username and

press Return.

3. Atthe password: prompt, enter the administrator’s password and press b.

4. Atthe bash shell prompt, enter cat /etc/version and press Return.

The current Lighthouse instance’s version is returned to STD OUT. For example:

root@lighthouse:~# cat /etc/version 2022.01.0
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Note:The procedure above uses the Web Ul to reach the Lighthouse Local
Terminal. This is not the only way to reach the Lighthouse shell and cat
/etc/version works in any circumstance where an administrator has access
to the Lighthouse shell. For example, many of the Virtual Machine Manager
applications that can run a Lighthouse instance offer virtual console access. If
this is available and an administrator logs in to the Lighthouse shell via this

console, the command string works as expected.

Via other information sources

Two other command strings can be useful when specifics about a particular

Lighthouse instance are needed.

Both these commands can be run by an administrator with access to a running

Lighthouse instance’s bash shell.
Firstis cat /etc/sw*. This command concatenates the following four files to STD

OUT:

/etc/sw_product
/etc/sw_variant
/etc/sw_vendor

/etc/sw_version

For example:

# cat /etc/sw*

lighthouse
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release
opengear

2022.0Q01.0

Secondis cat /etc/issue. /etc/issue is a standard *nix text file which
contains system information for presenting before the system’s login prompt. On a
Lighthouse instance, /etc/issue contains the vendor and Lighthouse product

version.

# cat /etc/issue

Opengear Lighthouse 2022.01.0 \n \1

SHUT DOWN A RUNNING LIGHTHOUSE INSTANCE

To shut down a running Lighthouse instance:

1. Select MANAGE > LIGHTHOUSE > Local Terminal

2. At the Local Terminal login prompt enter a username with administrative

privileges (for example, root).
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3. At the Password: prompt, enter that account’s password. A Last login date and
time for that account are returned to STD OUT and a shell prompt for the logged in

user displays.

4. Enter the command shutdown now and press Return. The Lighthouse virtual

machine shuts down.

RESTARTING A RUNNING LIGHTHOUSE INSTANCE

To restart a running Lighthouse instance, follow the first three steps of the "Shut
Down or Restart Lighthouse" on page 121 instance procedure above. At the shell

prompt, enter one of these commands and press Return:
reboot

or

shutdown -r now

The Lighthouse virtual machine shuts down and reboots.

RETURNING A LIGHTHOUSE INSTANCE TO FACTORY
SETTINGS

At some stage, you may need to return to the factory settings. You can do this either

through the Ul or by running a shell script if you have root access.

Note:During this process, the current Lighthouse configuration will be
overwritten and user files will be deleted. If you wish, you can create a backup

of the configuration and any desired user files.

To return a Lighthouse to its factory settings using the Lighthouse Ul:
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1. Login to the Lighthouse as root. Other users, even those with full administrative
privileges, do not have the permissions required to reset the Lighthouse VM to its

factory settings.

2. Select SETTINGS > SYSTEM > Factory Reset.

3. Select the Proceed with the factory reset checkbox.

4. Click Reset.
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MANAGING LIGHTHOUSE NODES

After Lighthouse has been installed and configured, enrol a small set of nodes, then
create a set of tags and smart groups that allow nodes access to be filtered to the

correct subset of users.

Once these nodes are installed, test access to the Node’s Web Ul and serial ports.

MONITOR NODES

Lighthouse allows you to view all nodes including connected, not connected,

enrolled, and pending, as well as nodes using cellular.

MONITOR > Nodes displays the cellular health and number of ports. Click the icon

on the right of connected nodes to access the Web Ul of the node.

1. Select MONITOR > Nodes.

&2 3/8 portls) configured =]

&P 18/18 portls) configured (=]

FILTER BY

Smart Group Filtering @
(%] conFicuRe Smart Group Filtering ®

Select Smart Group...

P sermines

Status

Connected

Connected via Cellular
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2. Use the SORT BY menu to sort the display of nodes, by Status Change, Name or

Connected Devices, in ascending or descending order, or newest or oldest.
3. Use the FILTER BY menu to display the nodes by a selected Smart Group.

4. Use the Status menu to display the nodes by Any status, Connected, Connected

via Cellular, Disconnected or Pending.

5. Use the Free Text Search to search using a text string. You can also search by

Port tags.
6. The Monitor Nodes page displays the result of the search on the page.

Click on any connected node to view the node details, list of configured ports and

unconfigured ports.

MONITOR ) VACM-AWS-I-0D7E30AETEEB39AA2-1
nodes: ast status chan 1 ours ago

IWebUl @& Unenrol Il
es-1  Last status change 13 hours ago

FORTS NETWORK INFO

Management VPN Address

Show All e 192.168.128.2
View more

MANAGED DEVICES o v PORT# & LABEL TAGS
CELLULAR

a] . -
Active SIM
Unavailable
Ports [m} 2 Switeh . e
icciD
NODES ] 3 POU > s

Unavailable

LIGHTHOUSE (|} 4 UPS » View more

Local Terminal

From this detail page, you can access the web Ul of the node, as well as the web

terminal and SSH of each connected device.

MONITOR PORTS

Lighthouse allows users with the appropriate permissions to view ports on a node to
get a quick snapshot of the health of the nodes. For example, to trace a faulton a

node, a network engineer will want to investigate the latest logs for a port.
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. Select MONITOR > Nodes. A list of nodes displays, each node displays the total

number of ports/configured ports.

. Click on the required node. The Node page displays node information including

sortable lists of Configured Ports and Unconfigured Ports, Network Info,

Cellular details, Node tags and Node details.

MONITOR

) VACM-AWS-I-0D7E30AE1EEB39AA2-1 Oy U
nodes-1  Last status change 13 hours ago

d

PORTS
NETWORK INFO
- Management VPN Address
Jobs
.1__.% MANAGE View more
MANAGED DEVICES o v PORT# & LABEL TAGS
CELLULAR
(m] LY s N
Active SIM
=] 2 Switch [N G Unavallable
ICCID
NODES [w] 3 POU * B navaiiabie
LIGHTHOUSE O 4 UPS [N

Local Terminal

. The drop down allows you to select to Show All, Configured Ports, or

Unconfigured Ports on the node.

. If the node has been configured to display logs, and you have the correct

permissions you can select Port Logs.

. The Port Logs page displays.

,; ACM7008-2-L

il CLIWebUl & Unenroll
nodes-24  Last status change 3 weeks ago

PORTS PORT LOGS

Fort 1(port1) - ;ta"t dd/mm/yyyy —:— E‘m dd/mm/yyyy —— -8 | UTC X Filter Log Contents @ B
ate ate

There are ne more logs to display.

Select the Port from the list, and specify the date range (Start Date and End
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Date) to view the logs that display in the log window below. You can also access

the web terminal and SSH of each connected device.

6. Alternatively, you can search for a log with a particular text, using the Filter Log

Contents Logs matching the search parameter display in the log window.

7. You can also download the displayed logs, or open a new window to view the logs

in more detail.

FILTERING PAGES DISPLAYING NODES

If you want to quickly find a particular node or set of nodes, you can drill down to
specific nodes by using BASIC and ADVANCED filters. The filters can be used
independently from each other or in combination to create customized displays

based on ports, devices and permissions.

Select MANAGE > MANAGED DEVICES > Console Gatewayto display all the

nodes with all the devices/ports.

HONIOR: CONSOLE GATEWAY

c BASIC FILTER

Free Text Search @

Jobs NODE 1D NAME STATUS NFO Search... *
-8 manace
nodes-1 vacm-aws-i- Connected MANAGEMENT VPN ADDRESS 4device(s) v
d183b6111e9cc 92.168.128.2
MANAGED DEVICES 0d183b6111e8cc 192.168.128.2 ADVANCED FILTER
2 Laststas NETIMAC ADDRESS .
tus change _ Smart Group Filtering ®
Console Gateway ’ 52:54:00:80:00:01
2 hours
NETWORK Select Smart Group...
ago -
Ports : 172.19.1.2
Show Details Port Filter
NODES
New Port Filter
LIGHTHOUSE nodes-2 vacm-aws-i- Connected MANAGEMENT VPN ADDRESS 4 device(s) v
Od leScc 192.168.128.3
— . e Fieldto search Operator
[&] conrieure 122-2 Laststa :
— tus change
- o Field tosearch ~ Oper ~
o am 2 hours
ago
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FILTERING USING THE FREE TEXT SEARCH FIELD

The Free Text Search input field allows near real-time filtering of nodes and

managed devices using the following criteria:

* Node name

* Firmware version

* Management VPN address

* MAC address

» Serial number and

* Port label

* Porttag

Enter your search term in the Free Text Search field and press Enter.

The Free Text Search field treats multiple search terms separated by the space
character as being combined with the logical AND operator, returning results only if

all terms are present in the item.

For example, the search phrase production switch returns only nodes that

contain both production AND switch anywhere in searchable fields.

To search for a multi-word term, enclose the search term in double quote
characters. For example, “production switch” will return results only if the

entire search term is matched in the item.

FILTERING USING SMART GROUPS

Use MANAGE > MANAGED DEVICES > Console Gateway to customize the node
display.
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() MONITOR CONSOLE GATEWAY

<
Jobs E 1D l NFO
ibg MANAGE nodes-1 Connected

MANAGED DEVICES

Console Gateway

LIGHTHDUSE

CONFIGURE

Edit Port Filters nodes-3

NODE ENROLLMENT

O o

a2

MANAGEMENT VPN ADDRESS 4 devicels

BASIC FILTER
Free Text Search @

Search...

ADVANCED FILTER
Smart Group Filtering @

New Smart Group - Bundle

Field to search Operator

Field tosearch = Opera =

Select Port Filter..

On the ADVANCED FILTER pane, on the Smart Group Filtering pane, use the

Select Smart Group dropdown list. Select a group from the list and the page

displays the nodes that belong to the selected smart group.

Use Fields to search to narrow the search:

To add more filtering options:

1.

2.

Click Field to search.

Select a field and enter a Value in the text box.
Select an Operator from the drop-down box.
Enter the search criteria.

Click Apply.

The list of nodes that meet the specified criteria display.
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6. Click the + Add Parameters button to add more AND/OR parameters. Repeat

from step 1.

FILTERING NODES USING THE PORT FILTER
Use MANAGE > MANAGED DEVICES > Console Gateway to customize the node
display.

On the ADVANCED FILTER pane, on the Port Filter pane, use theSelect Port Filter
dropdown list. Select a filter from the list and the page displays the nodes that

belong to the selected Port Filter.

(7) MONITOR

Fieldtosearch - Opera ~

5 MANAGE

MANAGED DEVICES

LIGHTHOUSE
Port Label

To narrow the search:

1. Click Field.

2. Select a field option such as Port Label or Port Tag and enter a Value in the text

box.
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3. For Port Label you can select an Operator from the drop-down box on the right. A
range of operators are available allowing you to define any filters from very wide

to very narrow ranges.

4. If you wish to narrow the search, select +Add Parameters. Select the AND or OR

button to specify the requisite boolean value.

5. Select the next Field to Search option such as Port Tag and enter a value in the

text box.
6. You can repeat from step 4 to add more parameters.
7. Click Apply Filter.

8. Click Save Changes. You can also select to Clear.

ENROL NODES

Enrolling nodes is the process of connecting nodes to Lighthouse to make them

available for access, monitoring, and management.
Enrollment can be performed via:

* the Lighthouse Web Ul

» the Node Web Ul

« ZTP

» USB key.

Credentials must be provided to authenticate either the Lighthouse during
Enroliment via the Lighthouse WebUI, or the node during the other Enrollment

scenarios.

Managing Lighthouse Nodes



\ LIGHTHOUSE

Access Portal

Lighthouse uses OpenVPN tunnels secured with certificate authentication to
connect the Lighthouse instance and remote nodes. For the connections to work
properly, the clocks/times between the Lighthouse instance and each remote node
server need to be synchronized. During the enrollment process when a new remote
node is being added, if that node is not using NTP (Network Time Protocol) to
synchronize its time, the node will check the HTTP Date header sent by Lighthouse

in the enrollment request.

The remote node will then set its own local system clock to match the time shown in
that HTTP Date header from Lighthouse. This ensures the new remote node has its
time matched to the Lighthouse before the VPN tunnel is established, preventing

potential time sync issues between the tunnel endpoints.

If a remote node is relying on an NTP server to set its own time, it still checks the
HTTP Date header sent by Lighthouse to affect the time synchronization but does

not set its local time to that of the Lighthouse instance.

When enrolling via Lighthouse, an administration username and password for the
node must be provided. When enrolling via the node, an Enroliment token must be
provided. A default Enroliment token can be set on the CONFIGURE > NODE
Enrollment > Enroliment Settings page, and individual tokens set per Enroliment
bundle.

Enrollment is a two-step process:

1. After enrollment begins, nodes receive their Enrollment package, and establish a

VPN connection to Lighthouse.

2. The node is now in the Pending state and needs to be Approved before the node

is available for access, management, or monitoring.
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Note:This second step can be skipped by selecting the Auto-approve node

checkbox when configuring an Enrollment bundle.

THE ENROLLED NODES PAGE

The Enrolled Nodes page lists all the enrolled nodes on a Lighthouse instance.

B manace
Evaluation Mode
CONFIGURE Currently running in evaluation mode. There is a limit of 5 enrolled nodes. There are 30 days remaining for evaluation.
ENROLLED NODES
. c FILTER BY
Smart Group Filtering @
Edit Smart Groups
Select Smart Group...
(m] NODE ID NAME STATUS INFO
Edit Port Filters
Free Text Search @
NODE ENROLLMENT O nodes- vacm Connected MANAGEMENT VPN ADDRESS ¥
L Search x
192.16¢ 8.2 °
Enrolled Nodes NET1MAC ADDRESS
52:54:01:81:00:01
NETWORK
172.19.254.2
Show Details
O nodes-2 vacm [ y
CONFIGURATION TEMPLATING
MULTIPLE INSTANCE 2
day ago
NETNPS MNNIILEQ ~ NETWORK

172.19.254.3
o am (

Show Details

To display the enrolled nodes:
1. Select CONFIGURE > NODE Enrollment > Enrolled Nodes

2. The enrolled nodes display in the chronological order in which they were enrolled

to Lighthouse. For each node, the following details display:
* model

 firmware version

* serial number

e status.
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3. Click Iltems per page to select the number of nodes per page. Choose a default
value of 10, 20, 50, 80, or 100 nodes per page, or enter a custom value between
1 and 100.
This setting applies to the current user session only and will be lost when the

current user logs out.

Note:ltems per page also displays on the Pending Nodes, Console

Gateway, and Node Web Ul pages.

4. Status is the current connection status of the node and displays either of two

things:

* Connected: Last status change x [time unit] ago: The time since Lighthouse

connected to the console server.

* Disconnected: last status change x [time unit] ago: The time since

Lighthouse disconnected from the console server.

* Configuration Retrieval Status displays if any configuration retrieval sections
failed when performing a configuration sync with this node, such as Groups,

Users, Node Description, Authorization, or Serial Ports.

» Configuration Template Run Status displays the result of the most recent
configuration template push on this node, listing which templates finished
applying, or failed to apply to the node. This information is displayed until the next

template push has completed on this node.
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Note:The Configuration Retrieval Status and Configuration Template Run
Status are not displayed if there is no relevant data to display and are only
displayed for users with Lighthouse Administrator or Node Administrator

permissions.

* Results of the Configuration Retrieval Status and Configuration Template

Run Status indicate:
* Success: all templates were successfully executed on the node.

* Partial Failure: some templates failed to execute on the node, or some config

sections failed to synchronize.

* Failure: all templates failed to execute on the node, or all config sections

failed to synchronize.

You can select a summary of each status to see more detailed information as

follows:

* Retrieval failed for: section_name, section_name, section_name.
* Template(s) failed to apply: template_name, template_name, template_name.

* Template(s) successfully applied: template_name, template_name, template_

name.

5. If SETTINGS > SERVICES > Cellular Health Reporting is Enabled, the
Cellular Health column displays the node’s current cellular status. If this state is
Good|Moderate|Bad, click the color indicator or the text to view more detailed

health information as follows:
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Cellalar Mestth Detals for wnTT16-001 JobDrng

Coliar  hddvwsn Sustan [ Dgesl Quaiity  BSH  Conewstion Type  Tam iises Camsactiviry Tost

H0RL 145, 134
. rak " 1 thvity Tt
e = - . aiicwer Drabled e [ Cormer: 1d Duabled

* Cellular IP Address (IPv4 and IPv6)
* Cellular interface status (Up|Down)
» Conditions

» Signal Quality

* RSSI

* Connection Type

* SIM Issues

* Connectivity Test (Passed|Failed|Connectivity Test
Disabled)

6. The INFO column displays more details about each node. Click Show Details to

see more information about the node, or Hide Details to display fewer details.

ENROLLMENT BUNDLES

An Enroliment bundle is a downloadable file that stores provisioning information,

allowing for bulk Enrollment and manipulation of remote nodes.

Applying an Enrollment bundle during Enroliment allows tags to be associated with
nodes when they’re first enrolled, rather than manually assigning tags after the

nodes are enrolled.
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This is useful for larger roll outs where there are many nodes deployed with a similar
configuration and responsibilities. If relevant Smart Groups and tags have been set
up, newly enrolled nodes are immediately visible for the relevant users to configure

and use.

Associating templates with an Enroliment bundle allows to run a set of templates on
a node, after it has been enrolled. Any template defined on the Lighthouse can be

added to an Enrollment bundle, and each bundle supports any number of templates.

ASSIGNING SUBSCRIPTIONS

When a user has subscribed to Enterprise Edition, Enterprise Automation Edition, or
both then assigning a subscription type to the bundle will be necessary. Based on
the feature set for the node to utilize, this will mean they might need to create two

bundles:

* An Enterprise tier subscription bundle to enrol nodes, and perform other basic

functions (set up AAA, run scripts, create groups/users, set up logging, etc)

* An Automation Edition tier subscription allows all basic functions of the enterprise
plus advanced feature set Automation Gateway, and Secure Provisioning for

assigned nodes.

CREATING AN ENROLLMENT BUNDLE

To create an Enrollment bundle in a Lighthouse instance:

Managing Lighthouse Nodes



\ LIGHTHOUSE

Access Portal

1. Select CONFIGURE > NODE Enroliment > Enrollment Bundles

-

ENROLLMENT BUNDLES

]
B MaNaGE
@ CONFIGURE NAME NODE COUNT
NODE ENROLLMENT Enterprise Vd <] e
Enrolled Nodes Automation 1 Fa ] th

Enrollment Bundles

2. Click the + button. The Enroliment Bundle Details page displays.

ENROLLMENT BUNDLES

ENROLLMENT BUNDLE DETAILS

Name @
Token @

(J Auto-approve node @

Subscription Selection @

Lighthouse Enterprise

Lighthouse Enterprise Automation Edition

ENROLLMENT BUNDLE NODE TAGS

Select tag - Select value - E\
Create new tag value
TEMPLATES
ORDER TEMPLATE TYPE TEMPLATE NAME ACTIONS

3. Enter a Name and Authentication Token for the bundle in the respective fields.
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4. Select the number of Tags and Values to apply to any nodes that enroll using this

Enrollment bundle.

5. (Optional) Select the Auto-approve node checkbox.
When this is checked, a device configured using this Enrollment bundle is not
placed in pending mode during the Enrollment process. Instead, it is

automatically approved for Enrollment after it has been identified.

6. Select the desired Subscription Bundle Label - Lighthouse Enterprise Edition
or Lighthouse Automation Edition.This is the desired subscrption type to assign
to newly enrolled nodes using this bundle (optional when more than one

subscription is active on the Lighthouse).

7. You can also use this bundle to automatically activate NetOps modules for any
supported nodes. Scroll down to the NETOPS MODULES section and press the
+ button to open the MODULE DETAILS dialog.

MODULE DETAILS

Pleaze select 2 module from the list below.
Module Name

P Access v

Cance Apply

8. Select the desired Module Name from the drop-down list. Click Apply.

With the Enrollment bundle named, use the Enrolilment BUNDLE NODE TAGS to

populate it with the desired name-value pairs:
1. Select a field name from the left-most drop-down menu.

2. Select or enter a value from the right-most drop-down menu.
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3. Click the + button to add a new pair of drop-down menus.
4. Select another field name and select or enter another value.
5. Repeat until all desired name-value pairs are displayed.

6. Click Apply.

With the Enrollment bundle named, use the TEMPLATES to populate it with the

desired list of templates to be applied post-Enroliment:

1. Click the + button to add a new pair of drop-down menus.

2. Select a value from the Template Type menu. The selected template type filters

the available names to those templates of that type.
3. Select a value from the Template Name menu.
4. Repeat until all desired type-name pairs are displayed.

5. Click Apply.

The templates in the table can be reordered using the arrow buttons in the far-left
column of the table and are executed in the order they appear. The order buttons

appear if there is more than one template in the table.

Template push operations stop if one template fails.

STRUCTURE OF AN ENROLLMENT BUNDLE

An Enroliment bundle file, manifest. og, contains a series of field-value pairs that

an unconfigured device can use to configure itself.

Options that can be setinmanifest. og include new firmware, custom

configuration scripts, OPG config files, and Lighthouse Enroliment details.
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By default, manifest. ogincludes the following field-value pairs (with example

values):

address=192.168.88.20
apl port=4443
bundle=bne-dc

password=secret

Custom field-value pairs can be added manually. The field names are potential field
names for a real-world, customized file, but the values following each field name are

examples:

script=configure ports.sh
image=acm7000-3.16.6.1image
external endpoints=192.168.1.2:4444,192.168.1.3:4445

ENROLLING NODES

Enrolling nodes is the process of connecting nodes to Lighthouse to make them

available for access, monitoring, and management.

A node is a device that can be enrolled with Lighthouse, allowing it to be accessed,

managed, and monitored.

You can enrol nodes in the following ways:
* via the node's Web Ul

* via Lighthouse Web Ul

* via OM, ACM, CM, and IM Web Ul
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e via USB drive

* Mass Enrollment using ZTP.

This section also covers how to back up nodes.

ENROLLMENT VIA NODE WEB UI

If a node is behind a firewall, Lighthouse cannot initiate an Enroliment. The node

must be enrolled from the Node Web UI.
1. Log into the Node Web UI.
2. Select Serial & Network > LIGHTHOUSE.

3. Enter the Server Address of Lighthouse (which can be hostname, FQDN, or IP

address)
4. Optionally, enter the Server Port.

5. Enter the Enrolilment Bundle (if a specific bundle is being used), and the

Enroliment Token (either the global token or the bundle-specific token).

6. Select Apply Settings. The Enroliment process begins.

After enroliment, the node displays in the Pending Nodes page, with a Status of

Approval. Click the Approve icon in the Actions column.

ENROLLMENT VIA LIGHTHOUSE WEB Ul

Enrollment via Lighthouse Web Ul only works if the Node is reachable from

Lighthouse. To enroll a node:
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1. Select Add Node in the top menu bar to open a NEW Enrollment dialog.

NEW ENROLLMENT

Product (®

An Opengear device

Network Address @

Username ®

Subscription Type @
Lighthouse Enterprise Automation Edition

Lighthouse Enterprise

Auto-approve node (3

Run pre-enroliment connectivity check (@

2. Select the Producttype from the Product menu.

An Opengear device

A generic third-party device, see Note below

An Avocent ACS6000

An Avocent ACS8000
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¢ An Avocent ACS Classic
¢ A Cisco 2900 Series
* A Digi Passport

3. Enter the Network Address, Username, and Password of the node being
enrolled. The Username and Password fields are for the login credentials
required by the remote node being enrolled, not the login credentials used to

login to the Lighthouse instance.

4. Select the Subscription Type. Each type shows the number of available

subscriptions.
* Enterprise Edition
* Automation Edition.

5. If required, you can also select the Auto-approve node and Run pre-

enrollment connectivity checks.

6. Click Apply

Once enrolled, the console server’s details are removed from the Pending Nodes

page and added to the CONFIGURE > NODE Enroliment > Enrolled Nodes page.

ENROLLING NODES VIA OM, ACM, CM, AND IM WEB Ul

Nodes can be enrolled from other Uls such as the Operations Manager(OM) as

follows via:

* OM: Nodes can be enrolled into a Lighthouse instance on OPERATIONS
MANAGER Web Ul using the CONFIGURE > LIGHTHOUSE Enrollment menu
item and the 1hvpn-callhome command. See the OPERATIONS MANAGER

User Guide for more details.
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* ACM, CM and IM: On the Web Ul, select Serial & Network > Lighthouse to

open the Request Enroliment with Lighthouse Server page.

MASS ENROLLMENT USING ZTP

For mass node Enrolments using ZTP, three new custom DHCP fields are handled
by ZTP scripts.

These fields contain the URL, Bundle Name and Enroliment Password used in an
Enroliment which is kicked off after all other ZTP handling is completed. If a reboot is
required because of a config file being provided the Enroliment starts after the

reboot. Otherwise it happens immediately.

Here is a sample configuration file for the ISC DHCP Server:

option space opengear code width 1 length width 1;
option opengear.config-url code 1 = text;

option opengear.firmware-url code 2 = text;

option opengear.enroll-url code 3 = text;

option opengear.enroll-bundle code 4 = text;

option opengear.enroll-password code 5 = text;

class "opengear-config-over-dhcp-test" {

match if option vendor-class-identifier ~~ ""“Opengear/";
vendor-option-space opengear;

option opengear.config-url "http://192.168.88.1/config.xml";
option opengear.enroll-url "192.168.88.20";

option opengear.enroll-bundle "";

option opengear.enroll-password "default";

}
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Note:The maximum amount of data allowable as DHCP options is 1200 bytes,
including all overhead inherent in the structuring of this data. Individual options

are limited to 255 characters.

ENROLLMENT VIA USB DRIVE

An unconfigured device can be enrolled using a USB drive loaded with an

Enrollment bundle. (See "Creating an Enrollment bundle" on page 140.)

Download the Enrollment bundle, manifest.og from a Lighthouse instance as

follows:

1. Select CONFIGURE > NODE Enrollment > Enrollment Bundles. A list of

existing Enroliment Bundles displays.

2. Inthe Actions column of the particular bundle, click the download button, a

downward arrow in a circle.

3. Depending on the browser’s configuration, a manifest. og file either
downloads to the local system or displays a dialog asking to specify where to

download the file.
To enroll a node via USB drive:
1. Copymanifest.og tothe rootdirectory on a USB drive.
2. Plug the USB drive into an unconfigured and powered-down console server.
3. Power the console server up.

On first boot, the device searches for the file — manifest.og —onany USB

drives attached to the device and configures the device based on its contents.
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BACKING UP NODES

Administrative users can enable automatic node backup. Up to 10 backups can be
stored on a rolling basis.

Note:Node backup requires firmware 4.6 or later.

To set up node backup:

1. Select SETTINGS > SERVICES > Node Backup.

2 MANAGE
NODE BACKUP
[£] CONFIGURE

[(JEnable &®

£ SETTINGS

NETWORK CONNECTIONS STORAGE

Mumber of stored backups &
USER MANAGEMENT

1 -
NOTIFICATIONS
Retention period after unenroliment @
SERVICES l @
O None
Cellular Health Reporting ® Days
Con y 1 dayls)
e O Forever
HTTPS Certificate
Location @

Lighthouse VPN

hvailable space

2420 MiB

Total space

2. Select the Enable checkbox to turn on this service.

3. Under the Storage section, select the Number of stored backups you wish to
keep.

4. In Retention period after unEnrolment select None, Days or Forever.
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If you select Days enter the number of days.

5. Enter the Location you wish to store the backup files. We suggest you store

backups at /mnt/nvram/.

6. Click Validate to make sure the location exists and has enough space to store
them. The Available space, Total Space and Estimated disk usage MiBs

display.
7. Click Apply or set a schedule using the Scheduling fields.
To setup an automated schedule for performing node backups:

1. Scroll down to the SCHEDULING section.

£ SETTINGS
SCHEDULING
NETWORK CONNECTIONS Start @
Olmmediately ® Set Time
USER MANAGEMENT !
UTC Time
NOTIFICATIONS UTC Time @
05:25 +0000 October 25, 2022
SERVICES
Server Time @
Cellular Health Reporting 15:11+0000 October 25, 2022
Local Time &
15:25 +1000 October 25, 2022
2022 - October b 25 d
Time ®
15 2 -
Repeat
O One Time Only @ Interval
SNMP Manager svery | 1 dayls)~

SNMP Service

Apply
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2. Forthe Start time, choose either Immediately or choose Set Time to open

editable Date and Time fields.

3. Choose how often you wish to Repeat the backup by selecting either One Time

Only or Interval.

4. If you selected Interval, enter the values for Days or Weeks.

Note:You can modify these options by returning to SETTINGS > SERVICES >

Node Backup at any time.

WORK WITH NODES

After a node has been enrolled, you can connect to it directly, either to monitor it, or

to run commands on it, Multiple nodes can be selected.

CONNECT TO THE WEB-MANAGEMENT INTERFACE OF A
NODE

After a node has been enrolled, you can connect to the enrolled node’s web-

management interface as follows:
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1. Select MANAGE > NODES > Node Web Ul. The nodes display:

NODE 1D NAME STATUS -
odes SPT-0M2248 Connected [}
Cellular
Interface
Disabled
change 2 Last sta-
eaks ago us
chang
weeks a

MANAGEMENT VPN ADDRESS (]

192.166.128.5

NET1MAC ADDRESS
00:13:c6:08:07:7c
NET1:STATICI
MNET1:DHCP
10.220.3.6
NET1:IPBAUTO
Unavailable
\0:DHCP

ilable

NET2:STATICS
10101021

o Click Fthe Access Web Ul link for the particular node. The web-based login for

that node loads.

3. Authenticate using the username and password required by that node. The

appearance of the Web Ul depends on which device you have added. Below is
the ACM/CM/IM Web Ul, followed by the OM Web Ul.

%, opengear
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This mywtem is being sccessad via Lighthssna - click hane to return 1o Lighthouss

A message displays at the bottom of the browser and provides a link to return to

Lighthouse.

CONNECTING TO A NODE’S SERIAL PORTS

You can connect to the enrolled node’s serial ports via the Console Gateway option
on the user interface if required. This allows the user to directly connect to any

devices that are connected to the serial ports of the selected node.
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FIND THE SERIAL PORTS

To search for serial ports on Lighthouse select MANAGE > MANAGED DEVICES >

Console Gateway

(2) mMoNITOR e

= MANAGE

NODEID NAME STATUS
MANAGED DEVICES HEALTH

Console Gateway

nodes-5 SPT-0M2248 58 device(s) v
LIGHTHOUSE
[#] conFIGURE
k]
3 SETTINGS
NET2:STATICS
0.10.10
Show Detail
nodes-6 SPT-Management- Connected . MANAGEMENT VPN ADDRESS 51 device(s) v

or
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Select MANAGE > MANAGED DEVICES > Quick Search A page displays all the

connected nodes, the right most column displays the number of devices connected

to the node.
| (@ moniToR
17004-5-L R I -1 Terminal SSH
| 5 MaNAGE
MANAGED DEVICES
0OM1208-L RS1 I -1 Terminal SSH
Quick Search ACM7008-L RS1 part? SPT-Management-IM7248 Termina H
Node Web Ul ! TRsZ ! t-I Termina H
LIBHTHOUSE
ort | changs 6 days Web Terminal SSH
[#] coNFIGURE
0
" SETTINGS - i Terminal SSH
t m7008 Terminal SSH

The Items per page drop-down on Quick Search page allows the user to select the
number of ports per page. This setting applies to the current user session only and

will be lost when user logs out.

Note:Port-centric search allows filtering via the Managed Device Filters and
displays a list of ports within enrolled nodes that match the search terms, while
node-centric search allows filtering via Smart Groups and node properties.

Quick Search can be used to filter on the managed device label.
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NODE-CENTRIC SEARCHING

1. Select MANAGE > MANAGED DEVICES > Console Gateway.

2. Find the particular port using the Smart Group Filtering options to restrict the

listed nodes.

3. Click the + button in the Access Console Ports row adjacent the particular

node.

PORT-CENTRIC SEARCHING

1. Select MANAGE > MANAGED DEVICES > Console Gateway.

2. Find the particular port by using the Managed Device Filtering options to restrict

the listed managed devices within enrolled nodes.

Once the serial port is located, serial port access via Console Gateway can be

accomplished in two ways:
* Web Terminal

* SSH
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QUICK SEARCH

1. Select MANAGE > MANAGED DEVICES > Quick Search.

2. Enter the managed device label, aka name, in the Quick Managed Device

Search field. This search live-updates as user type.

(2) moNIToR QUICK SEARCH
8
- RUNEGE FILTER BY
Free Text Search @
MANAGED DEVICES
M7 X
Console Gateway
Quick Search
MANAGED DEVICELAB PORT NODE + STATUS

LIGHTHOUSE

[2] coNFIGURE

‘P SETTINGS

O a

3. Use Web Terminal and/or SSH links on a particular port to access it.

ACCESS VIA HTML5 WEB TERMINAL

To provide easy console port access, Lighthouse includes a HTML5 Web Terminal.
The HTML5 Web Terminal includes native cut, copy and paste support. The

terminals available on nodes do not.
To access a console port via the Web Terminal:

1. Locate the particular port by using one of the search techniques described in

"Connecting to a node’s serial ports" on page 154.
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2. Click the Web Terminal link for the particular port. A new tab opens containing
the Web Terminal.
To close a terminal session, close the tab, or type ~. in the Web Terminal window.
ACCESS A SERIAL PORT VIA SSH

To access ports via SSH, use a direct SSH link from the Web Ul to connect to the

port.
To access a console port via a Direct SSH link:

1. Locate the particular port by using one of the search techniques discussed in

"Connecting to a node’s serial ports" on page 154..

Locate the particular port by using one of the search techniques discussed in

"Connecting to a node’s serial ports" on page 154..

2. Click the SSH link to connect to the URL.

These auto-generated links use the colon (:) as the field-delimiter. The auto-

generated SSH link has the following form:

ssh://user-name:console-server-name:port-number@lighthouse-

ip-address

Some web browsers associate the colon character with delimiting the protocol at the

beginning of a URI so they don’t pass these auto-generated URIs correctly.

To work around this, the default delimiter character can be changed. To change this

character:
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1. Select SETTINGS > SERVICES > Console Gateway

Q’D SETTINGS

Evaluation Mode
NETWORK CONNECTIONS Currently running in evaluation mode. There is alimit of 5 enrolled nodes. There are 30 days remaining for evaluation.
USER MANAGEMENT CONSOLE GATEWAY
NOTIFICATIONS Console Gateway Port Delimiter D
SERVICES
Cellular Health Reporting Console Gateway SSH Address @

54.79.71.202
Console Gateway

3. Enter a delimited character in the Console Gateway Port Delimiter text-entry

field. The carat, 2, is the most common alternative.

4. Use the Console Gateway SSH Address drop-down menu to choose an
address from which to SSH. The list of available addresses contains the current
network interfaces and external network addresses. The value defaults to
netl:dhcp ifitexists and net1:static otherwise. The additional external
addresses can be added to this list using the SETTINGS > SYSTEM>

Administration page.

To use the console chooser menu, SSH to the Lighthouse appliance with the
username format username:serial. This connects to the Lighthouse and presents a
list of nodes that the user can access. Once the user selects a node, they are
presented with a list of console ports they have access to. When one is selected, the
user is connected to that port. For faster access, there are username format
shortcuts that give more specific lists of serial ports, or direct access without a

menu.
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* username:node_name
When a valid node name is specified, a list of console ports that the user can
access on that node is shown. If they do not have access to this node, the

connection fails.

* username:node_name:port_name
When a valid node name and port name are specified, and the user has access to
that node and port, the user is connected to this port. If they do not have access

to that port, the connection fails.

* username:port_name
When a valid port name is specified, the user is connected to first port with that
port name found. If the user does not have access to this port, the connection

fails.

NOTE: Node names and port hames are not case sensitive.

EXAMPLE CONSOLE GATEWAY SESSION

S ssh adminuser:serial@lighthouse-name-or-ip-here
1: cm71xx

Connect to remote > 1

1: Cisco Console 2: Port 2

Connect to port > 1

router#

SELECTING NODES USING SHELL-BASED TOOLS

There are a number of ways to select nodes, also known as console servers, as
targets on which to run a command. These can be used multiple times, or together,

to select a range of console servers:

Managing Lighthouse Nodes




\ LIGHTHOUSE

Access Portal

Select individually by name, address, Lighthouse VPN address, config index or

smart group (as per --list- nodes output):

node-command —--node-name BNE-R01-IM4248
node-command --node-address 192.168.0.33
node-command —--node-index nodes-1

node-command --smartgroup="model-acm"
To Select all nodes

node-command --all

To running commands on selected nodes

Once nodes are selected, the commands to be run for each can be given. These are
run on each managed node in parallel. Any command which can be run from a node

shell can be run on each managed node.
Note:All commands are run as root.

For example, to check the version on two specific, configured nodes, selecting one

by name and the other by index, run the following command:

node-command —--node-name BNE-R01-ACM7004-5 --node-index
nodes-2 cat

/etc/version

When using non-trivial selection arguments, check which target nodes have been
selected on the initial command pass by using the --11ist-nodes switch rather

than the final command.
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NODE ORGANIZATION AND FILTERING

To provide clear and customized access to nodes, Lighthouse uses Smart Groups
which allow node properties and user-supplied tags, consisting of a name and value,

to be compiled into a search expression.

These search expressions can be saved and used to filter the various lists of nodes
in the Web Ul, for example when selecting a serial port to connect to or to connect to
the node’s Web Ul. They can also be used for define and restrict the nodes that a

particular group of users can access.

To help locate managed devices, Lighthouse includes Port Filtering which allows
users to search for port labels and port tags on a node. This search can be saved
and applied on the MANAGE > MANAGED DEVICES > Console Gateway page.

FILTER NODES

Filters enable you to quickly find a particular node or set of nodes. The filters are:
* Free Text Search
* Smart Group Filtering, and

* Port Filtering.

You can see how to use these in "Monitor Nodes" on page 127.

CREATING SMART GROUPS

Smart Groups are used within Lighthouse to group related nodes.
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Smart Groups can also be used to filter visible nodes on pages that display enrolled
nodes (such as CONFIGURE > NODE Enrollment > Enrolled Nodes) to make it

easier to drill down to a particular console.

Smart Groups are dynamic, when more nodes are added to the system, the filters

update automatically.

A user group can be linked to a particular Smart Group. When a user group is

linked to a smart group in this fashion, members of the group inherit rights over all

nodes in the smart group based on the group’s role. "Modifying existing groups" on

page 237 for how to set a group’s role and linked Smart Group.

To create a Smart Group:

1. Navigate to any page which displays the Smart Group search interface, for

example MONITOR > Nodes.

MONITOR NODES

nnection

8 manace ]

=~ | CONFIGURE

SETTINGS

nnection

NETWORK CONNECTIONS

USER MANAGEMENT

s-3  Last status change 23 hours a

5-i-0d183b6111e9ccf22-3

nodes-1  Last status change 23 hours ago
5-1-0d183b6111e9ccr22-1

hange 23 hours ago

b6111e9ccf22-2

&P 3/4 port(s) configured [m]
&P 3/4 port(s) configured [m]
g0
&P 3/4 port(s) configured [m]
temsperpage | 10

Sort By

Name - Ascending

FILTER BY
Smart Group Filtering @

Select Smart Group...

Status

Any status

Connected
Connected via Cellular

Disconnected

Free Text Search @

Search... X

2. Move to the Smart Group Filtering and select New Smart Group from the

displayed list
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3. Click the Field to search dropdown to select a node attribute to filter on.
FILTER BY
Smart Group Filtering 3@

New Smart Group

d to search Operator

+ Add parameters

X Clear B Save as... Apply

Free Text Search (®

Search... X

Node attributes include details about the device (Internal VPN Address, MAC
Address, Name, Product, SSH Port, Firmware Version, Model, Serial Number,
Node ID, Connection Status, Cell Health), and include any Tags that have been
configured in the system. For filtering access to devices, tags are the most useful

attributes to filter on. When a tag is selected, the Field to search text box contains

tag values.

4. Select the Operator to apply to the Value.

5. Select the Value to be matched against.

6. To enter multiple search parameters, click - Add parameters

7. The AND OR buttons display
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e Select AND if the filter must match all values.
¢ Select OR if one or the other values must match.

8. Enter the additional details in the Field to search, Operator and Value fields.

Note:Note: Click the - button to remove the additional Search parameters if

necessary.

9. Click Apply to see the results of the filter.

10. Click Save As and type in a name for your new Smart Group.
This Smart Group can now be used for filtering nodes for display and for access.
EDITING A SMART GROUP
To edit a Smart Group:

1. Select CONFIGURE > Edit Smart Groups.

(£ MONITOR EDIT SMART GROUPS

Dashboard Adding smart groups is done via the filter menu at the top of any pages centaining a node list.
Click here to go to the managed nodes page.

Nodes

NAME +

Automation P |

& MANAGE

New Smart Group 1 e o
CONFIGURE

NODE ENROLLMENT

o Click @ Delete to delete an existing Smart Group.

3 Click # Edit Group button to change a Smart Group’s name.
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EDIT SMART GROUP

Name ®

Automation

To change the search parameters used by a Smart Group:

1. Navigate to a page that displays Smart Groups for filtering (for example,
CONFIGURE > NODE Enroliment > Enrolled Nodes).

2. Select the required Smart Group to be changed from the Select Smart Group

drop-down menu.
3. Change the Field to search and Operator values as required.
4. Click Save Changes.

5. Retain the Smart Group Name and click Apply. The changed search parameters

overwrite the parameters of the Smart Group.

CREATING PORT FILTERS

Use Port Filters to easily find ports on nodes. The MANAGE > MANAGED

DEVICES > Ports page makes it easier to find a particular port.

Ports are dynamically updated when more nodes with managed devices are added.
Ports can be filtered by multiple parameters using either the AND and OR boolean

operators.

To create a Port Filter:
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. Selectthe MANAGE > MANAGED DEVICES > Ports page.

. On ADVANCED FILTER pane and select Port Filter.

(Z) MoNITOR S rorTS

BASIC FILTER

Free Text Sea ch®
Jobs ] LABEL PARENT NODE + TAGS Search
5 MANAGE -~ . Rout = a
MANAGED DEVICES it ADVANCED FILTER
Switc
O . 13
o v 1 & Smart Group Filtering @
PDU Select Smart Group...
o i . &
R Port Filter
— Router
(m] o » =
a v New Port Filter
- Switc
— ] e - = .
[Z] CONFIGURE v
POU Field to search Ops
AP SETTINGS . =] he =
o o . =
<+ Add parametes
o o . =
v X Clear B Save Changes
oy Apply
0 o - &

. Click Field to search to select a node attribute to filter on.

» Select either Port Label or Port Tag.

. If using Port Labels,click Operator to select the operator to apply to the Value.
. Enter the Value to be matched against.

. To enter multiple search parameters, click - Add parameters

. The AND OR buttons display

* Select AND if the filter must match all values.

» Select OR if one or the other values must match.

. Enter the additional details in the Field to search, Operator and Value fields.
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Note:Note: Click the x button to remove the additional Search parameters if

necessary.

9. Click Apply to see the results of the filter.

10. Click Save As and enter a name for the filter.
The new Port Filter can now be used for filtering nodes by ports.
EDITING AN EXISTING PORT FILTER

To edit an existing Port Filter, select CONFIGURE > Edit Port Filters page.

=5 manace EDIT PORT FILTERS

MANAGED DEVICES N Adding port filters is done in the Advanced Filter panel of the Ports page
Click here to go to the Ports page.

NAME v

New Port Filter- A Q
NODES

New Port Filter- B s Q
LIGHTHOUSE

Port Filter -PDU /7 @

CONFIGURE

Edit Port Filters
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* Click the Delete button to delete an existing Port Filter.

» Click the Edit button to change a Port Filter's name.

EDIT PORT FILTER

Name (@)

New Port Filter - A

To change the search parameters for a Port Filter:

1. Navigate to a page that displays the Port Filters, such as MANAGE > MANAGED
DEVICES > Ports.

PORTS
BASIC FILTER
h_-é MANAGE Free Text Search ®
=] LABEL PARENT NODE v TAGS Search x
MANAGED DEVICES
Router vacm-aws-i-
@] - 52 Status
Poortt 0d7e30aeTeeb39za2-1
Show All
vacn
u] . . [ED) _
0d7e30aeTeeb3gaaz- Configured
NODES
O o ezt Y =
LIGHTHOUSE v (/estasleebatan
. UPS vacn .
Local Terminal u I 0d7e30acTeeb3gaaz-1 ADVANCED FILTER
& Router vacr Smart Group @
CONFIGURE =] o o . Y 52
Y portt 0d7e30aeTeeb3gaaz-2
Select Smart Group.
Man
u] . 2]
Port Filter @
PDU vacm-aws-i- New Port Filter
a] I ‘ i . =)
Y port3 0d7e30aeTeeb392a2-2

2. Select the required Port Filter from the Port Filter list.
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3. Change the parameters (for example, Operator values) as required.
4. Do not change the name of the Port Filter.
5. Click Save as.

6. Click Apply. The modified Port Filter overwrites the existing Port Filter.

Note:Do not change the name of the Port Filter.

UPGRADE NODES VIA THE Ul

When you need to upgrade nodes to the latest firmware, for example, for security
fixes, use the Node Upgrade Ul to upgrade up to 5000 connected nodes per task.
The Node Upgrade Ul allows you to upgrade nodes either immediately or at a

scheduled time, even outside normal business hours.

The Node Upgrade Ul is available in the Web Ul under Settings > Services > Node

Firmware Upgrade.

Completed jobs with the nodes selected can be duplicated so as to allow easy

sequential upgrades. Nodes that failed to upgrade can be re-scheduled.

Upon opening the Node Firmware Upgrade window there are two tabs accessible,

plus access to the upgrade scheduling wizard, these are:

* Upgrade Tasks — a filtered dashboard where you can view scheduled and

completed tasks and see their status.

* File Manager — An area that allows upgrade files to be uploaded and a table that

displays previously uploaded files.
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* Node Firmware Upgrade scheduling wizard —This is where you can set up and
schedule firmware upgrades. The wizard is accessed by clicking on the + button

in the Upgrade Tasks tab.

Completed jobs with the nodes selected can be duplicated so as to allow easy

sequential upgrades. Nodes that failed to upgrade can be re-scheduled.

FIRMWARE FILES

Before you upgrade, you need access to firmware files.

UPLOAD A FIRMWARE FILE

The Node Upgrade Ul is available in the Web Ul under Settings > Services > Node
Firmware Upgrade Use the Upload tool on the File Manager tab to upload one file

atatime.

Note:Only one file may be uploaded at a time using the upload tool. If multiple
files are selected and placed in the drag and drop field, only the last file that was

selected will be uploaded.

1. Select the ‘File Manager’ tab in the Node Firmware Upgrade Ul section.

2. Either select ‘upload afile’ to open an explorer view, then select the file. Or
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3. Drag and drop the file into the upload area.

HODE FIRMWARE UPGRADE

UPGRADETASKS  FILE MANAGER

(L

In-progress uploads can be cancelled by clicking the Close button (X).

The file upload will continue even if you click elsewhere in the Lighthouse Ul,
however, the upload will be cancelled if you close the website or if the HTTPS

connection to Lighthouse is closed.

DELETE A FIRMWARE FILE

The Node Upgrade Ul is available in the Web Ul under Settings > Services > Node
Firmware Upgrade Use the Delete tool on the File Manager tab to delete one file at

atime.
To delete a firmware file that is no longer needed:

1. Select the File Manager tab on the Node Firmware Upgrade Ul page.

2. Click the delete button (¥ ) next to the firmware file you wish to delete.

Note:If the selected firmware file is required by an ongoing or upcoming

firmware upgrade task, an error message displays and the file is not deleted.
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NODE UPGRADE TASKS

To upgrade a node you will need to set up a task.

CREATE AN UPGRADE TASK

The Node Upgrade Ul is available in the Web Ul under Settings > Services > Node
Firmware Upgrade Use the Upgrade tasks tab to

* Upgrade a node

* Schedule a node upgrade

* Upload a new firmware file

To upgrade a node use the task information table:

1. Click the Schedule an Upgrade button (+) above the task information table to

schedule an upgrade (or start one immediately).

2. The Node Firmware Upgrade wizard displays. Enter a nameltitle for the
upgrade task.

NODE FIRMWARE UPGRADE

Setup Upgrade Task Schedule Upgrade Review and Confirm

NEW FIRMWARE UPGRADE TASK

Name @

Select Firmware for Upgrade @

Select Firmware

SELECT NODES

Select Upgrade Firmware to get a list of compatible Nodes

Back - Node Firmware Upgrade Next - Schedule Upgrade
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3. Click the Select Firmware button. The Select Firmware list displays.

SELECT FIRMWARE

Drag your file here or upload a file

system images must have the extension

FILE NAME F/W VERSI( DEVICE FA!

perations_manager-22.06.0-produc-

tion-signad.rauck

m7lxx-4.12.3.flash

acm700x-4.12.3 flash

-

4. Select the firmware upgrade or upload new firmware for the upgrade task. Click

Select Firmware button.
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5. Select the nodes to be upgraded. Select Next - Schedule Upgrade.

SELECT NODES
' A CURRENT NODE
O NODE ID DEVICE NAME MODEL FIRMWARE STATUS
O nodes-25 SPT-ACMT004-5-L ACM7004-5-L 4.9.0ul ]
0O nodes selected tems per page | 10

Back - Node Firmware Upgrade Mext - Schedule Upgrade

Note:Compatible nodes that have already been scheduled for an upgrade
cannot be selected, these are visible in the list but appear greyed-out. Nodes

that are not compatible with the firmware file will not be listed.

6. Select the Start time as either Immediately after creation forimmediate start,

or, Set time. For Set Time , enter the Scheduled time Date and Time.

Note:The scheduled time is always in UTC.
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7. If Upgrade in Failover is selected, it is selected either in bulk, by dropdown

selection (a), or, individually by a toggle switch beside each table row (b):

© o Al— D

Note:Selecting this option may result in considerable cell charges in the event

of a failover.

8. Click Next — Review and Confirm to go to the review screen. Check the
schedule details are correct. To change schedule details, click Back — Schedule
Upgrade, all data local data will be preserved while you change parameters on

previous screens.

9. Select Confirm, and type Yes at the prompt, then click Confirm to create the

task.
CANCEL AN UPGRADE TASK
You can cancel a task that has not yet completed the upgrade.
To cancel an upgrade task"
1. Select Settings > Services > Node Firmware Upgrade

2. Inthe task list, select the task name you wish you cancel, the Task Details screen

displays.

3. Click the X button (top-right) to cancel the task.
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OM-UPGRADE-TASK

reated by root on 20 May 2022 03:27 UTC

Note:You cannot cancel upgrade tasks that have already been completed.

Limitations:

* Do not cancel an upgrade job just as it is about to begin, for example, 10 seconds

before or after the start time.

* If an upgrade is cancelled while in progress, only nodes that have not yet been

upgraded will be cancelled.
COPY A SCHEDULED TASK

You can copy a scheduled task in order to create a new upgrade task. The new
upgrade task will use the nodes that were selected for the original task you are
copying, for example to add or remove nodes from the list. You can also select

different firmware or use the same firmware for the list of nodes.

Note:For a task to be copied, the task must have already run or been cancelled,

and display an Upgrade Status of Completed.

Managing Lighthouse Nodes



\ LIGHTHOUSE

Access Portal

1. Navigate to the Node Firmware Upgrade Home screen. The Node Upgrade Ul is

available in the Web Ul under Settings > Services > Node Firmware Upgrade

%: QPQnQQQf Feedback @ AddNode @ Help @ System & Logout
Lighthouse™ Central Management
USER MANABEMENT Free Text Search ®
Searc x
NOTIFICATIONS
SERVICES
Cellular Healt @
TASKS UPGRADE START UPGRADE END UPGRADE STATUS
Jun 20 2022 04:48 AM Jun 20 2022 D4:53 AM o
cmupgrade ~ o .~ Completed
uTc utc
0M1200 woarede Jun 16 2022 10:48 PM Jun 16 2022 10:51 PM _  Completed
B uTC uTc
OM 20.6 J'TTIE‘EJEEIE:SEDF ",L_'“_]E Ao ~ Completed
uTc UTc

Node Firmware Upgrade

SNMP Manager

2. Select the task you wish you copy, by clicking the task name in the task table

Managing Lighthouse Nodes



\ LIGHTHOUSE

Access Portal

3. Click the Copy button to copy the task

\ opengear

Lighthouse™ Central Management

USER MANAGEMENT

NOTIFICATIONS

SERVICES

Cellular Health Repo

SNMP Manager

rting

CMUPGRADE

Created by root on Jun 20 2022 04:48 AM UTC

TASK STATUS

Completed

1/1 Done

Target Firmware Version

4.12.3

Start Time
Jun 202022 04:48 AM UTC
End Time
Jun 202022 04:53 AMUTC
NODES
NODE ID DEVICE NAME MODEL

4. A new task is created with the same nodes.

DELETE AN UPGRADE TASK

CM7148-2-DAC

Feedback @ AddNode @ Help @ System &lLogout

o e

FIRMWARE & UPGRADE INFAILO UPGRADE STATUS

4.12.0 Dizallow ]

Upgrades cannot be permanently deleted as they can offer a valuable insight into

the health of the nodes when problem-solving and provide the version path that they

have traversed over their lifetime.

If the number of jobs is becoming unmanageable, or jobs need to be deleted for

security measures, the support team will be able to advise on how to remove/clear

them.
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RETRY AN UPGRADE TASK

If an upgrade task fails, you can retry the node upgrades, provided the firmware file

is still available.

1. Navigate to the Node Firmware Upgrade Home screen. The Node Upgrade Ul is

available in the Web Ul under Settings > Services > Node Firmware Upgrade

2. Select the task you wish you retry, by clicking the task name in the task table. You

can filter the task list by using the Completed with Errors filter.

%- openQQOf Feedback (D AddNode @ Help @ System 8lLogou
Lighthouse™ Central Management
] -
] SETTINGS Status @
Show All
NETWORK CONNECTIONS
nProgress
USER MANAGEMENT Scheduled
NOTIFICATIONS Completed
Completed with Errors I
SERVICES
Cancelled
Cellular Health Reporting
Free Text Search &
Search... =
@
TASKS UPGRADE START UPGRADE END UPGRADE STATUS
oM 20.8 Jun 162022 10:38 PM UTC Jun 16 2022 10:41 PM UTC ~ Completac
0OM1200 upgrade Jun 182022 10:48 PMUTC Jun 182022 10:51PM UTC ~ Completed

3. Inthe task detail screen, click the Repeat for failed upgrades button.

TASK STATUS

A TS Repeat for failed upgrades
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Note:If the relative Firmware file has been deleted, the Repeat for failed

upgrades button is not displayed.

4. The Node Firmware Upgrade page displays. See "Create an upgrade task" on

page 174.

NODE UPGRADE RUNTIME BEHAVIOUR

The following describes the behavior of the Node Upgrade tool while performing

routine upgrade tasks.

PROMOTING A SECONDARY INSTANCE TO PRIMARY

* All scheduled upgrades are cancelled when a secondary node is promoted to be

the new primary node.

* Firmware files are not replicated among the multiple instance cluster and must be

re- uploaded to the new primary after promotion.

DOWNGRADING AND SKIPPING VERSIONS

Lighthouse does not allow downgrading of nodes, nor does it allow upgrading to an
identical version. The node upgrade will skip nodes that are at the upgrade version
or later, for example, if upgrading from version 21.Q3 to 21.Q4, it will ignore any
nodes that are already at 21.Q4 or 22.Q1.

Skipping versions

If a node is scheduled to be upgraded from 21.Q3 directly to 22.Q1 (skipping 21.Q4),
it will upgrade the node even if it has been manually upgraded to 21.Q4 before the

scheduled upgrade starts.
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Note:Lighthouse does not check or validate the version jumps for nodes, so
there is a risk that the upgrade could fail if major versions are being skipped.
Skipping versions is not recommended or supported, however, it is not

disallowed.

TIME ZONES

Node upgrades can only be initiated or scheduled by an operator with administrator
credentials while logged in at the primary lighthouse. The scheduling of the node

upgrade is based on the time zone of the primary lighthouse.

If the time zone of the primary lighthouse is changed before a scheduled upgrade
starts, the schedule time will be based upon the new time zone. This may result in
jobs not running at all, being skipped, ignored, or otherwise running at unpredictable

times.

Note:lt is recommended that you avoid changing the system time of lighthouse,

or its time zone, while jobs are scheduled.

OFFLINE NODES

If a node is offline or otherwise unreachable at the time of upgrade, the node will be

skipped.

If the node is offline there is a one minute buffer before the scheduled upgrade is

skipped and Lighthouse will report the node with a failed to upgrade status.
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NODE CONNECTION INTERRUPTED

If the connection to the node is interrupted during the upgrade, the upgrade may be
cancelled and will fail unless the upgrade was in the final stages and had no need for
further interaction with Lighthouse. In this scenario Lighthouse may still report the
node upgrade as failed if it was unable to confirm that the upgrade succeeded due to

the node being disconnected during the validation period.

Failure to upgrade one node does not affect other nodes in the upgrade job.

UNENROLLING NODES AT UPGRADE

Unenrolling nodes as they are being upgraded is not supported as this could result

in unexpected behavior.

LIGHTHOUSE AVAILABILITY AND STABILITY

Lighthouse must be online and fully booted (preferably for at least a few minutes)
before the upgrade starts. It is good practice to have Lighthouse online for a few
hours before a node upgrade. This ensures that all the nodes that will be upgraded

have re-established their connection and allows time to troubleshoot any issues.

Do not attempt to change major Lighthouse settings, especially those involving the

network or timezone, when an upgrade is underway or imminent.

Do not conduct multiple major operations on nodes simultaneously, for example, do
not apply templates to the node while it is being upgraded. Do not login to a node

and change settings moments before an upgrade occurs.

Note:If Lighthouse is offline when a scheduled upgrade is due to start, the

upgrade will not be run.
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MANAGE PORTS

Lighthouse allows you to manage all ports connected to nodes. MANAGE >
MANAGED DEVICES > Ports displays the status and number of all the ports on

Lighthouse, which you have permissions to view/edit.

1. Select MANAGE > MANAGED DEVICES > Ports. The Ports page displays the
Labels, Parent Node and Tags of the connected ports which the user has

permissions to view/edit.

Nodes PORTS

Jobs BASICFILTER
Free Text St h
.E MANAGE ree Text Search @
=] LABEL PARENT NODE + TAGS Search x
MANAGED DEVICES
Rout:
@] oo - 2] Status
Show All
Switch
o Y port A b Configured
NODES Ui f d
PDU nconfigure:
O Yo \ &
LIGHTHOUSE s
- uPs N
Local Terminal u et ADVANCED FILTER
CONFIGURE Router Smart Group @
= o P portl A )
Select Smart Group.
a Switch . &
Y port Port Filter @
PD c New Port Filter
@] i ; : 13 52
| 0d7e30aeleeb39aa2-2

2. BASIC FILTER,and ADVANCED FILTER allow you to sort the display of ports, by
Free Text, Smart Group or Port Filter.

3. The BASIC FILTER Free Text Search allows you to search by the name of a port

label or port tag.

The Port Filter drop down menu allows you to fine tune your search by either

selecting an existing Port Filter or to creating a New Port Filter.
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4. The Tagicon allows you to create, assign or remove a new Port Tag. You

can use port tags to control user access to ports.

You can also access the Web Terminal and SSH links for individual ports via the

icons to the right of each row, if you have the requisite permissions.

FILTERING PAGES DISPLAYING PORTS

If you want to quickly find a particular port or set of ports, you can drill down to
specific ports by using the BASIC and ADVANCED filters. You can filter on:

* Free Text Search

* Smart Group, and

* Port Filters

¢ Status.

The filters can be used independently from each other or in combination.
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1. Select MANAGE > MANAGED DEVICES > Ports. The Ports page displays the

Labels, Parent Node and Tags of the connected ports.

Nodes PORTS

Jobs > BASICFILTER
Free Text St h
.E MANAGE ree Text Search @
@] LABEL PARENT NODE v TAGS Search X
MANAGED DEVICES
Router vacm-aws-i-
13 2] Status
= Y portt © irea0a 39aa -
Show All
o Switch IS &
R port Configured
NODES Ui f d
PDU nconfigure
0 Do . [52)
LIGHTHOUSE e
- uPs N
Local Terminal u et ADVANCED FILTER
CONFIGURE Router Smart Group @
= o Y portt * &l
Select Smart Group.
Switch
a] . [E0)
Y port Port Filter @
PD New Port Filter
o o 13 2]

2. Use the BASIC FILTER and ADVANCED FILTER dropdowns to sort the display
of ports, by Free Text, Status, Smart Group or Port Filter.

3. In Status, you can select to Show All, or Configured or Unconfigured ports.

FILTERING USING THE FREE TEXT SEARCH FIELD

The Free Text Search input field allows near real-time filtering of ports using the

following criteria:

* Port Label

* Port Tag

Enter your search term in the Free Text Search field and click Enter.

The Free Text Search field treats multiple search terms separated by the space
character as being combined with the logical AND operator, returning results only if

all terms are present in the item.
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For example, the search phrase production switch returns only ports that

contain both production AND switch anywhere in searchable fields.

To search for a multi-word term, enclose the search term in double quote
characters. For example, “production switch” will return results only if the

entire search term is matched in the item.

FILTERING USING THE SMART GROUP FILTERING DROP-DOWN
MENU

You can search for groups of ports by using the Select Smart Group field. Enter the
search criteria in Select Smart Group and a menu displays the ports that belong to

the selected group, provided you have the requisite permissions.
See "Creating Smart Groups" on page 163 for how to create such groups.

After a particular Smart Group has been selected, further filtering options become

available under Fields to search:
To add more filtering options:
1. Click Field to search.
2. Select a field and enter a value in the text box.
3. Select an Operator from the drop-down box on the right.
4. Click the + Add Parameters button. Select a parameter.
5. Click Apply.
The list of ports that meet the specified criteria display.

FILTERING USING THE PORT FILTER DROP-DOWN MENU

You can search for groups of ports by using the Port Filter field. Enter the search

criteria in Port Filter and the page displays the ports that belong to the selected

group.

Managing Lighthouse Nodes



\ LIGHTHOUSE

Access Portal

To add a new Port Filter:
1. Click Field .

2. Select a field option such as Port Label or Port Tag and enter a value in the text

box.

3. Select the next Field to Search option such as Port Tag and enter a value in the

text box.
4. For Port Labels you can select an Operator from the drop-down box on the right.

5. If you wish to narrow the search, select +Add Parameters. Select the AND or OR

button to specify the requisite boolean value.
6. You can repeat from step 4 to add more parameters.
7. Click Apply Filter.
8. Click Save Changes. You can also select to Clear.

FILTERING USING THE PORT TAGS

You can search for groups of ports by using the Tags filter on the Manage Port

Tags page.

To find a tag
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1. Select CONFIGURE > Manage Port Tags. The Manage Port Tags page

displays the Tags.|

() moniTor

MANAGE PORT TAGS

® FILTER BY

B manace

ASSIGNED PORTS

[Z] conrisure

2. Enter avalue in the FILTER BY text box, such as a name of a tag, or even part of

aname
3. The Manage Port Tags page displays the list of ports with the selected tag only.

4. You can then click the Assigned Port link to view or manage the tagged ports.

CREATE A NEW PORT TAG

1. Select CONFIGURE > Manage Port Tags. The Manage Port Tags page
displays the Tags and the number of Assigned Ports, if any
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() monToR
Evaluation Mode

MANAGE PORT TAGS
FILTER BY
TAG ¥ .

ASSIGNED PORTS

5 manace

Select © Create New Tag icon on the upper right. The ADD NEW TAG dialog

displays.

ADD NEW TAG

Cancel

1. Enter the port tag name in the field and click Add Tag.
2. You can also enter multiple port tag names separated by commas.
3. The new tags display on the Manage Port Tags page.

4. Click the Assign to Port link to assign the tag to a specific port. The Ports page
displays.
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5. After the tag is assigned, the Manage Port Tags page displays the number of
ports that a tag is assigned to in the Assigned Ports column. You can click on the
number in the Assigned ports column to view a filtered version of the PORTS

page.

EDIT A PORT TAG

Select CONFIGURE > Manage Port Tags. The Manage Port Tags page displays
the Tags.

(Z) monmoR
Evaluation Mode

MANAGE PORT TAGS
® FILTER BY

5 mamace

ASSIGNED PORTS

CONFIBURE

Select the tag to edit. The EDIT <TAGNAME?> dialog displays.
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EDIT $1

B Delete Tag

1. Edit the port tag name in the field and click Update Tag.

2. The edited tag name displays on the Manage Port Tags page.

DELETE A PORT TAG

Select CONFIGURE > Manage Port Tags. The Manage Port Tags page displays
the Tags.
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(Z) moNToR

Evaluation Mode

MANAGE PORT TAGS

@ FILTER BY

ASSIGNED PORTS

Select the tag to delete. The EDIT <TAGNAME?> dialog displays.

EDIT S1

B Delete Tag

1. Click Delete Tag.

2. A confirmation message displays. Click Confirm to delete the tag.
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ASSIGN A PORT TAG

1. Select MANAGE > MANAGED DEVICES > PORTS. The PORTS page displays .

BASICFILTER
Free Text Search @
l}-% MANAGE
PARENT NODE v TAGS Search %
MANAGED DEVICES
A J B [ Status
Show All
s &J bl Configured
NODES Ui f d
nconfigure
- [E ]
LIGHTHOUSE
Local Terminal he ADVANCED FILTER
S t Gl
CONFIGURE . B =@ mart Group @
Select Smart Group...
Mana
- N ~ [ES G
0d7e30aeleeb39aa2-2 Port Filter ®
vacm New Port Filter
rm‘*a A &) B
0d7e30ze

2. You can select one or more ports. Click the tag icon

3. The MANAGE PORT TAGS dialog displays.

MANAGE PORT TAGS - ROUTER

W Select existing tag @ Create new tag

Cancel

4. To assign port tags to the selected port(s), click the Select existing tag button. A

dropdown list of existing tags displays. Select the required tags.

5. Click Confirm on the Confirm Changes message box.
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6. Select the required tag(s) and click Update tags

7. The added tags display on the PORTS page

PORTS
L3
O LABEL PARENT NODE + TAGS
O I;;LITEI" @ vacm sl (52 W s
port

Switch

u A @ vacm LN sH
PDOU

O o @ vacm % ssH
Router

0 ,?TWLLE‘{‘ @ vacm * b4
Switch

D ‘?Pﬂj--‘« 9 vacm \n ISSH|

8. The number of assigned ports also display on the Manage Port Tags page.
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CONFIGURING LIGHTHOUSE

Lighthouse can be customized as required, by the creation of users and user

Groups, for authentication, and to enable network traffic mirroring.

Lighthouse supports the creation of Users and Groups, Authentication and Script
templates. Templates are a centralized way of changing the configuration for
enrolled Opengear console server nodes by pushing pre-defined configuration

templates to selected nodes.

CREATE TEMPLATES

Administrators can access CONFIGURE > CONFIGURATION TEMPLATING >
Users and Groups Templates to create, edit, and delete templates. Each template

must contain at least one group.

Each template contains a list of user-defined groups and/or individual users. Each
group has a defined role which determines what privileges group members have.

User roles are defined by the groups they are a member of.
The available group roles are:

* Node Administrator — maps to the administrator role on the nodes.

* Node User — maps to the ports user role and the pmshell role on the nodes.

Ports access can be restricted if required.
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CREATING NEW USER AND GROUP TEMPLATES

Administrators can access CONFIGURE > CONFIGURATION TEMPLATING >
Users and Groups Templates to create, edit, and delete users and groups

templates. Each template must contain at least one group.

Each template contains a list of user-defined groups and/or individual users. Each
group has a defined role which determines what privileges group members have.

User roles are defined by the groups they are a member of.
The available group roles are:
* Node Administrator — maps to the administrator role on the nodes.

* Node User — maps to the ports user role and the pmshell role on the nodes.

Ports access can be restricted if required.
To create a new users and groups template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups

Templates.

2. Click the + button. The New Users and Groups Template page displays.
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;__E MANAGE
Evaluation Mode
CONFIGURE Currently running in evaluation mode. There is a limit of 5 enrolled nodes. There are 31 days remaining for evaluation.
Manage Node Tags NEW USERS AND GROUPS TEMPLATE
Manage Port Tags TEMPLATE DETAILS
Edit Smart Groups Name
Edit Port Filters
Description

NODE ENROLLMENT

CONFIGURATION TEMPLATING

Apply Templates

SET GROUP LIST

Authentication Templates

Groups provided in this list will replace any user defined groups on the node

Script Templates

GROUP NAME ACTIONS

"EH]WE

3. Enter a Name and Description for a template in the Template Details section.

4. Click the + Add a group button in the Set Group List section to add a new
group. The Group Details dialog loads.

5. Enter a Group Name, a Description, and select a Role for the group.

6. If Node User role is selected, the Restrict accessible Serial Ports checkbox

and Serial Ports range appear.

7. Use the checkbox to restrict access and specify as port or range of ports in the

Serial Ports range text box.
8. Click Apply.

9. Click the + Add a user button in the Set User List section to add new users. The

User Details dialog displays.

10. Enter a Username, a Description, and a Password for the user. Type the

password again in the Confirm Password text box.
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11. Optionally, click checkboxes next to the groups this user should belong to. Only

groups from this template are available.

12. Click Apply.

13. Continue adding new groups and users until finished.

14. Click Save Template.

Note:When a users and groups template is pushed to a node, all custom groups
on that node are replaced by groups defined in the template. If no users are in
the new template, existing users will remain on the node. To push users, the

selected nodes need to be running firmware version 4.3.0 or later.

MODIFYING EXISTING USERS AND GROUPS TEMPLATES

Use the Edit Users and Groups Template dialog to modify a template’s

Description, Group List, and User List.

To modify a template:

1.

Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups

Templates

Edit Port Filters

USERS AND GROUPS TEMPLATES

NODE ENROLLMENT

®
CONFIGURATION TEMPLATING

Apply Templates NAME + DESCRIPTION

ChardofRaa test o
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2. Click Edit button next to the template to be modified. The Edit Users and

Groups Template dialog displays

EDIT USERS AND GROUPS TEMPLATE

MPLATE DETARLS

ringes fon 8 e

Loban prowaed i1 Fn 4 il s By ST oy 0 B e

Mok o s wrar. Son selwched s smed B b rusing Arsswars s 4.7 or daber

-

Make changes to the template’s details, group list, or Individual user list as

required.

Click the x button under Actions next to any groups or users which need to be

removed.

Click Save Template.

DELETING USERS OR GROUPS FROM A TEMPLATE

To delete users or groups from a template:

1.

Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups

Templates.
Click the Edit button in the Actions section of the template.

Click the x button under Actions next to any groups or users which need to be

removed.

Click Save Template to save the changes.
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DELETING USERS AND GROUPS TEMPLATES

To delete a template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Users and Groups

Templates.

2. Click the Delete button next to the template to be removed. The Confirmation

dialog displays.
3. Click Yes in the Confirmation dialog.

The template is deleted.

CREATE AUTHENTICATION TEMPLATES

Only users assigned to the Lighthouse Administrator role can access
CONFIGURE > CONFIGURATION TEMPLATING > Authentication Templates

and create authentication templates.

CREATING NEW AUTHENTICATION TEMPLATES

Only users assigned to the Lighthouse Administrator role can access
CONFIGURE > CONFIGURATION TEMPLATING > Authentication Templates

and create authentication templates.

The supported modes are Local, Radius, TACACS+, and LDAP. For example, if an
authentication template is configured to use RADIUS as an authentication source,
that corresponds to RADIUSDownLocal with Use Remote Groups ticked on the

downstream node.

To create a new authentication template:
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Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication

Templates.

Click the + button. The New Authentication Template page loads.

Bl MEW AUTHEMTICATION TEMPLATE

Looal wsers o

Enter a Name and Description for a template in the Template Details section.

Select a desired Scheme or click Pre-populate to pre-populate a template with

the current Lighthouse remote authentication configuration.

Enter or update authentication settings if required. See 8.10 Configuring AAA for

an example.

Click Save Template.

Note:When an authentication template is pushed to a node, the authentication
settings at that node are replaced by the those defined in the authentication

template.

Note:The authentication templates do not support the full list of settings that the
Opengear console servers support. However, templates can be applied, and

then additional settings configured manually.
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MODIFYING EXISTING AUTHENTICATION TEMPLATES

The Edit Authentication Template dialog allows the template’s Description and

Authentication Settings to be set and changed.

To modify an existing authentication template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication

Templates.

Bl AUTHENTICATION TEMPLATES

2. Click Edit next to the template to be modified. The Edit Authentication

Template dialog displays.
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3. Make required changes.

4. Click Save Template.

DELETING AUTHENTICATION TEMPLATES

To delete an authentication template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Authentication

Templates.

2. Click Delete next to the template to be removed. The Confirmation dialog

displays.
3. Click Yes in the Confirmation dialog.

The authentication template is deleted.

CREATE SCRIPT TEMPLATES

Script Templates allow the user to upload arbitrary shell scripts to be run on a node.
For example, a script may set additional configuration settings not available in other

templates or store additional files onto the node such as certificates.
The uploaded script must have:

* a.sh extension and

* can’t be more than 1MB in size.

Other than those, there are no other restrictions on the script file to be uploaded.
Once saved, the template stores the size and SHA1 checksum of the script. This can

be used to verify the script contents of the template once saved.
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To apply script templates, the selected nodes need to be running firmware version

4 .11 or later.

CREATING NEW SCRIPT TEMPLATES

Script Templates allow the user to upload arbitrary shell scripts to be run on a node.
A script may set additional configuration settings not available in other templates or
store additional files onto the node such as certificates, for example. The uploaded
script must have a .sh extension and can’t be more than 1MB in size. Other than
those, there are no other restrictions on the script file to be uploaded. Once saved,
the template stores the size and SHA1 checksum of the script. This can be used to
verify the script contents of the template once saved. To apply script templates, the

selected nodes need to be running firmware version 4.1.1 or later.

Lighthouse Administrators can create script templates via CONFIGURE >
CONFIGURATION TEMPLATING > Script Templates

To create a new script template:

Configuring Lighthouse



\ LIGHTHOUSE

Access Portal

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.

2. Click the + button. The New Script Template dialog loads.

NEW SCRIPT TEMPLATE
TEMPLATE DETAILS

Hamma

Seaipt ek
N seripl upiasdad

Script size (kB) &
Ma seriph uplesdod

UPLOAD SCRIFT FILE

Seript File &

Browse_.  No file selecied

Mota: To apply script templates, the sefected nodes neod to be nmning firmware version 4.1.1 or lafar

3. Enter a Name and Description for a template in the Template Details section.
4. To select a script to upload, click Choose file.

5. Click Save Template.

Script checksum and Script size are displayed after the template with uploaded

script is saved.

MODIFYING EXISTING SCRIPT TEMPLATES

The Edit Script Template dialog allows the template’s Description, Script

timeout, and Script File to be uploaded. To modify an existing script template:
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1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.

2. Click Edit next to the template to be modified. The Edit Script Template dialog
displays.

3. Make the required changes.

4. Click Save Template.

DELETING SCRIPT TEMPLATES

To delete a script template completely:
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1. Select CONFIGURE > CONFIGURATION TEMPLATING > Script Templates.

2. Click Delete next to the template to be removed. The Confirmation dialog

displays.
3. Click Yes in the Confirmation dialog.

The script template is deleted.

USE TEMPLATES

Users with Lighthouse Administrator privileges (that is, users with the Lighthouse
Administrator role or users who are members of groups with the Lighthouse
Administrator role) can access CONFIGURE > CONFIGURATION TEMPLATING >

Apply Templates and execute templates affecting any node.

Users with Node Administrator privileges (i.e. users with the Node Administrator role
or users who are members of groups with the Node Administrator role) can access
CONFIGURE > CONFIGURATION TEMPLATING > Apply Templates and

execute templates affecting nodes in Smart Groups linked to their role.

APPLY TEMPLATES

Users with Node Administrator privileges (that is, users with the Node Administrator
role or users who are members of groups with the Node Administrator role) can
access CONFIGURE > CONFIGURATION TEMPLATING > Apply Templates and

execute templates affecting nodes in Smart Groups linked to their role.

The following types of templates can be applied to selected nodes
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¢ Authentication

Users and Groups

Script

Netops Module Activation

Port Logging

Apply Templates consists of four stages, each one a step in the overall wizard. The

steps are:
1. Select Template.
2. Select Nodes.

3. Preflight. This test run simulates what happens if the template is pushed to the

selected nodes.

4. Execution.
To apply a template:

1. Select CONFIGURE > CONFIGURATION TEMPLATING > Apply Templates.
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. Select a template from the existing template tree. Template Details populates

with details from the selected template.

\\, LIGHTHOUSE
22.10.0p0

(2 monmoR

APPLY TEMPLATES - SELECT TEMPLATE

Select Template >

Authentication . TEMPLATEDETAILS
o Template Name

Secure Pro

5 MANAGE %

Template Descr

CONFIGURE

Only nodes with the correctly assigned subscription can be selected

NODE ENROLLMENT

Enable Port Logging

CONFIGURATION TEMPLATING i35 =
Disable Port Logging

Apply Templates

. Click Next — Select Nodes. The Select Nodes stage loads.

. Select nodes from the list of enrolled nodes. Smart Group Filtering and Free

Text Search Filtering can be used to narrow down the results.
Note:Third-party nodes are not supported for template execution.

5. Scroll to the bottom of the page and click Next — Preflight. The Preflight stage
loads. To retrieve updated Preflight results and details, click the C Update icon

above the table.

After all nodes finish preflight, a success message displays and the Next — Push

Configuration button becomes active.
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6. Select desired nodes for template execution and click Next — Push

Configuration. The Configuration Status stage loads. To retrieve Push results

and details, click the C Update icon above the table.

After all nodes finish the template push, a success message displays.

MANUALLY ACTIVATE NETOPS MODULES VIA TEMPLATE

Lighthouse Administrators can manually apply the Secure Provisioning, Automation

Gateway, or IP Access to the suitable Opengear Console Server node.

1.

2.

Select CONFIGURE > CONFIGURATION TEMPLATING > Apply Templates

Click Secure Provisioning or IP Access or Automation Gateway under

NetOps Module Activation.

LIGHTHOUSE

22.10.0p0

(2) MoNmoR

Jobs
5 MANAGE
CONFIGURE

NODE ENROLLMENT

Edit Smart Groups

Edit Managed Device Filters

CONFIGURATION TEMPLATING

Apply Templates

Authentication Templates

Script Templates

Feedback @ AddNode @ System and Subscriptions ® Help 3 Logout

APPLY TEMPLATES - SELECT TEMPLATE

Select Template > ...

Secure Provisioning
P Access

Automation Gateway

Port Logging ~
Enable Port Logging

Disable Part Logging

TEMPLATE DETAILS

Template Name

Please choose a template from the list
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3. Click Next — Select Nodes

4. Choose the desired NetOps Console Server nodes by clicking the check boxes
next to them.
Note: Only applicable Console Servers for the module display during this node

selection step.

5 Click Next — Preflight. To ensure the preflight check has succeeded click the C

Update icon above the table.

6. When preflight is complete, click Next - Push Configuration.

CONFIGURATION & TECHNICAL SUPPORT
REPORTS

Lighthouse can generate a technical support report that includes Lighthouse

configuration information and the current system log for the Lighthouse VM.

The support technician may ask for this report if you contact Opengear Technical

Support.

GENERATE A SUPPORT REPORT VIA THE LIGHTHOUSE INTERFACE

To generate a complete configuration and status report regarding a given
Lighthouse VM:

1. Select Help > Technical Support Report

Lighthouse generates this support report on demand and the report includes the

current system log. This process can take several minutes.
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2. Click Download support report.
This downloads a PKZip archive to the local system. The archive’s flename is

structured as follows:

support-[host-name]-[iso-8601-order-date-and-time-stamp].zip

It contains two files:

* system. txt — the configuration information also presented in the Technical

Support Report window.

* messages — the current Lighthouse VM system log.

The two files are also presented in the Support Report text box below the Download
support report link. Because the report includes the current system log, this is a long
but scrollable presentation and is searchable using the web browser’s built-in search

function.

GENERATE A SUPPORT REPORT VIA THE LOCAL TERMINAL
To generate a complete configuration and status report regarding a given
Lighthouse VM:

1. Select MANAGE > LIGHTHOUSE > Local Terminal.

2. Atthe [hostname] login: prompt, enter an administrator username and press

Return.

3. Atthe password: prompt, enter the administrator’s password and press Return.

4. Atthe bash shell prompt, enter
support-report -z > /tmp/support.zip

and press Return
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The -z switch generates the same combined file produced by the Download support

report link noted in the Lighthouse Ul-specific procedure.

Note:In the example above, the redirect saves the generated PKZip file to
/tmp/support.zip. However, be aware that the /tmp directory is deleted during a

reboot, so the file might be saved to a different location.

Here are two options for copying the file from Lighthouse:

* Use SCP from a Mac or Windows client. As scp only requires ssh access, no

additional configuration is required on Lighthouse for this to work.

$ scp root@192.168.0.2:/tmp/support.zip
root@192.168.0.2"'s password:

support.zip 100% 321 604.0KB/s 00:00

For Windows users, WinSCP on Win10 also works.

* Use the FTP client on Lighthouse to copy the file to an FTP server. Passive mode

must be used for this to work. Example:

root@LH5-UK-Lab:/tmp# ftp ftp> open 192.168.0.216

Connected to 192.168.0.216.

220 im7200-demo-uk FTP server (GNU inetutils 1.4.1) ready. Name
(192.168.0.216:root): fred

331 Password required for fred. Password:

230- *** Opengear UK Demo IM7216 ***

230 User fred logged in. Remote system type is UNIX.

Using binary mode to transfer files. ftp> passive
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Passive mode on. ftp> bin

200 Type set to I. ftp> put support.zip

227 Entering Passive Mode (192,168,0,216,208,166)

150 Opening BINARY mode data connection for 'support.zip'.

226 Transfer complete.

4132664 bytes sent in 0.128 seconds (32262492 bytes/s) ftp> quit

221 Goodbye.

LIGHTHOUSE CLI, SERIAL PORT AND REST API LOGGING

Lighthouse offers command line interface (CLI) and REST API logs.
Note:Logging is disabled by default.

Once enabled, CLI and REST API logs can be found in /var/log/messages. All
passwords are masked in the logs so that sensitive information is not stored in plain

text or leaked.

When you enable logging, you do not need to restart or log out and in again. There

are a few caveats:

* CLIlogging only works for interactive (human-controlled) terminals. Commands

generated by automated scripts will be not be logged.

* Commands such as sshor telnet do notproduce logs for the commands sent

over the connection.

* Requests can be logged for all endpoints, however, only endpoints implemented

in Lipy can have responses logged.
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Note:These logs are not intended to be used as a definitive record of all
commands that have ever been run. A malicious user with full root access can

circumvent anything.

For more details see:

https://ftp.opengear.com/download/documentation/api/lighthouse/og-rest-api-

specification-v3-7.html

USING OGCONFIG-CLI TO ENABLE LOGGING
Logging should be enabled using ogconfig-cli. Use the following commands in a

Lighthouse terminal to view, enable or disable logging:

* system.logging cli enabled - Enable/disable logging commands entered

in the Lighthouse Terminal.

* system.logging rest enabled -Enable/disable basiclogging for the
REST API. These logs report the following information about every REST API

call:
* Time
* Request type (GET/POST/PUT/DELETE)
* HTTP status code
* Username
* Source IP Address

* Endpoint
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system.logging rest request enabled - Enable/disable requestlogging
for every REST API call. In addition to the basic logging, also logs the request body

that was provided by the client, if any.

Requires system.logging_rest_enabled to be enabled.

CONFIG SEARCHES USING OGCONFIG-CLI

Simple config searches can be performed from inside ogconfig-cli with the

find command.

Note:The element being searched must be a list, otherwise the command

returns an error.

The syntax is:

find <path of list to search> <element to search for> <value

to search for>

For example, to find enabled users use:

ogcfg > find users enabled true

Or to find the enabled ports on a particular node set:

ogcfg> find nodes[0] .ports mode 'ConsoleServer'

ADD NODE AND PORT TO LIGHTHOUSE LOGS

Node and port logs will log all access to nodes via Lighthouse using the pmshell
function, including which console, and which port was accessed by the user when

logged in.
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When system logging is enabled, user and node selection and user and Port

selection is logged. To enable node and port logging on Lighthouse:
1. Navigate to Lighthouse > Manage > Lighthouse > Local Terminal.
2. Login to a user that has rights to use CLI and ogconfig-cli.

3. Node and port logging can only be enabled through ogconfig-cli as follows

Oncroot@lighthouse:~# ogconfig-cli

ogcfg> set system.logging cli enabled true
root-l-system logging cli enabled: Integer <True> ogcfg> push
OK

ogcfg> exit
After node and port logging is enabled, you can view any logs recorded in your

Lighthouse’s syslog,located at /var/log/messages.

EXAMPLE LOGS

Here is an example of logs without request or response logging:

2020-03-17 15:29:37,237 INFO [root:117] [waitress] POST 400 (root |
192.168.1.1) - /api/v3.4/system/licenses/file
2020-03-17 15:30:23,034 INFO [root:117] [waitress] GET 200 (root |

192.168.1.1) - /api/v3.4/users?page=l&per page=10

Here is an example of logs with request or response logging

Note:These logs differ slightly due to being logged with different systems:
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2020-05-11T05:45:09.567214+00:00 lighthouse rest api log[2465]: PU
200 (root | £d07:2218:1350:4b:a438:£f8ff:fedf:65fc) -
/api/v3.4/system/cli session_ timeout REQUEST={"system cli session_
timeout":{"timeout":0}}
2020-05-11 05:45:18,999 INFO [lipy.logging.rest api:62] [waitress]

200 (root | £d07:2218:1350:4b:a438:f8ff:fedf:65fc) -

T

GET

/api/v3.4/users?page=1l&per page=10 RESPONSE={'users': [{'username':
'root', 'description': 'System wide SuperUser account', 'enabled':
True, 'id': 'users-1', 'no password': False, 'expired': False,

'locked out': False, 'rights': {'delete': True, 'modify': True},

'groups': ['groups-2']}], 'meta': {'total pages': 1}}

ENABLE LOGGING

To enable logging, run these commands on the Lighthouse local terminal:

root@lighthouse:~# ogconfig-cli
ogcfg> set <value> true
root-1-<value>: Integer <True>
ogcfg> push

OK

ogcfg> exit

Replace <value> with the desired setting:
* system.logging cli enabled

* system.logging rest enabled
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* system.logging rest request enabled (requires

system.logging rest enabled)

* system.logging rest response enabled (requires

system.logging rest enabled)
* To check if logging is enabled:

To establish if logging is enabled run these commands on the Lighthouse local

terminal:
root@lighthouse:~# ogconfig-cli ogcfg> print system

This will produce output with Boolean values:

system.logging cli enabled (bool): false
e system.logging rest enabled (bool): false
* system.logging rest request enabled (bool): false

* system.logging rest response enabled (bool): false

DISABLE LOGGING

root@lighthouse:~# ogconfig-cli ogcfg> set <value> false
root-1-<value>: Integer <False>
ogcfg> push OK

ogcfg> exit

Replace <value> with the desired setting:
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system.logging cli enabled
system.logging rest enabled
system.logging rest request enabled

system.logging rest response enabled

SYSLOG EXPORT

Administrative users can specify multiple external servers to export the syslog to via
TCP or UDP.

Select SETTINGS > SERVICES > Syslog.

Feedback @ Add Node

NOTIFICATIONS

SERVICES

Cellular Health Reporting

PORT PROTOCOL
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The Syslog page lists any previously added external syslog servers. To add a new

one,

1. Click the + symbol. The Add External Syslog Server dialog displays.

ADD EXTERNAL SYSLOG SERVER

2. Enter the Server Address.
3. Enter the Protocol, either UDP or TCP.

4. Enter the correct Port. If no port is entered, UDP defaults to port 514 and TCP
defaults to 601.

5. Click Apply.

To edit an existing syslog server, click the Edit button . Delete a server by clicking

the x button.
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CONFIGURING LIGHTHOUSE FOR NETWORK
TRAFFIC MIRRORING

Lighthouse can be integrated with a user's enterprise Intrusion Detection System

(IDS) for real-time detection of security events in their network infrastructure.
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Lighthouse allows users to configure the network traffic tap feature via the command

line interface. The traffic mirroring command:
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» Mirrors all network traffic over the encrypted OpenVPN tunnel between
Lighthouse and the Opengear supported appliances, and forwards all network
traffic as decrypted packets to a configurable endpoint. The endpoint is expected
to be a “gateway” IP address of an external device that is routable from

Lighthouse.

* Preserves the original UDP and TCP/IP header information while mirroring (so

that the IDS can reassemble TCP streams and inspect the payload).
Note:Traffic mirroring is only supported on TCP and UDP.

* Provides an option to add a configurable VLAN tag to the Ethernet header.
* Works with multiple instances.

Only users with sudo access on the primary Lighthouse CLI (for example, via the

admin group) can enable or disable traffic mirroring.
Users must:

* Ensure that the traffic is routed to the required destination in their enterprise

network

* Ensure that their firewall rules allow traffic mirroring.

Note:All functionality is available only via the Lighthouse CLI. There is no Ul or
REST APl interface for network traffic mirroring feature. For detailed CLI usage

see traffic mirroring --help.
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CONFIGURING NETWORK TRAFFIC MIRRORING FOR
MULTIPLE INSTANCES

Network traffic mirroring can configured for multiple instances of Lighthouse. It can
mirror traffic between Lighthouses, and between a node and a dependent
Lighthouse.

If new dependent Lighthouses are added to a network that is mirroring traffic, they

must be re-configured for network traffic mirroring.

Note:All CLI configuration, including enabling and disabling, must be run on the
primary Lighthouse. A dependent Lighthouse can only run the --test and --

status arguments.

Users can specify different settings for each Lighthouse. For example:

* A dependent Lighthouse can have a different VLAN ID (or no VLAN ID), and a

different destination IP

* A dependent Lighthouse can be set to only mirror node traffic, and not multi-

instance traffic. This is useful because the primary is already mirroring that traffic

* You can enable or disable network traffic mirroring per instance.

Note:All newly enrolled secondary Lighthouse instances have network traffic

mirroring disabled by default.
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TROUBLESHOOTING NETWORK TRAFFIC MIRRORING

It is possible that there may be momentary periods of up to a few seconds where
traffic is not being mirrored. For example mirroring outages of a few seconds can

occur during:
» Configuration if changes are being made to the VPN subnet or firewall
* The Lighthouse boot process.

To ensure that traffic monitoring is uninterrupted, avoid rapid changes to

configuration and repeated reboots of Lighthouse.
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MANAGING LIGHTHOUSE USERS

Lighthouse supports locally defined users, and remote users who are authenticated
and authorized by Authentication Authorization Accounting (AAA) systems such as
LDAP, Radius and TACACs+.

Role Description

Users must be members of one or more groups. Each group has a role assigned to it
which controls the level of access that group members have to the system. These

roles are:

Role Description

Lighthouse Administrator The Lighthouse Administrator role is
assigned to groups whose members
need to manage and maintain the
Lighthouse appliance. Members have
access to all data on the Lighthouse
system

Node Administrator The Node Administrator role is
assigned to groups that need to man-
age and maintain a set of Nodes. Each
group with the Node Administrator
role must have an associated Smart
Group which is evaluated to define the
set of nodes that the group members
have access to.

Node User The Node User role is assigned to
groups that need to access a set of
nodes. Each group with the Node User
role must have an associated Smart
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Group which is evaluated to define the
set of nodes that the group members
have access to. Optionally, access to
the managed devices can be limited
by associating the saved Managed
Device Filter with the Node User role.

Group membership can either be defined locally for local users or defined on the

AAA server. Groups that are assigned by the AAA servers must still exist locally.

WORK WITH GROUPS

User groups are used to organize user accounts and their associated privileges. A
user group is associated with a set of nodes, its managed devices and ports, and
users who are members of the group will have access to those devices through

Lighthouse.

For example, administrators can configure port access, and ensure that devices are

only accessible to users with the appropriate permissions.

A group may also be associated with one or more roles, which provide permissions

to access operational features in Lighthouse.

A user may be a member of multiple groups.

ABOUT GROUPS

THE NETGRP GROUP

The netgrp group exists as a convenient way to set the permissions of all users
that only exist on the [AAA] server rather than having to manage the permissions of

every remote-only user.
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Below are some points on how the netgrp group operates:
* The netgrp group exists on all lighthouses but is disabled by default

* Do not enable the netgrp group before configuring its permissions because it

provides admin privileges by default.

 If a user authenticates remotely using a [AAA] server and that user doesn’t yet
exist locally on the lighthouse, then the user is automatically added to the netgrp
group. Note, that a user can exist in the Lighthouse Linux system but not in the

Lighthouse config

There is no hard requirement for a remotely authenticated user to be a member of
the netgrp group when logging in. However, if the netgrp group is the only way the
user gains the required permissions to log in, then they do need to be a member of

the netgrp group and the group needs to be enabled.
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REMOTE GROUPS

When a user authenticates using a [AAA] server, any groups that the server returns
are added to a list of groups that the user becomes a member of. If any of those
groups match a local group on the Lighthouse, then the user becomes a member of

that group and gains any permissions provided by that group.

For example, if a user authenticates remotely and the [AAA] server returns the

following groups:
* my_group1
* my_group2

If the lighthouse has a group called my_group1 but it does not have a group my_
group2 then the authenticated user will gain the privileges provided by my_group1

and the remote group my_group?2 will simply be ignored.

Note:If the user is a member of any other groups locally on the lighthouse, the

user will also gain any permissions provided by those groups.

To summarise, a user will be a member of

* the local groups that the user is locally configured to be a member of AND

* any remote groups returned by the [AAA] server that match groups on the

lighthouse.
If the authenticated user doesn’t yet exist on the lighthouse, the user will be:

* a member of any remote groups that match groups on the Lighthouse AND

* amember of the netgrp group,

Note:The netgrp group is disabled by default.
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If a group is disabled, the user does not get the permissions from that group.
REMOTE GROUP NAME CONVERSION

To further align Lighthouse remote authentication with legacy console servers such
as ACM 7000, remote groups from the [AAA] server are applied as they are returned

but in addition, the remote groups are converted such that:

* uppercase characters are converted to lowercase

* any character that is not a number, a letter, an underscore or a hyphen is

converted to an underscore

* These converted group names are added to the unconverted group names

Some legacy console servers only use the converted group names but Lighthouse

uses both the unconverted and converted remote group names.

If a converted group name is the same as the unconverted group name, the

converted group name is simply ignored.

Below are examples of a remote group name and its corresponding converted group

name:

My Group : my group
My-Group# : my-group
my@group: my group

my#odd@Sgroup : my odd group

CREATING NEW GROUPS AND ROLES

User groups and roles allow you to control access to nodes, managed devices and

ports by creating filters that specify permissions.
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CREATE A NEW GROUP

1. Select SETTINGS > USER MANAGEMENT > Groups and Roles. Select the

User Groups tab.
2. Click + Add User Group. The New Group page opens.
3. Click Enabled to enable group.

4. Enter a Group Name and Group Description.
Note:Group Name is case sensitive. It can contain numbers and some
alphanumeric characters. When using remote authentication, characters from a
user's remote groups that are not allowed on Lighthouse are converted to
underscores during authentication. Local groups can be created that take that

into account, allowing the authentication to continue.

5. If desired, you can select a Linked Port Filter and Linked Smart Group to
associate with this group.
The Linked Port Filter can be used to restrict groups and users to only view

ports that are explicitly tagged for their use.

6. The CLI Permissions section displays Command Line Interface(CLlI)
permissions based on the roles you have assigned to this group. To change the
permissions, you can edit or add new roles with the desired CLI Permissions. See

"Create a new Role" on page 239.

7. Add one or more roles by clicking Add Role and checking the desired roles.
Each role has specific operation permissions associated with it and CLI
(Command Line Interface) access levels for console shell, shell, and PM

shell. Click view details to see the information for each group.
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8. You can also control the new group’s permissions independently of the roles you
add to your group. Scroll to the bottom of the page to specify Full Access, Read

Only, or Deny. Click to the right of each Operation row to see all options.
Note:See Available Operations Permissions for a list of all options.

9. Click Save Group.

AVAILABLE ROLES:

Lighthouse Administrator: Members of groups with this role have Full access

to all nodes and managed devices.

* NodeAdmin: Has no shell access. Has Read Only access to Netops Modules,
all Nodes & Configuration Operations, Cell Health, Smart Groups, Tags, and
Jobs.

* NodeUser: Has PM Shell access. Has Read Only access to Nodes & Devices

(Base) and Tags.

* Lighthouse Reporter: Has no shell access. Has Read Only access to all

Operations.

You can also create a custom role that allows you to modify CLI Permissions and
Operations Permissions by clicking"Create a new Role" on page 239 on the New

Group page.

A new role can also be based on an existing role with the Use as template link on

the upper right of a role’s detail page.
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AVAILABLE OPERATIONS PERMISSIONS:

* Logging
Port Logging — Manage port logging settings.

Syslog — Manage system syslog settings.

* Netops
Netops Modules

* Nodes & Configuration

Nodes & Devices (Base) — Access to dashboard, nodes, managed devices, node
Enrollment, console gateway, and Node web UlI.
Nodes & Devices (Advanced) — Access to jobs, pending nodes, smart groups,

and managed device filters.

Nodes Firmware Management

Template Push — Manage templates and push templates to nodes.

* Service Settings
LHVPN
Cell Health
Console Gateway
Date & Time
HTTPS
Netops — Install Netops modules and manage local Netops repositories.

Node Backup

Session Settings. Check if this will cause any conflicts with Multiple instance

permissions.
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SNMP
SSH
Syslog

* Smartgroups & Tags
Bundles — Manage and use bundles.
Smart Groups — Manage and use smart groups.

Tags — Manage and use tags.

* System
Admin & Licensing — Manage access settings for Lighthouse and license settings.
Backup & Restore
Jobs
Multi-instance — Manage multi-instance settings and control state of instances.
Network Interfaces — Manage network interface settings.

System Upgrade & Reset

* Users & Permissions
Authentication — Manage authentication settings including methods, policies, and
restrictions.
Groups & Roles — Create and edit groups and roles. May not assign them to
users.

Users — View, manage, create, and delete users.

Note:\WWhen a new group is given the Lighthouse Administrator role,
members of the group have access to the sudo command. Groups or users

with the Lighthouse Administrator role are added to the admin group, which is
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in the list of allowed sudoers. On first boot of a new Lighthouse instance, the
root user is the only member of the admin group and the only user with sudo

access.

MODIFYING EXISTING GROUPS

To modify an existing group:

1. Select SETTINGS > Groups and Roles. If necessary, click on the USER
GROUPS tab.

2. Click the name of the group to be modified.
3. Click the Edit icon on the upper right and make desired changes.

4. Click Save Group.

WETGAP
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The group details page allows the group’s Description, Access Controls, Roles,

Linked Smart Group, and Port Filter to be set and changed.
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If a Group’s Role is Lighthouse Administrator, the group’s Smart Group is All
Nodes and Port Filter is All Ports. This cannot be changed. If a Group has a Smart
Group other than All Nodes or a Port Filter other than All Ports, the group’s Role

cannot be set to Lighthouse Administrator.

The Groups page also allows you to delete groups. All users who were members of

the deleted group lose any access and administrative rights inherited from the

group.

Note:The netgrp group is inherited as the primary group for all remote AAA
users who are not defined locally on Lighthouse. By default, netgrp has the

Lighthouse Administrator role and is disabled - it must be enabled to take

effect for remote AAA users.

USE AN EXISTING GROUP AS A TEMPLATE FOR A
NEW GROUP

To use an existing group as a template for a new group:

1. Select SETTINGS > USER MANAGEMENT > Groups and Roles. If necessary,
click on the USER GROUPS tab.

2. Click the name of the group to be used as a template.

3. Click the Use as Template icon on the upper right. This opens a new group page

with the settings from the group you selected as a template.
4. Change the Group Name and make and other desired changes.

5. Click Save Group.
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CREATE A NEW ROLE

You can create a new role in two ways, either from the Roles tab or by using an

existing role as a template.

To create a new role from the Roles tab:

1. Select SETTINGS > USER MANAGEMENT > Groups and Roles.

2. Click the ROLES tab.

MONITOR &

Evaluation Mode

GROUPS AND ROLES

USERGROUPS ROLES

B manace
— Filter roles by name
2] conrieure
o
SETTINGS
= NAME

"WORK CONNECTIONS
NETWORK CONNECTION LighthouseAdmin

USER MANAGEMENT NodeAdmin

Groups and Roles NodeUser

Reporter

Currently running in evaluation mode. There is a limit of 5 enrolled nodes. There are 10 days remaining for evaluation.

DESCRIPTION GROUP USAGE PERMISSIONS

Lighthouse Administrator

No dministrator

Node Ut

Lighthouse Reporte
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3. Click + button. The Create Role page opens

CREATE ROLE

Role Name

Role Description

CLIPERMISSIONS

Console Shell Access Level @

Admin Standard Disabled

Shell Access @

Enabled Disabled

PM Shell Access ®

Enabled Disabled

4. Enter a Role Name and Role Description.

5. Modify the CLI Permissions for as desired.
Console Shell Access: Ability to connect to nodes’ command lines via
Lighthouse’s SSH.
Shell Access: Ability to access Lighthouse’s command line as administrator.

PM Shell Access: Ability to connect to serial ports via SSH.

6. You can also control the Operation Permissions for the new role independently.
Specify
Full Access,
Read Only, or
Deny.

Click to the right of each Operation row to see all options.

Note:See Available Operations Permissions for a list of all options.
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7. Click Save Role.
To create a new role from an existing role:

A new role can also be based on an existing role with the Use as template link on

the upper right of a role’s detail page.

1. Select SETTINGS > USER MANAGEMENT > Groups and Roles.
2. Click the ROLES tab.

3. Select the role you wish to copy from the list.

4. Click Use as template. The Create Role tab displays with all the settings of the

existing role. Make changes if necessary.

5. Click Save Role to create the new role.

WORK WITH USERS

You can create new users, edit existing users, delete users and alter groups and
permissions. Users can be either local users or remote users, in both instances you
must understand how users must be authenticated. Lighthouse allows users to use

the following authentication modes:
* LDAP

* RADIUS

 TACAS

The root user can be authenticated by AAA but it will always try local auth for the

root user first.
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AAA MODE COMPARISON

Password And Group

Source

Extra Notes

(Radius, Tacacs+,
Ldap)

name/password provided
by the user is ONLY tested
against the [AAA] server.
Groups: Union of the user’s
local groups and their
[AAA] groups. If the user
didn't exist locally and suc-
cessfully authenticated via
[AAA], the user is also
added to the netgrp

group.

Local Authentication: Local only All users must exist
Groups: Local locally before they can
login.
[AAA] Authentication: the user- If there is a local user

with the same
username as the [AAA]
user and that user tries
to login with the local
password, login will be
denied UNLESS the
local password is the
SAME as the remote
password,that is, the
remote password is

used to login.

If the [AAA] server is
unreachable, the only
user that can
authenticate locally is

root.
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Password And Group

Source

Extra Notes

Local[AAA] (LocalRa-
dius, LocalTacacs+,

LocallLdap)

Authentication: The user-
name/password provided
by the user is first tested
locally and if local authen-
tication fails then the
[AAA] server is used.
Groups: Union of the user’s
local groups and their
[AAA] groups. If the user
didn't exist locally and suc-
cessfully authenticated via
[AAA], then the user is also
added to the netgrp group.

Basically, the user can
log in with either their
local password (if the
user exists locally) or
their [AAA] password
(if the user exists in
the [AAA] server). The
main point is that the
username/password is
tested locally first and
if it fails, [AAA] auth is
attempted with the
same username and

password.

[AAA]Local (Radi-
usLocal, Tacac-

s+Local, LdapLocal)

Authentication: The
username/password
provided by the user is first
tested by the [AAA] server
and if [AAA] authentication
fails then the credentials
are tested locally. Groups:

Union of the user’s local

Basically, the user can
log in with either their
local password (if the
user exists locally) or
their [AAA] password
(if the user exists in the
[AAA] server).
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Password And Group

Source

Extra Notes

groups and their [AAA]

groups.

If the user didn’t exist
locally and successfully
authenticated via [AAA],
then the user is also added

to the netgrp group.

The main point is that
the
username/password is
tested by [AAA] first
and if it fails, local auth
is attempted with the
same username and

password.

[AAA]DownLocal
(RadiusDownLocal,
Tacacs+DownLocal,

LdapDownLocal)

Authentication: Local
authentication is ONLY
used if the [AAA] server is
urnreachable. Otherwise
[AAA] authentication is
always used. Groups:
Union of the user’s local
groups and their [AAA]
groups. If the user didn't

exist locally and suc-

This should behave
exactly the same as
the [AAA] mode until
the [AAA] server is
unreachable at which
point, local authen-

tication is attempted.

cessfully authenticated via
[AAA], then the user is also

added to the netgrp group.
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ABOUT NON-SYSTEM USERS

There are two main types of non-system users in Lighthouse (non-system users

include users other than root and users that exist for the purpose of providing

services on the Lighthouse):

1.

Users added via the UI/REST API or Lighthouse config: These users are added
by using the Ul or the REST API (or even the ogadduser CLI command).

* These users exist in the Lighthouse config/database and are visible in
the Ul and REST API

* The users are added as standard Linux users and can be seen in

/etc/passwdand /etc/shadow

Users added via [AAA] authentication: These users are created in the Lighthouse
Linux system when the user doesn’t already exist locally and the user has

successfully authenticated remotely via [AAA]

These users are simply added to the Linux OS and can be seen in

/etc/passwd.

These users are NOT visible in the Lighthouse config/database or Ul and REST
API

LOCAL USERS ADDED BY AAA AUTHENTICATION

If a user does not exist locally on the Lighthouse when the user authenticates

remotely via [AAA], then the user is added to the linux system but NOT into the

lighthouse configuration/database. This means:

* These users are not visible in the Ul or config/database

* These users are visiblein /etc/passwd
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Also, a user that is created locally after authenticating via [AAA] is automatically
added to the netgrp group, even though that group may be disabled (which it is by
default). "About Groups" on page 229.

CREATING NEW LOCAL USERS

To create a new local user:

1. Select SETTINGS > USER MANAGEMENT > LOCAL USERS.

By default, the root user is the only user listed.

2. Click the + button. The New User page displays

Wi R

3. Enter a Username, Description, and Password.

4. Re-enter the Password in the Confirm Password field.

5. Select the User Enabled checkbox.

6. Click on Add User Group to add this user to any existing User Groups.

7. Choose which CLI options this user should have.
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8. Select any Operation Permissions this user should have. See "Create a new

group"

9. Click Save User.

Note:When a new user is created, an entry is added to the syslog, indicating the
new user's name, the user that performed the operation, database queries, and

the time that it occurred:

2020-05-22T16:22:46.490627+01:00 localhost rest api log[62]: GET 200

(root | 192.168.1.230) - /api/v3.5/users?page=l&per page=10 RESPONSE=
{'users': [{'username': 'root', 'description': 'System wide SuperUser
account', 'enabled': True, 'id': 'users-1', 'no password': False,
'expired': False, 'locked out': False, 'rights': {'delete': True,
'modify': True}, 'groups': ['groups-2']}, {'username': 'fred',
'description': 'fred', 'enabled': True, 'id': 'users-2', 'no_
password': False, 'expired': False, 'locked out': False, 'rights':
{'delete': True, 'modify': True}, 'groups': ['groups-2']}], 'meta':

{'total pages': 1}}

If the created user is set to disabled, the configurator users message does

not appear as they have not been added to the passwords file.

The syslog can be accessed from Lighthouse by clicking Help > Technical Support

Report.
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CREATE NEW LOCAL USERS FOR REMOTE
AUTHENTICATION

To create a new user without a password which causes them to fail back to remote

authentication:

1. Select SETTINGS > USER MANAGEMENT > Remote Authentication

ﬁ% |Z_3|%|'(|]TH0USE B4 Feedback @ AddNode (@ Systemand Subscriptions @ Help &) Log out
Nodes REMOTE AUTHENTICATION
Jobs SETTINGS
- Scheme
B manase
RADIUS
@ CONFIGURE
Mode

¢ sETTINGS

RADIUSDownLocal
NETWORK CONNECTIONS

A —— REMOTE AUTHENTICATION SERVERS
ADDRESS PORT (DEFAULTS TO 612
10.10.10.10 1812 ==
REMOTE ACCOUNTING SERVERS

ADDRESS PORT (DEFAULTS TO 1813)

10.10.10.10 1813 = Ea

2. Choose a remote AuthenticationScheme and enter appropriate settings.
3. Click Apply.

4. Select SETTINGS > USER MANAGEMENT > Local Users
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5. Click the + button. The New User dialog loads.
% IZ_KI_%I_-(I]THD“JSE

Feedback @ AddNode @ Systemand Subscriptions ® Help & Logout

»

Nodes Evaluation Mode

Currently running in evaluation mode. There is a limit of 5 enrolled nades. There are 31 days remaining for evaluation.
Jobs

B manace NEW USER
[&] Username
[&] conricure

Operatro88
P seTTiNGs

Description
NETWORK CONNECTIONS

Localuser

USER MANAGEMENT

O User Enabled

Remote Password Only &
Password @

Confirm Password

LISFR GRNIIP NAMF NFSCRIPTION STATHIS N

6. Enter a Username and Description.

7. Select the Remote Password Only checkbox.The Remote Password Only

checkbox only displays if you set up the Scheme correctly in Step 2.

8. Select the Enabled checkbox. The Password and Confirm Password fields are
disabled.

9. Selectthe Remote Password Only checkbox. The Password and Confirm
Password fields are disabled.

10. Click Save User.

Note:\When a new user is created, an entry is added to the syslog, indicating the

new user's name, the user that performed the operation, database queries, and
the time that it occurred:
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2020-05-22T16:22:46.490627+01:00 localhost rest api log[62]: GET 200

(root | 192.168.1.230) - /api/v3.5/users?page=l&per page=10 RESPONSE=
{'users': [{'username': 'root', 'description': 'System wide SuperUser
account', 'enabled': True, 'id': 'users-1', 'no password': False,
'expired': False, 'locked out': False, 'rights': {'delete': True,
'modify': True}, 'groups': ['groups-2']}, {'username': 'fred',
'description': 'fred', 'enabled': True, 'id': 'users-2', 'no_
password': False, 'expired': False, 'locked out': False, 'rights':
{'delete': True, 'modify': True}, 'groups': ['groups-2']}], 'meta':

{'total pages': 1}}

If the created user is set to disabled, the configurator users message does

not appear as they have not been added to the passwords file.

The syslog can be accessed from Lighthouse by clicking Help > Technical Support

Report.

MODIFY EXISTING USERS

To edit settings for an existing user:
1. Select SETTINGS > USER MANAGEMENT > Local Users

2. Click the name of the user to edit this user and make desired changes. You may
change CLI access and specific access to operations. You may also control

which groups this user is a member of.
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3. Click Save User.

WO G

The Edit Users dialog also allows the user’s Description to be changed and the

user’s Password to be reset. The username cannot be changed. To disable a user,
uncheck the Enabled checkbox.

Note:Disabled users cannot login to Lighthouse using either the Web-based
interface or via shell-based logins (thatis sshusername-

disabled@lighthouse-name-or-ip). The user and the /home/username-
disabled directory still existin the Lighthouse VM file system.

EXPIRE USER PASSWORD

You can set user passwords to expire. To ensure a user’s password is set to expire:
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1. Select SETTINGS > USER MANAGEMENT > Local Users.

2. Click the Expire Password button in the Actions section of the user to be
deleted.

—_

= LOCAL USERS
(2] conFicure

P serTiNes

NETWORK CONNECTIONS
J USERNAME DESCRIPTION
USER MANAGEMENT

0 root System wide SuperUser account @
Groups and Roles

J andrewp @ [ ]
Local Users

@] pleb password pleb @ []

Remote Authentication

3. Click Yes in the Confirmation dialog.

The next time this user logs in, the user will be required to change the password.

SETTING LOGIN RESTRICTIONS

Login restrictions can be applied by administrator users to prevent unauthorized
login attempts via the Ul and REST API.

Note:This does not affect SSH or Console logins.
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1. Select SETTINGS > USER MANAGEMENT > Login Restrictions.
LOGIN RESTRICTIONS

A Warning:Setting up restrictions can cause the system to be inaccessible inan emergency

Enabled Disabled

Maximum attempts

B

Lockout periodiminutes)

5

2. Enter a value for either or both of the following:

* Maximum attempts — choose a number of attempts a user can enter an

incorrect password before being locked out.

* Lockout period — enter a number of minutes until a user can try to login again

after reaching maximum incorrect login attempts.
After a user has been locked out, an administrator can unlock the account.

1. Goto SETTINGS > USER MANAGEMENT > Local Users.

2. Click the Unlock button associated with the locked out user’s row in the User

table.
o Superlser account m
T

Managing Lighthouse Users



\ LIGHTHOUSE

Access Portal

DISABLING A LIGHTHOUSE ROOT USER

To disable a root user:

1. Make sure that another user exists that is in a group that has the Lighthouse

Administrator role.
2. Select SETTINGS > USER MANAGEMENT > Local Users
3. Click Disable in the Actions section of the root user.

4. Click Yes in the Confirmation dialog.

To re- enable the root user, login as another user with Lighthouse Administrator role

and enable access for root user from Actions section on Users page

An Identity Provider (IdP) stores and manages users' digital identities An IdP may
check user identities via username-password combinations and other factors, or it
may simply provide a list of user identities that another service provider (like an
SSO) checks. An IdP can authenticate any entity connected to a network or a

system, including computers and other devices.

DELETE AND DISABLE USERS

You can delete users and disable root users.

To delete a user:

1. Select SETTINGS > USER MANAGEMENT > Local Users

2. Click the Delete button in the Actions section of the user to be deleted.

3. Click Yes in the Confirmation dialog.
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Disabling a Lighthouse root user
To disable a root user:

Make sure that another user exists that is in a group that has the Lighthouse

Administrator role.

1. Select SETTINGS > USER MANAGEMENT > Local Users
2. Click Disable in the Actions section of the root user.

3. Click Yes in the Confirmation dialog.

To re-enable root user:

1. Log in with an existing user id that is in a group with the Lighthouse Administrator

role.

2. Click Enable in the Actions section of the root user.

An Identity Provider (IdP) stores and manages users' digital identities. An IdP may
check user identities via username-password combinations and other factors, or it
may simply provide a list of user identities that another service provider (like an
SSO) checks. An IdP can authenticate any entity connected to a network or a

system, including computers and other devices.

SAML CONFIG FOR SSO

SAML is the framework used to integrate applications with identity providers for
single sign-on (SSO). This is mostly (if not completely) reflected when a user logs in
and authenticates with their IdP or is already logged in (if they have already

authenticated with their identity provider prior to accessing Lighthouse).
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Lighthouse supports the independent, concurrent use of both SAML and AAA
authentication. SAML authentication is independent of, and does not interact with,

other authentication methods.

Note:Forrelease 2023.10 SAML is only supported for authentication to the
lighthouse Web GUI.

When SAML is configured and enabled, users can authenticate to the Lighthouse
Web GUI either through SAML or another configured authentication mechanism
such as Local or AAA. Users can SSH only via the other configured authentication

mechanism (Local or AAA) if Remote Authentication is configured.

The default authentication is Local, with Lighthouse using locally defined users and
groups. If AAA (TACACS, RADIUS or LDAP) Remote Authentication is configured,
this will be used for Web GUI and SSH login authentication to Lighthouse (except for
root which is always locally authenticated). Users are authenticated against AAA
server(s) with group membership returned to Lighthouse, which is used to determine
user roles and permissions. AAA Remote Authentication can support 2FA/MFA,

depending on the AAA server capabilities.

Lighthouse’s SAML integrates with the following identity providers:
+ OKTA

* Azure Active Directory (Azure AD)

* One Login

¢ AuthO
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Note:In the following instructions, any text in braces {} for example, {main
lighthouse address} needs to be substituted with the value for your

environment.

Common values you will need are:

{main lighthouse address} - The address (withoutthe protocol or path) most
users use to connect to your primary lighthouse's web interface. e.g.

lighthouse.example.comor192.168.1.10

{provider} - Each IdP implements the spec slightly differently lighthouse needs to
know which style to expect to handle these differences. If your IdP is not one of our
officially supported IdPs, try configuring lighthouse using the generic provider
option as the most widely applicable. (You could also try using our other explicit IdP

options but these often expect provider specific intricacies).

Please also review the "Limitations of SAML Configuration" on page 277.

GENERIC IDP SETUP

This section describes how to integrate Lighthouse with your Generic Identity

Provider (IdP) Application.

In case Lighthouse's supported IdPs doesn't include your identitiy provider, use the
Generic IdP setup. This has been made as general as possible to meet expectations

of all IdPs in the market today.
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Note:You must have your user groups setup in Lighthouse prior creating &
assigning them via the IdP. See the example in step 6 of the Okta configuration

later in this topic.

Note:The {provider} inthe steps must exactly match one of our provider

strings that is, generic, okta, azure ad, onelogin.

Create an application integration for "Lighthouse" in your IdP

2. Set ACS or consumer URLas https://{main lighthouse

address}/api/v3.7/sessions/saml/sso/{provider}

3. Setthe Allowed SSO URLs or Allowed redirect URLs or ACS URL Validator

to include or match the /saml/sso/ URL for each address of each of your

Lighthouses that you want users to be able to login from.

Example:

https://{main lighthouse address}/api/v3.7/sessions/saml/sso/

{provider}

https://{main lighthouse ip address}/api/v3.7/sessions/saml/sso/

{provider}

https://{secondary lighthouse address}/api/v3.7/sessions/saml/sso/

{provider}

Depending on your IdP you may need to include the /saml/sp init/ URLs.

https://{main lighthouse address}/api/v3.7/sessions/saml/sso/

{provider}

https://{main lighthouse address}/api/v3.7/sessions/saml/sp init/
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{provider}

https://{main lighthouse ip address}/api/v3.7/sessions/saml/sso/

{provider}

https://{main lighthouse ip address}/api/v3.7/sessions/saml/sp init/

{provider}

https://{secondary lighthouse address}/api/v3.7/sessions/saml/sso/

{provider}

https://{secondary lighthouse address}/api/v3.7/sessions/saml/sp_

init/{provider}

4. Setthe Service Provider EntityID or Audience as 1ighthouse-{provider}
5. If your service provider requires you to configure the Recipient

* And only allows a single value

* And you run multiple Lighthouses or access Lighthouse via multiple addresses

Then either:

» Set the recipient as lighthouse-{provider} and use the onelogin option as your

provider configuration.

* Orif you only access each via a single address you could create a separate

application integration per lighthouse.
6. If your IdP has the option then set the initiator tothe Service Provider

7. Setyour IdP to sign the Assertion for SAML
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GENERIC IDP SAML ATTRIBUTE

You will also need to configure your |dP to send an additional attribute LH Groups

as part of the SAML response.

In most IdPs this is done by adding an Attribute Statement or Parameter
configuration in your application integration. This parameter should be set as a
multi-value parameter, that is, multiple values should be provided by multiple

duplicative either Attribute Value tags or Attribute tags in the SAML assertion.

We recommend setting the value of this attribute to be populated with the names of
the user's Roles (or Groups) in your IdP. This method allows you to create roles in
your IdP with the same names as the user groups on your lighthouse that can be

assigned in your IdP to grant users that level of access to lighthouse.

Alternatively, you can populate the LH Groups attribute with the names of the
lighthouse user groups the user should be granted by any other mechanism that

your IdP provides, that is, custom user properties

Note:Your IdP can populate the LH Groups attribute to place users in any
Lighthouse user group except Lighthouse’s default admin group. You can allow
users to login with admin privileges by simply creating another user group in
lighthouse with the admin role and assigning the matching role/group in your

|dP to the user (that is, populate LH Groups to include its value).

Managing Lighthouse Users



\ LIGHTHOUSE

Access Portal

LIGHTHOUSE SETUP

You will need to export an IdP metadata xm1 file for your Lighthouse application
integration from your IdP. If your IdP requires that requests be signed by the Service
Provider then you will also need to provide an x509 certificate & private key in .pem

format (either exported from your IdP or created locally then configured in your I1dP).

1. Upload your IdP metadata XML (and if required certificate & private key) to your

primary Lighthouse i.e. scp

2. Usethe saml-idp-metadata command to configure each lighthouse
individually. Each Lighthouse is configured individually with the same or a

different metadata xml (and certificate + key).

Note:Note: the commands to configure each Lighthouse individually, all must

be run from your primary Lighthouse.

# Example: Configuring a Multi-Instance Lighthouse for Okta IdP
# List initial lighthouse configurations (i.e. none)
saml-idp-metadata list

# Configure Primary lighthouse

saml-idp-metadata create \

--metadata metadata.xml \

--provider okta \

--1lh-id 1

#Configure Secondary lighthouse

saml-idp-metadata create \

--metadata metadata.xml \

--provider okta \
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--1lh-id 2
# List lighthouse configurations (i.e. both lighthouses configured)

saml-idp-metadata list

Specific examples of IdP setups are available, The following are examples of how
you could configure officially supported IdPs. They are based on the above generic

step and the IdP’s configuration options as of 10/2021.

EXAMPLES OF SPECIFIC IDP SETUPS

The following are examples of how you could configure officially supported IdPs.
They are based on the above generic step and the IdP’s configuration options as of

10/2021.

OKTA

CREATE AN APPLICATION

You need to create an application that Okta will be doing authentication on behalf of.

Note:You'll need to know what the addresses of your Lighthouses before

creating the application.
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1. In the Okta web console go to Applications - > Applications
a. Click Create App Integration
b. Select SAML 2.0
2. Give the application a name: for example, Lighthouse and click Next

3. Forthe Single sign on URL enter
https://{main lighthouse

address}/api/v3.7/sessions/saml/sso/okta
a. Select:
i. Use this for Recipient URL and Destination URL

b. Fill out the Other Requestable SSO URLs with the SSO URLSs for every
lighthouse address you want to be able to sign in with. i.e. IP addresses and

DNS address for both your primary and secondary lighthouses.

Example:

https://{main lighthouse ip}/api/v3.7/sessions/saml/sso/okta
https://{dependent lighthouse
address}/api/v3.7/sessions/saml/sso/okta

https://{dependent lighthouse

ip}/api/v3.7/sessions/saml/sso/okta
4. Forthe Audience URI (SP Entity ID) enter 1ighthouse-okta

5. Set Name ID format to email.

6. Setto email.
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7. There are many ways you could configure Okta to populate the LH Groups
attribute, our recommended way is to populate it from and manage it via the

user’s Okta groups:

a. Add a Group Attribute Statement
i. Name: LH Groups
ii. Name Format: Basic

*

iii. Filter: Matches Regex .

8. Click Next and finish.
IdP Metadata

1. Open your Onelogin application.

2. Go to More Actions > SAML Metadata. This is the metadata xml file that you will

need to configure lighthouse.
Configure Lighthouse

1. Copy the Identity Provider metadata XML to your primary lighthouse.

2. Using saml-idp-metadata on your primary lighthouse, configure each of your

lighthouses to use your IdP

For example:

saml-idp-metadata -p {root password} create -m /path/to/okta

metadata.xml -P okta -n "My Okta display name" -1 {LH id number}

Groups setup
After this initial setup, you will be able to login as a SAML user.

If you do not already have your own User groups setup in lighthouse:

Managing Lighthouse Users



10.

11.

\ LIGHTHOUSE

Access Portal

. Login to Lighthouse as a local user (or any non-SAML user) i.e. root

Create the User groups with the Roles and permission that you desire. See

“'Creating new user and group templates" on page 198”.

. In Okta go to Directory > Groups.

Click Add Group.

Enter the Group name that matches a Group name on lighthouse.
Open your new group.

Go to Manage Apps.

Search for your lighthouse app and click Assign.

Click Done.

Go to Manage People

Search for and click on the users you wish to add to the group.

The assigned users are now able to login to lighthouse with the permission levels

which that group grants them.

ONELOGIN

Create an Application. You need to create an application that Onelogin will be doing

authentication on behalf of.

1.

Go to Applications > Add App > Search for and choose SAML Custom

Connector (Advanced)

Name your connector, that is, Lighthouse.

. In the Configuration tab for your new app

Managing Lighthouse Users



\ LIGHTHOUSE

Access Portal

a. Set Audience (EntitylD)to 1ighthouse-onelogin
b. Set Recipientto l1ighthouse-onelogin

c. Set ACS (Consumer) URLto: https://{main lighthouse address}/ap-

i/v3.7/sessions/saml/sso/onelogin

d. Set ACS (Consumer) URL Validator to a regex expression that matches only
all your lighthouses' SSO addresses (IP & DNS for Primary & Secondary
lighthouses).

i. Ensure it begins with * and ends with $ to match the whole url.

ii. Recommended pattern:
*https:\/\/ {lighthouse addresses}
\/api\/v3\.7\/sessions\/saml\/sso\/onelogin$

iii. For example to allow Onelogin login for lighthouse addresses
192.168.1.10and lighthouse.example.com, you could use the
following: (note the additional () around your hostnames and the |
separating them.

“https:\/\/
(192\.168\.1\.10|lighthouse\.example\.com)\/api\/v3\.7\

/sessions\/saml\/sso\/onelogin$

e. SetLogin URL to
https://{main lighthouse

address}/api/v3.7/sessions/saml/sp init/onelogin
f. Set SAML initiatorto Service Provider
g. Set SAML signature elementto Assertion

4. The recommended method to populate LH_Groups is with Onelogin Roles.
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a. Goto Parameters then click Add.

b. SetField Nameto LH Groups

c. Check Include in SAML assertion
d. Check Multi-value parameter

e. Click Save.

f. Set Default value to User Roles

g. If youintend on filtering the Roles that are sent to lighthouse (using a Rule) set

no transformotherwise set semicolon delimited.

* An example Rule to filter roles:
° “SetLH_Groupsin”
° foreach role

° with a value that matches TLH .~*
h. Save the parameter.
5. Save the connector.
IdP Metadata
1. Open your Onelogin application.

2. Goto More Actions > SAML Metadata. This is the metadata xml file that you will

need to configure lighthouse.
Configure Lighthouse
1. Copy the metadata xml to your primary lighthouse.

2. Using saml-idp-metadata on your primary lighthouse, configure each of your
lighthouses to use your IdP., For example

saml-idp-metadata -p {root password} create -m
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/path/to/metadata.xml -P onelogin -n "My Onelogin display

name" -1 {LH id number}

Roles Setup

After this initial setup, you will be able to login as a SAML user.

If you do not already have your own Usergroups setup in lighthouse:

1.

2.

9.

Login to Lighthouse as a local user (or any non-SAML user) for example, root.

Create the Usergroups with the Roles and permission that you desire. See

"Creating New Groups and Roles" on page 232.

In Onelogin Go to Users > Roles

Click New Role.

a. Setthe Role’s name to match the lighthouse group you want it to map to.
b. Select your Lighthouse app to associate the role with.

c. Click Save.

Open the newly created role.

Go to the Users tab on the left.

Search for and add your users or create a mapping to automatically add multiple

users.
Click Save.

a. If you used a mapping then go to Users > Mappings and run Reapply All
Mappings.

Click Done

The assigned users are now able to login to lighthouse with the permission levels

that the Onelogin Role/Lighthouse group grants them.
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AZURE ACTIVE DIRECTORY

Lighthouse can be added as an Enterprise application to Azure Active Directory.

This example uses “App roles” to grant users permissions.
To create an Application (Enterprise applications)

1. Go to Azure Active Directory.

2. Go to Enterprise applications.

3. Click New Application.

4. Click Create your own application.

5. Select Integrate any other application you don't find in the gallery (Non-
gallery).

6. Name your Application, for example, Lighthouse, then click Create.
7. Click Properties

a. Set Assignment required to Yes.

b. Set Enabled for users to sign-in to Yes.

c. Click Save.
8. Goto Single sign-on

a. Select SAML

b. Edit Basic Configuration
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i. Add an Entity Id lighthouse-azure_ad and set it as default.

ii. In Reply URL (Assertion Consumer Service URL) add the SSO URL for
each address of each lighthouse that you want to be able to signinon. i.e.
IP addresses and DNS address for both your primary and secondary
lighthouses.
https://{primary lighthouse
address}/api/v3.7/sessions/saml/sso/azure_ad https://
{primary lighthouse IP
address}/api/v3.7/sessions/saml/sso/azure_ad https://
{secondary lighthouse
address}/api/v3.7/sessions/saml/sso/azure_ad https://
{secondary lighthouse IP

address}/api/v3.7/sessions/saml/sso/azure ad

iii. SetSignonURLtohttps://{main lighthouse

address}/api/v3.7/sessions/saml/sp init/azure ad
iv. Click Save.
c. Edit Attributes & Claims
i. Remove the default claims from Additional claims.
i. Click Add new claim and Enter:
* Name: LH Groups
* Source Attributes: user.assignedroles
IdP Metadata
1. Go to the Azure Active Directory.

2. Go to Enterprise applications and open your application.
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Go to Single sign-on.

Navigate to 3. SAML Signing Certificate and find and download Federation

Metadata XML.

Configure Lighthouse

1.

2.

Copy the Federation metadata XML to your primary lighthouse.

Using saml-idp-metadata on your primary lighthouse, configure each of your
lighthouses to use your IdP as follows:

For example, saml-idp-metadata -p {root password} create -m
/path/to/metadata.xml -P azure ad -n "My Azure display

name" -1 {LH id number}

App Roles Setup

After this initial setup, you will be able to login as a SAML user. If you do not already

have your own Usergroups setup in Lighthouse, you can set them up as follows:

1.

2.

Login to Lighthouse as a local user (or any non-SAML user) i.e. root

Create the Usergroups with the Roles and permission required. See "Creating

New Groups and Roles" on page 232.

See Add app roles and get them from a token - Microsoft identity platform for

up to date documentation on how to create and assign App Roles.

1.

2.

Go to Azure Active Directory.

Go to App registrations.

Open your app (Use the All Applications tab to see Enterprise apps).
Go to App Roles.

Click Create App Role.
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a. Setthe value to match your usergroup on Lighthouse.

b. Set Allowed member types to Both (Users/Groups +

Applications).
c. Setthe other fields as required.
6. Go to Azure Active Directory.
7. Go to Enterprise applications.
8. Open your App, that is, Lighthouse.
9. Goto Users and groups.
10. Click Add user/group.

11. Select a user and one of your App roles then click Assign.

The assigned users are now able to login to lighthouse with the permission levels

which that App Role/Lighthouse group grants them.

CONFIGURE AUTHO FOR IDP

Lighthouse can be added as an Enterprise application to AUTHO. This example

uses “App roles” to grant users permissions.

CREATE AN APPLICATION (ENTERPRISE APPLICATIONS)

1. Go to AuthO.
2. Go to Applications > Application.

3. Click Create application.
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a. Select Regular Web Application.

b. Name the application, for example, Lighthouse.
4. Go to Settingstab.

a. Select SAML.

b. Set Application Login URI to

https://{main lighthouse address}/api/v3.7/sessions/saml/sp

init/auth0

c. In Allowed Callback URLs add each address for each lighthouse that you
wish to allow users to sign-in via. (that is, IP, hostname, dns for both primary

and dependent).

https://{primary lighthouse
address}/api/v3.7/sessions/saml/sso/auth0
https://{primary lighthouse IP
address}/api/v3.7/sessions/saml/sso/auth0
https://{secondary lighthouse
address}/api/v3.7/sessions/saml/sso/auth0
https://{secondary lighthouse IP

address}/api/v3.7/sessions/saml/sso/auth0

d. Click Save.
5. Go tothe Addons tab:
a. Click SAML2.

b. Go to the SAML settings tab.
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C. Set the Settings json to

{

"audience": "lighthouse-authO",

"mappings": {

"roles": "LH Groups"

by

"passthroughClaimsWithNoMapping": true,
"mapUnknownClaimsAsIs": true,

"nameIdentifierFormat": "urn:oasis:names:tc:SAML:1.1:nameid-
format:emailAddress",

"nameIdentifierProbes": [
"http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddres
t

]

}

d. Click either Enable or Save.
6. Go to Auth Pipeline.
7. Goto Rules.
8. Click Create.
a. Select empty rule template.
b. Name it appropriately, for example, Map roles to SAML user property.

c. Setthe scriptto
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9.

function mapSamlAttributes (user, context, callback) {
user.roles = (context.authorization || {}).roles;
callback (null, user, context);

}

Click Save.

CONFIGURE AUTHO METADATA FOR IDP

To setup the IDP metadata:

1.

2.

Go to AuthO.

Go to Application > Applications.

. Open your Lighthouse application.

Go to Addons.
Go to SAML.
Go to Usage.

Click the Identity Provider Metadata download.

A file named metadata.xml downloads to your preferred directory

CONFIGURE LIGHTHOUSES FOR AUTHO FOR IDP

In this step you will use the downloaded file to configure each of your lighthouses to
use your AuthO IdP.

1.

Copy the downloaded metadata. XML file to your primary lighthouse. See
"Configure AUTHO Metadata for IdP" above.
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Use the saml-idp-metadata file on your primary lighthouse, configure each of

your lighthouses to use your IdP with this command:

saml-idp-metadata -p {root password} create -m
/path/to/metadata.xml -P auth0 -n "My AuthO display name" -

1 {LH id number}

See"SAML Config for SSO" on page 255

CONFIGURE AUTHO FOR IDP

After you have added Lighthouse as an Enterprise application to AUTHO, you

need to use the App roles feature to grant users permissions to use IdP.

After this initial setup, you will be able to login as a SAML user.

1.

If you do not already have your own Usergroups setup in Lighthouse:
a. Login to Lighthouse as a local user (or any non-SAML user) for example, root.
b. Create the Usergroups with the required Roles and permission.

Go to AuthO.

. Go to User Management.

Go to Roles.

Click Create Role.

Enter the Role name that matches a Lighthouse group name.
Open your Role.

Go to the Users tab.

. Click Add Users.
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a. Assign the role to the appropriate users.

10. The assigned users are now able to login to Lighthouse with the permission

levels granted by the AuthO Role/Lighthouse group.

LIMITATIONS OF SAML CONFIGURATION

IDP METADATA CERTIFICATE EXPIRY

The Identity Provider (IdP) metadata XML file that you exported to configure
Lighthouse contains a certificate that is used to authenticate that the SAML

response came from your IdP.

Different IdPs have different expiry periods for these certificates, consult your IdP’s
documentation to find their expiry period. When your |dP’s certificate expires you will
need to regenerate it then re-export your I[dP metadata and update your Lighthouse
configurations. If your IdP supports sending expiry notifications to your admin, we

recommend you enable these notifications.

MAKING CHANGES TO USER PERMISSIONS

When you change the permissions assigned to a Lighthouse user in your IdP (via
LH_Groups SAML attribute), the changes will not take effect until the user logs out
and back into Lighthouse.

If you need to quickly restrict a user's access, consider altering the permissions of or
deleting that user’s usergroups on Lighthouse, see “"Modifying existing groups" on
page 237. You can also set a low Web Session Timeout. See Examine or modify

Lighthouse Session Settings.
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SAML SSO USERGROUPS

The LH_Groups attribute can be used to place SSO users in any Lighthouse
usergroup except Lighthouse’s default admin group. You can allow users to login
with admin privileges by simply creating another usergroup in Lighthouse with the
admin role and assigning the matching role/group in your IdP to the user (i.e.

populate LH_Groups to include its value).

SAML SSO USERS

SAML Users can only be managed in your IdP and will not appear under Lighthouse

User Management.

Note:SAML users have no access to either Web terminal or SSH functionality

via the Lighthouse web interface.

CONFIGURING AAA

Lighthouse supports three Authentication Authorization and Accounting (AAA)

systems:
* LDAP (Active Directory and OpenLDAP)
* RADIUS

. TACACS+
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Authentication works much the same with each, but group membership retrieval
varies. The following sections detail the configuration settings for each provider and

explain how group membership retrieval works.

LDAP CONFIGURATION

To begin, select SETTINGS > USER MANAGEMENT > Remote Authentication.

REMOTE AUTHENTICATION

SETTINGS

Scheme | i1

Mode | LDAPDownlocal ™

Remote authentication servers

ADDRESS il
(DEFALLTE TO LDARADAFE STANDARD FORTS)

LOAP base DN @

LDAF bind DN @

root

Bind DN password

Confirm password

LDAP username attribute @

LDAP group membership attribute @
Ignora referrals (&

S5L

Server protocol @ | LDAP over SSL preferrad ™

Ignore S5L certificate arrors @
CA cattificate (3

Browse._ No file selacted
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1. Select LDAP from the Scheme drop-down menu.

2. Choose the desired Mode from the drop-down menu.
* LDAPDownLocal
* LDAP: Default behavior
* LDAP/Local

* Local/LDAP
Note:See the Glossary for more information about these modes.

3. Add the Address and optionally the Port of the LDAP server to query.

4. Addthe LDAP Base DN that corresponds to the LDAP system being queried.
For example, if a user’s distinguished name is cn=John
Doe,dc=Users,dc=ACME,dc=com, the LDAP Base DN is dc=ACME,dc=com

5. Add the LDAP Bind DN. This is the distinguished name of a user with privileges
on the LDAP system to perform the lookups required for retrieving the username

of the users, and a list of the groups they are members of.
6. Add and confirm a password for the binding user.

7. Add the LDAP username attribute. This depends on the underlying LDAP
system. Use sAMAccountName for Active Directory systems, and uid for

OpenLDAP based systems.

8. Add the LDAP group membership attribute. This is only needed for Active

Directory and is generally memberOf.

9. If desired, check Ignore referrals option. When checked, LDAP will not follow

referrals to other remote authentication servers when logging users in to
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Lighthouse. If multiple remote authentication servers exist on the network,

checking this option may improve login times.
10. Under the SSL section, choose the desired Server protocol.

a. LDAP over SSL preferred: this will attempt LDAPS before trying LDAP
without SSL

b. LDAP (no SSL) only: non-SSL LDAP is always used
c. LDAP over SSL only: LDAP over SSL is always used

11. If desired, check Ignore SSL certificate errors to ignore any SSL certificate

errors.

12. CA Certificate is used to upload an SSL Certificate which will verify any LDAP

servers you specify on the page.

Note:The certificate will be uploaded but will not be used if you've chosen to

ignore certificate errors.

13. Install the CA certificate by clicking the Browse... button and locating the

appropriate file.

14. Click Apply.

Note:Multiple servers can be added. The LDAP subsystem queries them in a

round-robin fashion.

RADIUS CONFIGURATION

To configure RADIUS:
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Select SETTINGS > USER MANAGEMENT > Remote Authentication.

-

ST EEENETANGE REMOTE AUTHENTICATION
Lighthouse
SETTINGS
Scheme
Lighthouse VPN
RADIUS -

NETOPS MODULES

oo Mode

3 SETTINGS

RADIUSDownLocal
NETWORK CONNECTIONS

USER MANAGEMENT REMOTE AUTHENTICATION SERVERS

ADDRESS PORT (EFAULTS TO 112)

REMOTE ACCOUNTING SERVERS

ADDRESS PORT (DEFAULTS T0 1813)
Login Restrictions

"« ==

. In the Settings section, select RADIUS from the Scheme drop-down menu.

Choose the desired Mode from the drop-down menu.
* RADIUSDownLocal

* Radius

* RADIUS/Local

¢ Local/RADIUS

Note:See the Glossary for more information about these modes.

Add the Address and optionally the Port of the RADIUS authentication server to
query.

Managing Lighthouse Users



\ LIGHTHOUSE

Access Portal

4. Add the Address and optionally the Port of the RADIUS accounting server to

send accounting information to.

5. Add the Server password, also known as the RADIUS Secret.

Note:Multiple servers can be added. The RADIUS subsystem queries them in a

round-robin fashion.

To provide group membership, RADIUS needs to be configured to provide a list of
group names via the Framed-Filter-Id attribute. The following configuration snippet

shows how this can be configured for FreeRADIUS:

operatorl Auth-Type := System Framed-Filter-ID = ":group

name=west coast admin,east coast user:"

Note:The Framed-Filter-ID attribute must be delimited by the colon character.

TACACS+ CONFIGURATION

To configure TACACS+:

Managing Lighthouse Users
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Select SETTINGS > USER MANAGEMENT > Remote Authentication.

REMOTE AUTHENMTICATION

SETTINGS

Scheme | ITACARE: 77T -

Mode | TACACS+Downlocal ™

Remote authentication servers

PORT
(DEFALLTS TO 48

ADDRESS

ract =|fl +

TACACS+ login method & | PAP

Server password

freve

Confirm sarver passwaord

TACACS+ service (@

Select TACACS+ from the Scheme drop-down menu.

. Choose the required Mode from the drop-down menu.

« TACACSDownLocal:

* TACACS: Default behavior
« TACACS/Local

* Local/TACACS

Note:See the Glossary for more information about these modes.
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4. Add the Address and optionally the Port of the TACACS+ authentication server

to query.

5. Select the Login Method. PAP is the default method. However, if the server uses

DES-encrypted passwords, select Login.
6. Add the Server password, also known as the TACACS+ Secret.

7. Add the Service. This determines the set of attributes sent back by the
TACACS+ server

Note:Multiple servers can be added. The TACACS+ subsystem queries them in

a round-robin fashion.

To provide group membership, TACACS+ needs to be configured to provide a
list of group names This following configuration snippet shows how this can be

configured fora tac plus server:

user = operatorl {

service = raccess {

groupname = west coast admin,east cost user
}

}

To do this with Cisco ACS, see Setting up permissions with Cisco ACS 5 and
TACACS+ on the Opengear Help Desk.
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SETTING PASSWORD POLICY

An Identity Provider (IdP) stores and manages users' digital identities. An IdP may
check user identities via username-password combinations and other factors, or it
may simply provide a list of user identities that another service provider (like an
SSO) checks. An IdP can authenticate any entity connected to a network or a
system, including computers and other devices. Lighthouse Administrators can set

Password Policies to ensure that users set secure passwords.

To set a password policy:

1. Select SETTINGS > USER MANAGEMENT > Login Restrictions,
2. Choose Enabled, and

3. Click Save. Click Password Policy.

Choose one or more options from the following:
* Minimum password length — from 1 to 128

* Require at least one capital letter

* Require at least one number

* Require at least one symbol

* Disallow username in password

* Prevent password reuse — choose a number of days or select Always
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» Set password expiry — select a number of days until passwords expire. At next

login, the user will need to reset the password.

PASSWORD FIELDS IN LIGHTHOUSE

All password fields in Lighthouse are write-only. They accept data from the clipboard

or pasteboard but do not pass data out.
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ENABLING ADVANCED
FUNCTIONALITY

This section describes how to use the advanced functionality that the Netops
modules of IP Access, Secure Provisioning and Automation Gateway modules

provide.

INTRODUCTION

NetOps modules leverage Opengear's remote presence and proximity to
infrastructure by allowing software applications to run directly on top of the out-of-
band management fabric. The NetOps modules enable automation of the
configuration and operation of network infrastructure in data center and remote edge

locations.
The platform comprises the following:

* Opengear Lighthouse software: The central management interface and

automation controller.

* Managed Devices: Target infrastructure,for example, network switches from

Cisco or Cumulus.

* Opengear Nodes: OM, CM, ACM and IM appliances, connected to managed
device management NICs via Ethernet (and optionally managed device consoles
via RS-232 or USB serial).

* NetOps Modules: Software components that enable automation of specific
operational scenarios (for example, network device provisioning), deployed as

Docker containers — modules become active on Lighthouse when a module
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license is installed, they can then be manually or automatically activated on

nodes.

ABOUT NETOPS

NetOps modules require a Lighthouse with appropriate licensing and modules to be
uploaded and active. You will also need at least one node enrolled and able to use

these modules.

Lighthouse Enterprise contains the IP Access module, whereas, Lighthouse
Enterprise: Automation Edition contains IP Access, Secure Provisioning and

Automation Gateway.

The NetOps modules are built as Docker containers and accessed through the
Lighthouse GUI.

NETOPS PLATFORM SECURITY

The NetOps Automation platform uses a combination of advanced hardware and
software security features to provide end-to-end security and resilience against

network breach, fault or failure.

All communications between Lighthouse and nodes are tunneled inside Lighthouse

VPN, using strong ciphers and automated certificate authentication and revocation.

Nodes such as the OM and CM8100 contain a TPM chip, which verifies the

authenticity of the OM system software, its configuration, and NetOps Module code
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and data — any unauthorized tampering will render the appliance inoperable. These
nodes are physically hardened to resist tampering — attempts to physically to access

storage media will render the appliance inoperable

With a built-in cellular capability nodes with the TPM chip provide a secure WAN
uplink in the event of network outage, DOS, or during initial network turn-up at a

remote location.

CHANGING DOCKER IP RANGES

Docker powers the NetOps platform within Lighthouse. By default, Docker and
NetOps utilize the 172.17.0.0/16 and 172.18.0.0/16 subnets. This has the potential

to cause collisions inside of some networks.
To avoid this, you can change these settings.

To update Dockers subnet, you need to alter 2 parameters, Docker's default subnet

and the NetOps modules subnet. To do so:
Login to the Lighthouse shell CLI as a Lighthouse Administrator or the root user

Ascertain the number of running containers to ensure you select an appropriate

subnet size

sudo docker ps -g | wc -1

Open a config CLI session on the Lighthouse Server and run the following to enter

configuration management

ogconfig-cli

Set the IP Range of the Docker subnet in CIDR format
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set services.nom.default subnet "10.123.17.1/24"
Set the IP Range of the NetOps subnet in CIDR format
set services.nom.netops subnet "10.123.18.0/24"
Push the config to become the running config
push
Exit the configuration management
exit
Restart Docker
sudo /etc/init.d/docker.init restart

Restart the NetOps Module(s)

sudo /etc/init.d/docker.init reset

Note:The network mask selected for these subnets limits the maximum number
of containers that can run on Lighthouse. NetOps currently runs up to

approximately 10 containers.
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NETOPS MODULE MANAGEMENT

The NetOps modules, IP Access and Secure Provisioning, Automation Gateway,
are stored in a private repository. Periodically, module updates and new modules

may become available.

Note:You can upgrade NetOps Modules without upgrading Lighthouse

software.

UPGRADE MODULES FROM THE Ul

1. Launch an HTTPS browser session to Lighthouse Login using root and the

secure password set earlier.

2. You may also log in as a Lighthouse Administrator user, if you have configured

one.
3. Fromthe menu, select SETTINGS -> Services -> NetOps Modules.

4. Click the Synchronize widget.

5. From the menu, select CONFIGURE -> NetOps Modules -> Manage Modules.
6. Click the Redeploy icon.

UPGRADE MODULES FROM THE CLI

Log in to the Lighthouse CLI as root.

Or

Log in as a Lighthouse Administrator and become root with:sudo -1

Replace default with your root password and run:

PROCEDURE for Lighthouse CLI
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Replace root and default with a Lighthouse Administrator or root credentials, then

run the following:

USERNAME=root
PASSWORD=default
/etc/scripts/netops sync handler

token=$ (curl -k -L -d '

{"username" :"'SUSERNAME'", "password":"'SPASSWORD'"}'
"https://127.0.0.1/api/v3.0/sessions/" | python -c 'import sys, json;
print json.load(sys.stdin) ["session"]"')

curl -k -L -H "Content-Type: application/json" -H "Authorization:
Token S$token"

"https://127.0.0.1/api/v3.0/netops/modules/dop/redeploy"

UPDATE NETOPS MODULES WITHOUT DOCKER ACCESS

If Lighthouse is deployed on a network where outbound access to the Docker Hub
repository is not permitted or not available, use the NetOps offline installer script.
This script has a built-in payload with everything required to update NetOps Modules

on Lighthouse.

USE A PRE-BUILT OFFLINE INSTALLER (VIA GUI)

1. Download the offline installer file (named netops_modules_*.tar.gz) from this link:

offline installer file
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2. Browse to Settings > Services > NetOps Modules and click Offline.

[=] coNFIGURE NETOPS SERVICES
oD SETTINGS ®

NETWORK CONNECTIONS

USER MANAGEMENT

Choose installer file

NOTIFICATIONS R
| Browse... | No file selected.

SERVICES

@ If Lighthouse does not have access to the repositary, upload an offline installer package here. The installer will be executed on Lighthouse, so

Cellular Health . ensure the uploaded file is correct.
Upload

HTTPS Certifica

Lightho

NetOps Modules

3. Click Browse and select the downloaded file.

4. Click Upload.

Note:This process can take up to 15 minutes. There are notifications detailing

the process steps in the lower right hand corner as well as log entries in the
system log.

USE A PRE-BUILT OFFLINE INSTALLER (VIA CLI)

1. Download the offline installer file (named netops_modules_*.tar.gz) from this link:

offline installer file.

2. Copy the offline installer to Lighthouse using scp, WinScp or similar, into the
Imnt/nvram directory.

3. Loginto Lighthouse shell CLI as a Lighthouse Administrator and run:

gzip -d </mnt/nvram/netops modules *.tar.gz | nom update && rm

/mnt/nvram/netops modules *.tar.gz
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4. Deploy the upgrade to nodes:
a. Login to the Lighthouse web Ul as a Lighthouse Administrator or the root user

b. From the menu, select CONFIGURE NODES > NetOps Modules > Manage

Modules.

c. Inthe Status column, confirm the module versions now match the latest

release versions.

d. Click the Redeploy icon.

Note:Note: Using the offline install requires 8GB of free space in the

Imnt/data partition.

UPGRADE NETOPS MODULES

NetOps Modules are released independently of Lighthouse software or Operations

Manager firmware.

NetOps releases are uploaded to Opengear's file server, where they can be fetched

by Lighthouse then deployed to all activated nodes by Lighthouse.
Node upgrades may be carried out through either the Lighthouse Ul or the CLI.

PROCEDURE for Lighthouse Ul
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1. Login to the Lighthouse web Ul as a Lighthouse Administrator or the root user.

2. From the menu, select SETTINGS > Services > NetOps Modules.Select either

Online or Offline.

¢ sETTINGS

NETOPS SERVICES

TWORK CONMECTIONS -
o
USER MANAGEMENT
NOTIFIC
OMLINE DFFLINE
SERVICES
)

HetOps Modules

3 Click the © Synchronize icon. A message displays with the status.

@ System and Subscriptions (@ Help & Logout

% :I:-:“l%ll-rﬂ.-fll-mUSE Feedback @ Add Node

7" SETTINGS
NETOPS SERVICES

MET I.

USER MANAGEMENT

NOTIFICATIONS

SERVICES

NetOps Modules
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4. From the menu, select CONFIGURE NODES > NetOps Modules > Manage

Modules.
5. Click the Redeploy icon.

PROCEDURE for Lighthouse CLI

Replace root and default with a Lighthouse Administrator or root credentials, then

run the following:

USERNAME=root
PASSWORD=default
/etc/scripts/netops sync handler

token=$ (curl -k -L -d '

{"username" :"'SUSERNAME'", "password" :"'SPASSWORD'"} '
"https://127.0.0.1/api/v3.0/sessions/" | python -c 'import sys, json;
print json.load(sys.stdin) ["session"]")

curl -k -L -H "Content-Type: application/json" -H "Authorization:

Token S$token"

"https://127.0.0.1/api/v3.0/netops/modules/dop/redeploy"

ACTIVATE A NETOPS MODULE

IP Access is activated for both Enterprise Edition and Automation Editions.

Secure Provisioning and Automation Gateway are activated from the Automation

Edition license.
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The NetOps module license is installed on Lighthouse and contains a preset number
of available node activations. Each supported node that is activated for the NetOps
module provisioning, consumes an available activation; Lighthouse itself does not

consume an activation.

Installing the NetOps module license automatically activates the module on
Lighthouse, at which point the NetOps Automation platform deploys the central

module software components, including the module's Ul, to Lighthouse.

The process of automatically or manually activating a NetOps Module on a node
deploys the remote module software components to that node, securely over
Lighthouse VPN.

ACTIVATE THE NETOPS MODULE ON LIGHTHOUSE
PREPARATION

1. Install the Lighthouse VM and ensure it is running.
2. Login to the Lighthouse web Ul as root or a Lighthouse Administrator.

3. Install the Lighthouse node subscription (SKU OGLH) under SETTINGS >

System > Subscriptions.
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PROCEDURE

1. Ensure you have a valid NetOps Module licence installed under SETTINGS >

System > Subscriptions.

Note:The Enterprise Edition license includes the IP Access module.
The Automation Edition license includes IP Access, Secure Provisioning,

and Automation Gateway.

2. It will take a few minutes for the module to activate on Lighthouse, view progress
under CONFIGURE NODES > NetOps Modules > Manage Modules.

3. Click the C Update icon and note new module-specific menu items are now

available under CONFIGURE NODES, for example, Secure Provisioning or IP

Access.

Nodes may now be automatically activated for the module as they enroll, or

manually activated after enroliment.
'"ALWAYS ACTIVATE' MODE ON ALL NODES (AUTOMATIC)

In the Always Activate mode, NetOps automatically activates the NetOps Module on
all nodes, provided a license is present and activations are available. All nodes are

activated for the module as they enroll.
PROCEDURE

1. Check and apply CONFIGURE NODES > NetOps Modules > Manage Modules

> Module Name > Always Activate.

2. To activate a new node, enroll the node into Lighthouse, , see "Activate the

Secure Provisioning Module on Lighthouse" on page 341
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ACTIVATE NETOPS ON SELECTED NODES (AUTOMATIC)

You may selectively activate the module on a subset of nodes using Enroliment
Bundles. Only nodes enrolling using one of these bundles will be automatically

activated.
PROCEDURE

1. Navigate to CONFIGURE NODES > NetOps Modules > Manage Modules >

Module Name > Always Activate.
2. Uncheck Always Activate.
3. Click Apply.

4. Select CONFIGURE NODES > Node Enrollment > Enrollment Bundles and

add a new bundle (you may also edit an existing bundle).

5. Enter a bundle Name and Token, and choose whether or not to Auto-Approve

enrollment, see "Activate a NetOps Module" on page 297.
6. Scroll down to NetOps Modules and add the Module Name.

7. Enroll the node to Lighthouse, specifying the Enrolilment Bundle Name and

Token.

Note:Lighthouse-initiated manual enrollment (for example, clicking the Add
Node button in the Lighthouse web Ul) does not support bundles, you must

use a node-initiated enrollment method.
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ACTIVATE THE NETOPS MODULE ON NODES (MANUAL)

PROCEDURE

To activate nodes manually after enrollment, use the following steps:

1.

Ensure CONFIGURE NODES > NetOps Modules > Manage Modules >

Module Name > Always Activate is unchecked and applied.
Select CONFIGURE NODES > Configuration Templating > Apply Templates.
Under NetOps Module Activation, choose the Module Name and click Next.

Select the nodes to to activate, then click Next.
To ensure the preflight check has succeeded click the C Update icon above the
table, then click Next.

Click the C Update icon to ensure activation is successful.

Note:Under the NetOps licensing arrangement, once a node is activated for the
NetOps Module, the activation is consumed by and locked to that node.
Unenrolling the node returns the activation to the available pool. Under NetOps
subscription arrangements, it would be counted towards the node assignment

of the subscription.

DEACTIVATE (REMOVE) A NETOPS MODULE

To deactivate and remove a NetOps Module from a given node, use the following
API call to Lighthouse:

DELETE /api/v3/netops/modules/module id/nodes/node id
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where module_id is one of dop (Secure Provisioning), IP Access, or ag (Automation
Gateway), and node_id is the internal node ID, for example, nodes-1.
Follow the procedure below to remove NetOps Modules from a given node:

1. Login to the Lighthouse CLI shell as root or a Lighthouse Administrator user.

2. Determine the node's node ID by running:
node-info --1list

3. Update the highlighted fields with your username, password, the node ID and

modules to deactivate, then run the following:
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LH _USERNAME="root"
LH PASSWORD="default"
NODE ID="nodes-1"

MODULES TO DEACTIVATE="dop ag sdi"

token=$ (curl -k -L -d '{"username":"'$LH USERNAME'", "password":"'SLH

PASSWORD'"}' https://127.0.0.1/api/vl/sessions/ | cut -f10 -d'"")

for module id in $MODULES TO DEACTIVATE; do
curl -k -L -X DELETE -H "Authorization: Token $token"
https://127.0.0.1/api/v3/netops/modules/${module id}/nodes/S$NODE ID

done

AUTOMATION GATEWAY

Opengear allows you to set up your network using automation tools.

Automation Gateway allows Lighthouse users and automation code to discover and
manage IP-based management interfaces via the Opengear management system,

with the same level of simplicity and efficiency as if they were serial consoles.

Managed devices like firewalls and servers may present an IP-based management
interface in addition to (or sometimes instead of) the traditional serial or USB
console port. This interface may serve a web-based GUI, VNC or RDP based KVM,
SSH-based CLI and/or a programmable network API like RESTful HTTPS. The

device itself may be physical or virtual.
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By their nature, the IP-based management interfaces are more dynamic (for
example, they may change IP address), varied (for example, protocols vary from
device to device) and harder to reach (for example, on an un-routable private

network).

The Automation Gateway module addresses the challenges of discovering, auditing
and connecting to IP-based management services in a distributed, heterogeneous

network. It is available on Operations Manager product lines, OM120x and OM22xx.

DIFFERENCES BETWEEN IP ACCESS AND AUTOMATION
GATEWAY

The IP Access module provides the IP Access feature and the Automation

Gateway module provides the Automation Gateway feature.

These two features are similar in that they both allow Lighthouse users to access
network services on remote managed devices, however they accomplish this in
different ways. One way to think about it is that IP Access transports the user to the
remote network, whereas Automation Gateway transports a specific remote

network service to user.
IP ACCESS

Using IP Access, the user must establish a VPN tunnel from their computer to
Lighthouse, which then provides them with a routed connection to the entire network
(s) connected to the remote node. Once the tunnel is up, the user can access any
network service on any network device by their standard management IP

addresses.

AUTOMATION GATEWAY
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Using the Automation Gateway feature, the user clicks through their existing
Lighthouse browser session to access HTTP/HTTPS web GUI services of specific
devices that have been discovered by the remote node. Access is limited to these
services only, and the connections are proxied via Lighthouse's central address — so

no client or network reconfiguration is required.

HOW TO USE AUTOMATION GATEWAY

Using Automation Gateway, Lighthouse users can connect to the web Ul of a remote
physical & virtual managed device such as a firewall, lights-out server or SD-WAN

appliance.

Access is proxied via Lighthouse VPN via a remote node, allowing simply, point &

click access to what may be an otherwise unreachable remote device.

PROCEDURE
The basic steps to setup and use this feature are as follows:

1. Activate the Automation Gateway NetOps Module on an enrolled node, that is

on the same network as the remote device that you wish to reach.

2. Loginto the Lighthouse web Ul as a user with at least NetOps Modules: Read
Only permission, and at least Nodes & Devices (Base): Read Only permission

for the activated node.
3. Click CONFIGURE > AUTOMATION GATEWAY > Devices.
4. Inthe FILTER BY menu, select HTTPS or HTTP from the Services drop down.

5. Locate the remote device by hosthame or IP address.
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Tip: If many remote devices have been discovered, use the FILTER BY

menu to search by full or partial device hostname or IP address.

6. To initiate an Automation Gateway session, click the device's web Ul icon.

DEVICE ACCESS C'Rescan Devices

DEVICE INFD DISCOVERED SERVICES FILTER BY

Mo devices have been identified.

7. You are now connected the web Ul of the remote device
Note:While an Automation Gateway session is active, all new
browser tabs and windows that connect to Lighthouse are proxied

through to the remote device web Ul.

8. To close the Automation Gateway session, click the link at the bottom of the

device web Ul:
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This system is being accessed via Lighthouse - click here to

return to Lighthouse

CONNECT WITH REST/HTTP/HTTPS APIS

Automation Gateway allows central automation code to reach the HTTP/S API

services running on devices on remote networks.
For more details see:

https://ftp.opengear.com/download/documentation/api/lighthouse/og-rest-api-
specification-v3-7.html

This is accomplished by modifying the request to add the X-Ip-Access-Auth HTTP
header to your API request, and substituting the device's remote IP with
Lighthouse's central IP. Requests containing the header are reverse proxied via

Lighthouse then via an Operations Manager node that is local to the remote device.

The example Python (3.5+) code below illustrates this. Note that this code is
primarily for illustrative purposes with no error handling or modularity, for clarity &

brevity.

The device being accessed in this example is an HP ILO's Redfish REST API

service.

#!/usr/bin/env python3

# Example code showing how to reach a remote device REST API via Opengear
# Lighthouse Automation Gateway -> Operations Manager node -> device

#

# This code is primarily for illustrative purposes with no error handling

# or modularity, for clarity & brevity
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import requests
import json

import base64

# Authenticate to Lighthouse

lighthouse address = '192.168.67.20"

lighthouse account = 'root'

lighthouse password = 'default'

data = { 'username': lighthouse account, 'password': lighthouse password }

o)

r = requests.post('https://%$s/api/v3.7/sessions/' %
lighthouse address, data=json.dumps (data), verify=False)

lh token = json.loads(r.text) ['session']

o)

print ('Authenticated to Lighthouse, token %s' % lh token)

lh headers = { 'Authorization': 'Token ' + lh token }

# Find the node that is local to the remote device's API service

device address = '10.0.0.71' # Equivalent to the UI fields under CONFIGURE >
device service = 'https' # AUTOMATION GATEWAY > Devices > Filter By
r = requests.get ('https://%s/api/v3.7/nom/ag/devices?ip=%s&service=%s' %

(lighthouse address, device address, device service),

headers=1h headers, verify=False)

Enabling Advanced Functionality



Access Portal

\/& LIGHTHOUSE

jJ = json.loads (r.text)
print (json.dumps (j, indent=4))

for device in j['devices']:
for host in device['hosts']:
for service in host['services']:
if service['mmap']['name'] != device service:
continue
for avail in service['availability']:
node id = avail['id']

print ('Service available via %s' % node_ id)

break
# Generate Automation Gateway token

data = { 'session': lh token, 'request type': 'new',
'url': 'https://%s' % device address, 'node': node id }
r = requests.post ('https://%s/api/v3.7/nom/ag/auth tokens' %
lighthouse address, data=json.dumps(data), headers=1h headers,
verify=False)
J = json.loads (r.text)
ag _token = j['token']

o)

print ('Automation Gateway token is %s' % ag_ token)

ag_headers = { 'X-Ip-Access-Auth': ag token }
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# Now we can query the device API using the Lighthouse address, by including

# the access token in the request headers

# The remaining code is specific to the device being accessed. this example

# hits a Redfish-compliant REST API

device username = 'baz'
device password = 'foobarfoobar'
device auth = base64.b64encode(('%s:%s' %
(device username, device password)) .encode('utf-8')) .decode('utf-8")
device headers = { 'Authorization': 'Basic %s' %
device auth, 'Content-Type': 'application/json' }

# Add the access token to whatever headers you'd usually use to talk to the

# device's native API -- this header will be stripped by Automation Gateway
_headers = { **ag headers, **device headers }
r = requests.get('https://%s/redfish/vl/systems/1/' %

lighthouse address, headers= headers, verify=False)

J = json.loads (r.text)

print (json.dumps (j, indent=4))
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AUTOMATION GATEWAY SERVICE DISCOVERY

Automation Gateway discovery process can take varied amount of time to complete,

entirely based on the size of your scannable network.

Services discovered by Automation Gateway are listed in the Lighthouse web Ul,
under CONFIGURE > Automation Gateway > Devices The discovery process can
be restarted using the "Rescan" button on the Automation Gateway > Devices

page.

When an HTTP or HTTPS service has been discovered, it may also be accessed via

this page.

When a node has been activated for Automation Gateway, it begins to discover
remote services. The discovery process is initiated by Lighthouse, and runs every

10 minutes.

Each time the discovery process is initiated, the node runs an nmap script scan

against all IPv4 connections belonging to the node's LAN firewall zone.

Note:Large logical networks with address space larger than 254 hosts (i.e. with

a minimum netmask of /24 or 255.255.255.0) are excluded from the scan.

The nmap scan runs the default (non-intrusive) suite of nmap NSE scripts. These
can be listed by running the following command on a node that has been activated

for Automation Gateway:

sudo docker exec ag-remote cat /usr/share/nmap/scripts/script.db |

awk -F\" '/"default"/ { print $2 }'
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IP ACCESS

The Lighthouse IP Access feature allows an engineer to reach hosts on a remote
site via an OpenVPN client through Lighthouse, over the Lighthouse VPN fabric,
without physically traveling to the site. If IP Access is enabled for Lighthouse, it can
be managed from using the Configure > IP Access menu option on the Lighthouse
web Ul.

IP Access adds client VPN capability to Lighthouse. Network engineers, firewall and
server administrators can launch a VPN client connection to Lighthouse, be
authenticated, then automatically connected to the remote site management
network. The client PC has a secure VPN tunnel to the remote equipment the user
needs to work on, providing the same TCP/IP access they would get if they traveled

to the site and plugged into the management LAN.

The client can then access target devices on the remote network directly by their
usual IP addresses and network ports. Requests from the client are masqueraded
behind the node's IP address, so no additional routing configuration is required on

the target devices.

CONNECTIVITY

By default, IP Access connects the client to the Management LAN of the Opengear
appliance, or the interfaces in the LAN zone for the OM Series. A route for the
directly attached subnet, plus any static routes configured on that interface (but

never the default route) are also pushed automatically to the OpenVPN client.
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In the diagram, the client PC has a virtual tunnel interface with a route to the yellow
management network, and the user can access any target IP devices on the yellow

network using their real IP addresses.
The basic configuration of this feature is:

* Activate the IP Access NetOps module — this starts the OpenVPN service in a

Docker container on Lighthouse.

» Activate the IP Access NetOps module on each node you wish to use for IP
Access — this installs a remote connector service to allow the IP Access bridge to

be created.

* Generate a certificate and export an associated OpenVPN client configuration

file.
* Import the configuration into your preferred OpenVPN client.

The basic operation of this feature is:
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* Connect the tunnel — this starts a connection to Lighthouse on UDP port 8194.

* Authenticate when prompted using your Lighthouse credentials, appending the
node name to your Lighthouse username — client certificate authentication is

automatic, this is a second factor of authentication.

» Wait a moment for the connection to complete — this builds the GRE bridge

between the client and pushes routes to the node's remote network(s).

While connected, the client can access IP addresses on the node's remote network
(s) LAN directly, for example, by using the ping command or by typing them into the

browser address bar.

NODES SUPPORTED BY IP ACCESS

Opengear OM1200, OM2200, CM8100, ACM7000 and IM7200 nodes may be
activated as IP Access nodes, to allow IP Access to their directly connected remote

networks via Lighthouse.
Other vendors/models are not currently supported.

Select Configure > IP Access to view the available nodes in Lighthouse. The Node

Access page displays.
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NODE ACCESS

Edit Managed Device Filters

Smart Group Filtering
CONFIGURATION TEMPLATING Smart Group Filering

Select Smart Group...
MULTIPLE INSTANCE

Free Text Search
NETOPS MODULES
DEVICE PROVISIONING
AUTOMATION GATEWAY o
IP ACCESS
N . NAME NODE ID STATUS ACTIONS
SPT-Management-IM7248 nodes-6 Enabled Q@
SPT-IM7216 nodes-7 Enabled )
SPT-CM7148 nodes-8 Enabled @
im7216-2 nodes-9 Enabled %)

ENABLE IP ACCESS IN LIGHTHOUSE

This topic walks through the steps required to activate and enable the IP Access

feature.
ENABLE NETOPS AUTOMATION
After deploying the Lighthouse, sync the latest NetOps Modules from Docker Hub:

1. Log in to the Lighthouse web Ul as a Lighthouse Administrator or the root user.
2. Fromthe menu, select SETTINGS > Services > NetOps Modules.

3. Click the Synchronize icon.
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Note:If Lighthouse cannot contact the Docker Hub, you may be able to use

the offline installer.

ACTIVATE THE IP ACCESS MODULE

NetOps Modules must be activated on Lighthouse and a per-node basis.

1.

Log in to the Lighthouse web Ul as root or a Lighthouse Administrator, and
upload the Enterprise Edition or Enterprise Automation Edition licence file under
SETTINGS > System > Subscriptions > Add.

Click CONFIGURE > NetOps Modules > Manage Modules and wait until

Lighthouse activation is complete.

To activate on the node you wish to access IP networks via, use the following steps:

1.

Ensure CONFIGURE > NetOps Modules > Manage Modules > IP Access >

Always Activate is unchecked and applied.

Select CONFIGURE > Configuration Templating > Apply Templates.
Under NetOps Module Activation select IP Access and click Next.
Select the nodes to to activate and click Next.

To ensure the preflight check has succeeded click the C Update icon above the

table, then click Next.

Note:Any locally attached subnet and any static routes configured on the
Management LAN (OGCS) or interfaces in the LAN zone will get pushed to the

client.

See also: "Activate a NetOps Module" on page 297.
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NETWORK PORTS USED FOR IP ACCESS
IP Access OpenVPN clients connect on UDP port 8194, inbound to Lighthouse.

The remainder of the connection is bridged over the existing Lighthouse VPN

between the node and Lighthouse, therefore no additional ports are utilized.

GENERATE A CERTIFICATE AND EXPORT CLIENT
CONFIGURATION

Clients connect to Lighthouse via an OpenVPN client, which in turn connects them
to the Management LAN network of a particular node. IP Access provides a
convenient means to configure the OpenVPN client by generating the configuration

files that may be imported directly into your OpenVPN client of choice.

1. Login to the Lighthouse web Ul as root or a Lighthouse Administrator, and click
CONFIGURE > IP Access > Client Certificates. Enter a Certificate Name and

click Create.

2. When the certificate is created, download an associated OpenVPN client

configuration by clicking Export.

Note:Deleting a client configuration file from Lighthouse revokes that client
certificate and any associated client configurations using that certificate will

no longer be permitted to connect.

CONNECT THE VPN CLIENT

The final step is to establish the VPN connection that allows IP Access to the

Management LAN (and optionally other networks) behind a node.

1. Import the client configuration from the previous step into your preferred

OpenVPN client and start the VPN connection.
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2. When prompted to authenticate the VPN connection, you must also specify your

Lighthouse credentials and the node that you want to establish IP access via.

3. Specify the node by adding :node-name to your Lighthouse username, for
example, authenticating with the username james:my-acm7004-5 will
authenticate as Lighthouse user james and connect the VPN to the IP network(s)
behind my-acm7004-5.

Note:To be permitted connection, the Lighthouse user must have at least Node

User rights for the specified node.

Note:The IP Access NetOps module creates a Layer 2 TAP mode tunnel which

is not supported by Android or iOS operating systems.

PASSWORD AUTHENTICATION DURING VPN CONNECTION

During VPN connection, the client is prompted to enter a username and password.
These credentials are used to authenticate the user, and also to specify the remote

node to establish IP access through.

Specify the node by adding :node-name to your Lighthouse username,for example,
authenticating with the username james:my-acm7004-5 will authenticate as
Lighthouse user james and connect the VPN to the IP network(s) behind my-
acm7004-5.

For authentication to succeed, the Lighthouse user must be one of:

* Lighthouse Administrator role, or root
* Node Administrator role with access to the node you are connecting through

* Node User role with access to the node you are connecting through

Enabling Advanced Functionality



\ LIGHTHOUSE

Access Portal

ADVANCED OPTIONS

The Advanced options of the IP Access page enable you to set a number of
features, including setting expiry of certificates lifetime, changing default connection

routes and enabling policies.

IP Access connects the client to the Management LAN or LAN zone by default,
which is intended for deployments where the target devices are connected to those
interfaces. If the Opengear appliances are deployed into a different or more complex
network environment, then there are some advanced options that the Lighthouse
administrator can use to control the IP Access connectivity, and these are described

below.

-

ADVANCED OPTIONS

Edit Managed ce Filters

OPTION
CONFIGURATION TEMPLATING

Client Certificate Lifetime (days) ®@
MULTIPLE INSTANCE .

365

NETOPS MODULES

Clien ic @
DEVICE PROVISIONING :
AUTOMATION GATEWAY

ient Route Pushing Enabled (3)
IP ACCESS

O Push Wired WAN Routes ®@

Node

Client Certificates

for Operations Manager Enabled (3)

Client Status
' Apply

Advanced Options
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CONNECTING TO WAN ZONE

By default, IP access connects the client to the management LAN zone.

If IP Access is required for the WAN zone, select Configure > IP ACCESS >
Advanced Options > Push Wired WAN Routes. This is a global configuration,

and will affect all node that are enabled for IP Access.

In this case, the customer must have deployed Opengear appliances with the
Network Interface (NET1) connected to the management network or facing target
devices, and it results in IP Access connecting the client to the WAN (NET1)
interface on OGCS.

NETWORK ACCESS POLICIES FOR OPERATIONS
MANAGER

In a more complex deployment, Opengear appliances may be connected to multiple
networks or virtual networks (VLANSs), and in these cases it is often important to be
able to control which of these networks each authenticated IP Access user is able to

access.

This feature is only supported on Operations Manager or OM Series appliances,
which support the zone-based firewall, designed to work with multiple VLANs and
the optional built-in Ethernet switch with layer-3 capable ports. This flexibility and
control is very useful, especially for customers who have a number of separate

management networks (or VLANSs) for different administrative teams.

The Network Access Policy mechanism on Lighthouse provides a way to
dynamically map IP Access users, based on their group membership, to the firewall

zone(s) that they can access on the Nodes. Each firewall zone is a collection of
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network interfaces which is configured on each Opengear appliance or Node.
Firewall zones are used to provide policy abstraction by logical zone names — the
physical or virtual interfaces on each Node may vary by site, but the zone names
must stay consistent. It is recommended that zones and names are planned out in

advance of implementation.

A firewall zone is a collection of network interfaces which is configured on each
Opengear appliance or Node in Lighthouse terminology. The Network Access Policy
mechanism on Lighthouse provides a way to map users, based on their group

membership, to the firewall zone(s) that they can access on the Nodes.
UNDERSTANDING ACCESS POLICIES

Putting it all together, when a user authenticates to Lighthouse, they are mapped
into one or more group(s), which map into firewall zone(s), which allow
authenticated users to reach the appropriate network interfaces(s), including switch

ports or VLANS, via IP Access.

For example, users who belong to the security group may get mapped into the
secops (security operations) zone. On each OM appliance, the appropriate switch
port(s) and/or VLAN(s) for security operations should be configured to be in the

Secops zone.

Similarly, users in the server group may get mapped into the serverops zone, and
again on the OM appliances the appropriate interfaces can be configured to be part
of that zone. The result is that members of the security group get IP Access to the
networks in the secops zone, and members of the server group get IP Access to the

networks in the serverops zone, for each Node that they connect to.
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SETTING UP NETWORK ACCESS POLICIES

To enable this feature, go to IP Access > Advanced Options and select “Network

Access Policies for Operations Manager Enabled”, then hit Apply.

-

ADVANCED OPTIONS

CONFIGURATION TEMPLATING

OPTIONS
MULTIPLE INSTANCE
NETOPS MODULES Client Certificate Lifetime (days) @
365
AUTOMATION GATEWAY
Clien ic ©)
DEVICE PROVISIONING
1
IP ACCESS
Client Route Pushing Enabled (3)
0O Push Wired WAN Routes ®
& networ for Operations Manager Enabled (3)

Apply

TO SET ACCESS POLICIES
A policy must be configured for each group whose members will use IP Access.

1. Select Configure > IP Access > Network Access Policies. The Network
Access Policies page displays. The group to zone mapping column names
ZONES is empty by default.
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NETWORK ACCESS POLICIES
CONFIGURATION TEMPLATING

Need a new Network Access Palicy?

MULTIPLE INSTANCE .
+ Create a new user group first &

NETOPS MODULES

AUTOMATION GATEWAY ® cnable Network Access Policies in the Advanced Options® page for these policies to take effect.

DEVICE PROVISIONING

RS GROUP ZONES UPDATED

netgry 2021-04-08 03:01 UTC

Node Access

some_custom_zone, LAN, WAN 2021-04-08 03:01UTC
2021-07-0123:01UTC

PPihfjiWtGfwMcIROBARVhi TLISHZU 2021-12-14 22:56 UTC

odeadmingroup 2022-03-08 03:39 UTC
Network Access Policies RidersofRohar RR, RRZone 2022-10-04 03:21 UTC

.|

2. Click on the group name to edit the group policy.
3. Click on + Add Zone to add one or more firewall zones for this group.

4. Select the firewall zone and click Add.
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ADD FIREWALL ZONE

NAME NODES -
O LAN 1 View details
O Lighthouse VPN 1 View details
O wWAN 1 View details
O Cellular 0 View details
O RR 0 View details
O RRZone 0 View details

+ Manually specify zone

5. The Network Access Policies page now displays the group with the Firewall zone.

ACCESSING MULTIPLE VLANS OR PORTS

There are several ways a user can access multiple target networks, virtual networks

(VLANS) or physical ports.
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GROUP MEMBERSHIPS

A user may belong to multiple groups, in which case they will have access to the
sum of the zones mapped to those groups, in the same way port access works for
Console Gateway and Smart Group matching. Note that this works regardless of
Local or Remote user authentication on Lighthouse; user authorization (which
determines access to Nodes and managed devices, and now firewall zones) is

always derived from group membership.
FIREWALL ZONES

In the IP Access Network Access Policy settings, each group can be configured
to have access to one or more firewall zones. Some groups can be configured to
have access to no zones, some to just one zone, and other groups to have access to

multiple zones.
MULTIPLE LAYER 3 NETWORK CONNECTIONS

On each Node a layer 3 network connection or “conn” is required on the OM to
communicate with other hosts on a network or VLAN. Multiple conns on each OM
can be mapped into the same firewall zone. This may be used to provide access to
multiple switch ports, though it is perhaps more likely that those switch ports would
be configured in a bridge group if they are all part of the same LAN, and the bridge
group only requires a single layer 3 conn. If multiple LANs or virtual LANs (VLANS)
are managed by the same team, then it may make sense to combine them into the

same firewall zone.

Warning: The supported appliance's firewall will allow traffic to pass between
interfaces in the same firewall zone, so to maintain security, multiple “separate”
management VLANs should not be configured in the same zone, but should each
have its own zone. If required, one of the mechanisms above can be used to allow

user access to multiple zones and therefore to multiple “separate” VLANSs.
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TROUBLESHOOTING IP ACCESS

The most effective way to troubleshoot IP Access is to view the logs.

VIEW THE DOCKER LOGS

run the following command on Lighthouse, either as root or with sudo (for non-root

admins):
sudo docker logs -t central-sdi

The logs for the central-sdi Docker container, which controls client IP Access

display.

2022-10-03T10:03:19.051579136Z INFO:root:[NetOps-SDI node="nodes-36"
username="maverick"] VPN client authenticated
2022-10-03T10:03:19.0943137622 2.29.37.12:65437 TLS:
Username/Password authentication succeeded for username
'maverickl23:0M1208-UK2'

2022-10-03T10:03:19.422971278Z 2.29.37.12:65437 Control Channel:
TLSv1.3, cipher TLSv1l.3 TLS AES 256 GCM SHA384, peer certificate:
2048 bit RSA, signature: RSA-SHA256

2022-10-03T10:03:19.422999989Z 2.29.37.12:65437 [LH5-UK3-22] Peer
Connection Initiated with [AF INET]2.29.37.12:65437
2022-10-03T10:03:22.000300953Z INFO:root:[NetOps-SDI node="nodes-36"
username="maverickl23"] VPN client connected with IP 172.31.0.8
netmask 255.255.0.0

2022-10-03T10:03:22.084275387Z LH5-UK3-22/2.29.37.12:65437 OPTIONS

IMPORT: reading client specific options from: /tmp/openvpn cc
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3aa5d19c3eal9b3bbac56feobacf/boe. tmp

2022-10-03T10:03:22.084324213Z LH5-UK3-22/2.29.37.12:65437 Data
Channel: using negotiated cipher 'AES-256-GCM'
2022-10-03T10:03:22.084332293Z LH5-UK3-22/2.29.37.12:65437 Outgoing
Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2022-10-03T10:03:22.084337215Z LH5-UK3-22/2.29.37.12:65437 Incoming
Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2022-10-03T10:03:22.084342034Z LH5-UK3-22/2.29.37.12:65437 SENT
CONTROL [LH5-UK3-22]: 'PUSH REPLY,ping 10,ping-restart 120, route
192.168.2.0 255.255.255.0 172.31.0.1 1,ifconfig 172.31.0.8
255.255.0.0,peer-id 0,cipher AES-256-GCM' (status=1)
2022-10-03T10:03:22.084950386Z LH5-UK3-22/2.29.37.12:65437 PUSH:
Received control message: 'PUSH REQUEST'
2022-10-03T10:03:22.085204467Z LH5-UK3-22/2.29.37.12:65437 PUSH:
Received control message: 'PUSH REQUEST'
2022-10-03T10:03:22.085220316Z LH5-UK3-22/2.29.37.12:65437 PUSH:
Received control message: 'PUSH REQUEST'
2022-10-03T10:03:22.432350278Z LH5-UK3-22/2.29.37.12:65437 PUSH:
Received control message: 'PUSH REQUEST'
2022-10-03T10:03:23.120616769Z INFO:root:[NetOps-SDI node="nodes-36"

username="maverick"] VPN client identified by MAC c6:87:ca:4a:3b:2c

Note the PUSH_REPLY line above shows that the IP Access client has been pushed
the route to the network 192.168.2.0/24 which in this case is the interface on this
Node in the firewall zone that the user was mapped into. (Unfortunately, the firewall
zones are not listed in this log output). If there are errors with authentication, then

they will show up here.
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USING THE ROUTING TABLE

When troubleshooting IP Access it is useful to look at the routing table on the target
Node to make sure that routes to the target networks are installed. If the interface is

down, for example, then the route is not present and will not be pushed to the client.

The following commands can be used to display the routing table on the target OM

Series Node:

route

ip route

The Routing table displays:

root@OM1208-UK2:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway 0.0.0.0 UG 110000001 O O netl

5.5.5.0 0.0.0.0 255.255.255.0 U 0 0 O swOp8

172.17.0.0 0.0.0.0 255.255.0.0 U 0 O O dockerO
172.31.0.0 0.0.0.0 255.255.0.0 U 0 0O 0 ipa-br0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 O net2
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 O netl
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 swOp2

192.168.128.0 0.0.0.0 255.255.224.0 U 0 0 O tunO

14

root@OM1208-UK2: ~#

root@OM1208-UK2:~# ip route

default via 192.168.1.1 dev netl proto static metric 110000001
5.5.5.0/24 dev swOp8 proto kernel scope link src 5.5.5.5
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1

linkdown

172.31.0.0/16 dev ipa-br0 proto kernel scope link src 172.31.0.1
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192.168.0.0/24 dev net2 proto kernel scope link src 192.168.0.48
192.168.1.0/24 dev netl proto kernel scope link src 192.168.1.48
192.168.2.0/24 dev swOp2 proto kernel scope link src 192.168.2.8
192.168.128.0/19 dev tun0 proto kernel scope link src 192.168.128.6

root@OM1208-UK2:~#

The ip route command output is useful as it shows the interface IP address of the

OM, which should be reachable via IP Access as long as that interface is up.

Other standard network troubleshooting techniques can be used from the Node, for
example testing the ability to ping a target device, or using curl if it has an http or

https interface.
Examples

ping 192.168.2.4

curl -k https://192.168.2.4/

SECURE PROVISIONING

Secure Provisioning for NetOps is a configuration storage, distribution and
provisioning system. It does not generate, test or validate device configuration.
Instead, it is focused on provisioning remote managed devices with user-supplied
configuration and device OS images — automatically, remotely and securely, no

matter where those devices are and no matter what the state of the network is.
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Using Secure Provisioning for NetOps, network turn up no longer requires network
engineering staff to perform initial configuration tasks on site, even when there is no
existing LAN or WAN in place. Remote hands rack, stack and cable the
infrastructure, then Secure Provisioning for NetOps Automation automates the rest

of the turn up process.
The Secure Provisioning module leverages these technologies:

* ZTP (Zero Touch Provisioning): The process by which managed devices in their
unconfigured state request and are delivered initial setup resources over the local

management network

* Human-readable YAML language: Provides simplified configuration of managed

device ZTP configuration parameters

» Git source control: Managed Device resources such as initial configuration files

and OS images are automatically stored in a versioned, auditable repository

* Ansible automation framework: Automatically propagates device resources and

configures on-site ZTP services

The Secure Provisioning module combines a centrally orchestrated, vendor-neutral
ZTP service with on-site node LAN and WAN connectivity, to automate the

provisioning process end to end.

SECURE PROVISIONING CONFIGURATION MANAGEMENT

Secure Provisioning always applies device configuration in its entirety and does not
support applying config patches or deltas to a provisioned device (for example,

adding a few lines to running config, to enable a specific feature).
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STATELESS FILE MANAGEMENT

Secure Provisioning supports a DevOps-style approach which collapses initial
provisioning, disaster recovery and ongoing maintenance workflows into the one

workflow:

Using this approach, the config patch is applied in Lighthouse to the central
configuration template via git, which renders the configuration file in its entirety and
pushes to the OM node. The device is factory reset and pulls the new configuration

as if it were being provisioned for the first time.

Pros:

* Eliminates config drift

* Enforces config reproducibility

* Central audit trail of all configuration changes

* Disaster recovery becomes as simple as resetting all devices to reprovision
Cons:

* Requires a longer maintenance window as the device is reset and reboots

» Patches cannot be applied to running configuration

STATEFUL DEVICE MANAGEMENT GATEWAY

The NetOps Automation platform provides a management fabric from remote
devices to your central management network via Lighthouse VPN and/or the cellular
WWAN.
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There are many tools and protocols purpose-built for stateful configuration
management, such as Cisco NSO and SolarWinds NCM, and NETCONF and gRPC
(OpenConfig).

NetOps can be leveraged by these tools as a secure, resilient management path —
both extending their reach to the out-of-band management network, and ensuring

reachability during outages.

HOW SECURE PROVISIONING WORKS

The Secure Provisioning feature centrally orchestrates the distribution of managed
device configuration files and firmware images, and the node provisioning (ZTP)

services required to deliver the files to managed devices.

Secure Provisioning is configured by defining the resources to provision managed
devices with, and defining how these resources should be distributed around your

network.

* Device Resource Bundles contain the files needed to provision one or many

managed devices:
» Configuration File, Script File and/or Image Files.
* Each Resource Bundle has a defined Device Type.

* When a Resource Bundle is distributed to a node, any ZTP request matching

the Device Type are provisioned with the bundled resources.

* This may be restricted to specific devices by specifying one or more device
MAC Addresses (range and reverse match supported) or Serial Numbers

(not supported by all vendors).
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* Resource Distribution policies are defined by Node Inventory Lists:

« A Static Node Inventory List - a predefined, static list of nodes to distribute

to

* ADynamic Node Inventory List - evaluates a Smart Group each time

resources are distributed.

Tip: The Dynamic Node Inventory List allows you automatically tag
certain nodes with Enrollment Bundles, for example, by region or site
class, to help automate resource distribution to newly enrolled nodes in

that region.

Device Resource Bundle and Resource Distribution configuration are supplied to
Lighthouse using the web Ul or CLI (git) method. The Web Ul configuration method
creates an underlying YAML configuration the same as created using the git

method, it is effectively a front end to the git method.

A git push to the Lighthouse repository or clicking the Ul Push Now/Push

Resources button triggers a resource push:

* A git post-commit hook triggers an Ansible playbook on Lighthouse.
* The playbook copies resources down to nodes, securely over Lighthouse VPN.

* The playbook start or restarts ZTP services on nodes.

SUPPORT FOR SECURE PROVISIONING

Opengear OM2200 and OM1200 nodes may be activated as Secure Provisioning

nodes.
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Opengear ACM7000 or IM7200 nodes may also be activated as provisioning nodes,

however not all features are available and there are some caveats to be aware of.
Features that are not available of ACM7000/IM7200 nodes:

» Secure boot and physical tamper resistance.

* Encryption of device resource files at rest.

» Centralized ZTP status logging.

* Device configuration templating.

* Ordered provisioning.

» Post-provisioning scripts.

Other ACM7000/IM7200 caveats:

» Secure Provisioning takes control of node DHCP, NTP, DNS services and

overwrites system configuration.

» Secure Provisioning overwrites node Management LAN configuration.

VENDOR MANAGED DEVICES SUPPORTED BY SECURE
PROVISIONING

Secure Provisioning is vendor-neutral, with support for a broad range of network

devices from multiple vendors.

The ZTP process used to provision devices is not standardized, and each vendor
OS implements ZTP differently — for example, using differing DHCP options, or

requiring an intermediary script to load files.
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With Secure Provisioning, you upload configuration and/or firmware image files to
create Resource Bundles, then select the vendor profile for that Resource Bundle.
This automatically generates the vendor-appropriate ZTP configuration, simplifying

the delivery of resources to target devices.

Secure Provisioning currently has built-in support for provisioning devices from

these vendors:

» Cisco (I0S, IOS XR, 10S XE, NX-OS)
e Juniper

* Arista

* HPE/Aruba

* Huawei

* Cumulus

* Pica8

* Opengear

Advanced users may add support for additional devices using custom DHCP

configuration.

LOCAL NETWORK SERVICES PROVIDED BY NODES

In addition to zero touch provisioning (ZTP) services, the local node runs local
services required to act as a bootstrap management LAN and secure WAN for

managed devices, from day zero onwards.
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When responding to a BOOTP/DHCP provisioning request from a device, the

Operations Manager node hands out its own local address as:
DEFAULT GATEWAY

Devices trying to reach to destinations on the central LAN that Lighthouse resides
on are securely routed over Lighthouse VPN. This allows devices to reach, for
example, central NMS for monitoring, and central configuration systems for final

service provisioning.

Requests to other remote destinations are masqueraded behind and routed out the
node's built-in cellular WWAN, allowing devices to reach cloud provisioning

services.

Note that device requests are masqueraded to Lighthouse's central IP and will

appear to be originating from Lighthouse to hosts on the central LAN.

All traffic between remote node network and the central Lighthouse network is

securely tunneled inside Lighthouse VPN.
DNS SERVER

DNS lookups from devices are securely proxied through Lighthouse VPN to the
central DNS server(s) used by Lighthouse, allowing devices to resolve central hosts

from day one.
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NTP SERVER

The NTP Server allows devices to set accurate time on first boot, for example, for
certificate verification and generation. By default, the node's NTP service uses its

local hardware clock as time source.

SYSLOG SERVER

The Syslog Server relays messages to a central LogZilla instance (this is an optional
extra module). This allows log collection from day zero, and analysis of the device

ZTP process itself.

SECURE PROVISIONING CONFIGURATION

All system configuration is performed via Lighthouse. The configuration necessary
to provision a device consists two elements. The basic steps to configure Secure

Provisioning are:

» Create Device Resource Bundles and upload resource files (for example,

configuration files or scripts, firmware images) to Lighthouse.

* Define Node Inventories to distribute the resources to specific nodes, where they

will become available for devices to request for provisioning.
DEVICE RESOURCE BUNDLE

A Device Resource Bundle contains the resource files, such as, a configuration file
and OS upgrade image, that are loaded via ZTP (DHCP + TFTP/HTTP) onto the
managed device. This may be a full, final configuration, or a baseline configuration
to allow the managed device to become managed by an upstream configuration

service.
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As each vendor's ZTP process is slightly different, Device Resource Bundles allow
you to select the Device Type. This generates the appropriate ZTP server
configuration (DHCP options), any necessary intermediary provisioning scripts and

enables device-specific ZTP features, such as serial number matching.

By default, Device Resource Bundles are targeted to all managed devices of the
selected Device Type. Bundles may be targeted to specific managed devices by
specifying one or more device MAC addresses (including range and reverse match),

or in some case by specifying one or more device serial numbers.
NODE INVENTORY

A Node Inventory is a static or dynamic list of nodes and a corresponding list of
Device Resource Bundles. This defines how Device Resource Bundles are

distributed around your network.
Resource Bundles may be distributed using one of two methods:

* Push to a static list of nodes, selected individually by node ID

* Push to a dynamic list of nodes, linked to a Lighthouse Smart Group of nodes
Note:You may combine distribution methods.

Topic continued on next page:
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CREATE DEVICE CONfiGURATION

To provision a managed device, you must supply device resources. Device
resources consist of an initial configuration file for the device to install, and

optionally a operating system image for the device to upgrade itself with.

Device resource file formats are specific to the target vendor. Secure Provisioning

for NetOps Automation provisions these files, but does not generate them.
For example, a trivial Arista initial configuration file may look like:
demo_arista.cfg

hostname nom—demo—switceh
I
interface Managementl

descripticn ZTP Mgmt Interface
ip address 10.0.0.123/24

!

banner login

Welcome to $(hostname) !

;o
WA Provisioned by
{ ) L. Opengear NetOps Automation
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A trivial Cisco I0S XR initial configuration may look like:

Cisco I0S XR initial configuration:

I Ios XER
!
hostname nom-—demo-router
!
username admin
group reoot-lr I
group cisco-support
gecret 5 S1S50k9Y¥YSx/GCO¥sUPrEYOwlsS5cCdW3d
!
interface MgmtEthO/REO0/CEUC/O
description ZTP Mgmt Interface
ip address 10.0.0.200 255.255.255.0
I

banner Eﬁgé “Welcome to £ (hostname) !

() == Provisioned by

| | Cpengear NetOps Rutomation
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ACTIVATE THE SECURE PROVISIONING MODULE ON
LIGHTHOUSE

The Secure Provisioning license is installed on Lighthouse and contains a preset
number of available node activations. Each node activated for Secure Provisioning

consumes an available activation; Lighthouse itself does not consume an activation.

Installing the Secure Provisioning license automatically activates Secure
Provisioning on Lighthouse, at which point the NetOps Automation platform installs

the central Secure Provisioning software components on Lighthouse.

1. Install the Enterprise Automation Edition license under SETTINGS > System >

Subscriptions.

2. Install an applicable legacy license, or, apply an Automation Edition subscription,

to enable Secure Provisioning under SETTINGS > System > Subscriptions.

* It will take a few minutes for the Secure Provisioning to activate on Lighthouse,

view progress under CONFIGURE > NetOps Modules > Manage Modules.
3 Click the C Update icon and note new menu items are now available under

CONFIGURE > Secure Provisioning.

Secure Provisioning may now be selectively activated on nodes automatically as

they enroll, or activated on nodes manually after enrollment.

INSTALL THE NODE

1. Connectthe NET1 Ethernet to a network port via which node can reach the

Lighthouse VM Connect power to the node.

2. By default, the node requests a DHCP address and has a static address of
192.168.0.1/24.
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3. Testyou can reach the node address via ping, SSH and HTTPS, and note this

address for the following step.
CONFIGURE A PER-NODE MODULE ACTIVATION POLICY

The process of automatically or manually activating Secure Provisioning on a node

prepares it to become a Secure Provisioning server, securely over Lighthouse VPN.

Activating a node for Secure Provisioning consumes an activation from the license.
Deactivation returns the activation to the available pool. To deactivate and remove a
NetOps Module from a given node, see "Deactivate (remove) a NetOps Module" on

page 301.

Note:Operations Manager activation deploys the Secure Provisioning container

to the node, which may take several minutes.

OPTION A. AUTOMATICALLY ACTIVATE ALL NODES UPON
ENROLLMENT

This is the default policy. When a license is present and activations are available, all
nodes are activated for Secure Provisioning as they enroll. Nodes that have been

previously enrolled must be manually activated.

1. Ensure CONFIGURE > NetOps Modules > Manage Modules > Secure

Provisioning > Always Activate is checked and applied.

2. To activate a node, enroll it into Lighthouse.

OPTION B. AUTOMATICALLY ACTIVATE SELECT NODES UPON
ENROLLMENT

You may selectively activate Secure Provisioning on a subset of nodes using
Enroliment Bundles. Only nodes enrolling using one of these bundles will be

automatically activated.
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. Uncheck CONFIGURE > NetOps Modules > Manage Modules > Secure

Provisioning > Always Activate and click Apply.

Select CONFIGURE > Node Enroliment > Enroliment Bundles and add a new
bundle (you may also edit an existing bundle) Enter a bundle Name and Token,

and choose whether or not to Auto-Approve enroliment.
Scroll down to NetOps Modules and add Secure Provisioning then Apply.

When enrolling the node to Lighthouse, specify the Enrollment Bundle Name

and Token.

Note:Lighthouse-initiated manual enrollment (i.e. clicking the Add Node button
in the Lighthouse web Ul) does not support bundles, you must use a node-

initiated enrollment method.

OPTION C. MANUALLY ACTIVATE NODES AFTER ENROLLMENT

1.

2.

4.

Select CONFIGURE > Configuration Templating > Apply Templates.

Under NetOps Module Activation, select Secure Provisioning and click Next.

Select the nodes to to activate and click Next.

To ensure the preflight check has succeeded click the C Update icon above the

table, then click Next.

Click the C Update icon, to ensure activation is successful.

ENROLL THE NODE INTO LIGHTHOUSE

1.

2.

Launch an HTTPS browser session to Lighthouse.

Login using root and the secure password set earlier.
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Tip: You may also login as a Lighthouse Administrator user, if you have

configured one.

3. Atthe top of the UI, click Add Node.
4. Select An Opengear appliance, the second option in the Product dropdown list.

5. Enter the Operations Manager's Network Address, Username (root) and

Password (default) Check Auto-approve node then Apply.
6. From menu, select CONFIGURE -> Node Enrollment -> Enrolled Nodes then

click the C Update icon to check enrollment has completed.

7. If you are using the Automatically activate select nodes upon enroliment policy,

you must manually activate the node after enroliment.

The node now has a secure Lighthouse VPN (OpenVPN) tunnel back to Lighthouse,

over which all communications are now secured.
CONNECT TARGET DEVICE

Secure Provisioning currently supports provisioning devices from these vendors:
» Cisco

e Juniper

* Arista

* HPE/Aruba

* Huawei

* Cumulus

* Pica8

* Opengear
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Note:Additional devices may be supported using custom DHCP configuration.

To request built-in support for additional devices, contact customer support.

PROCEDURE
1. Connect a supported managed device's management NIC directly to the node.
2. If the node has a built-in Ethernet switch, connect the device to any switch port.

3. Otherwise, connect the device directly to the node's NET2 Ethernet, or via an

intermediary management switch.
4. Power on the managed device.

5. Ensure the managed device is in ZTP mode, this typically requires the device to

have its configuration erased/reset to factory defaults.

UI-BASED WORKFLOW

Each NetOps Module provides a simple web Ul for configuration and status
monitoring. This Ul is designed primarily for manual operation, evaluation and
testing. For comprehensive automation, refer to the CLI-based workflow section that
follows. It may be useful to familiarize yourself with the system using the Ul before

adopting a CLI-based workflow.

Note:Changes pushed to nodes via the Lighthouse Ul or API will override those
made by direct repository access, therefore Ul- based or CLI-based workflows

should be considered mutually exclusive modes of operation.

Ul WORKFLOW

Launch an HTTPS browser session to Lighthouse.
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Login using root and the secure password set earlier.

Tip: You may also login as a Lighthouse Administrator user, if you have one

configured.

CREATE DEVICE RESOURCE BUNDLE

1. Inthe menu, navigate to CONFIGURE > Secure Provisioning > Device

Resources.

Enabling Advanced Functionality



\\\/ LIGHTHOUSE

Access Portal

2. Click the Add (+) button. The Modify Device Resource page opens.
MODIFY DEVICE RESOURCE

DEVICE RESOURCE DETAILS

MName

Device Type

Cisco 105 XR

Configuration File ®

demo_xrv.cfg

No file chosen ‘

Image File )

‘ No file chosen ‘

MAC Addresses (3

‘ 36-B4:76:25:-AD:D8 ‘ -

-+

Serial Numbers &

ADVANCED

Advanced features are only available on Operations Manager nodes.
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. Choose a Name to identify this bundle, for example, demo_bundle1.

. Select the Device Type corresponding to a target managed device.

Note:Each device type may display different resource fields documented

below, this is dependent on the device-specific ZTP featureset

. The Configuration File is the initial configuration file for the device to load via
ZTP. Select a previously uploaded file or click the Browse button to upload a new

file.

. The Image File is the initial software image for the device loaded via ZTP. Select

a previously uploaded Image File or click the Browse button to upload a new file.

. Optionally, target this bundle at devices matching the specified MAC Addresses,

click the Add and Remove buttons when specifying multiples.

Note:Each MAC address is specified in full, using a wildcard (for example,
00:10:FA:C2:BF:*), or negated to exclude from the match (for example,
101:23:45:67:89:AB)

. Optionally, target this bundle at devices matching specified Serial Numbers,

click the Add and Remove icons when specifying multiples.

. Click Save.
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DEFINE RESOURCE DISTRIBUTION

See the Node Inventory section earlier in this document for an overview of available

distribution methods.

DEFINE A STATIC NODE INVENTORY
1. Navigate to CONFIGURE > Secure Provisioning > Resource Distribution.

2. Under Static Node Inventory List click the Add + button. The New Node

Inventory window opens, displaying inventory details.
3. Choose, and enter a Name to identify this bundle, for example, branchinventory_

4. From the Resource Distribution list, select the bundles to distribute.

NEW NODE INVENTORY
INVENTORY DETAILS

Name

Resource Distribution

s ] NAME DEVICE TYPE RESOURCES

i example_router cisco_xr Configuration File: demo_xrv.cfg

] example_switch arista Configuration File: demo_arista.cig

A FILTERING

Smart Group Filtering Free Text Search

Select Smart Group...

5. Select the Nodes to which these bundles are to be distributed.

Note:The Free Text Search and Smart Group filter options are to help

locate nodes for inclusion in the static inventory, these filters are not applied
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dynamically to the inventory going forward.

6. Click Apply.
DEFINE A DYNAMIC NODE INVENTORY

1.

2.

Create a Lighthouse Smart Group. See "Creating Smart Groups" on page 163

In the Lighthouse Ul, navigate to CONFIGURE > Secure Provisioning >

Resource Distribution.

Under Dynamic Node Inventory List click the Add + button. The Modify Node

Inventory window opens, displaying inventory details.
Choose, and enter a Name to identify this bundle, for example, Lablnventory

Select the Smart Group to link to this inventory,

Note:this Smart Group search is dynamically evaluated to a list of nodes

each time resources are pushed.

Select the bundles to distribute, listed in the Resource Distribution table.

Click Apply.

Note:Changes to resource bundle or distribution configuration are not

applied to nodes immediately, they must be explicitly pushed to nodes.
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PUSH RESOURCES

Any changes to the resource bundle or distribution configuration made in the
previous steps are not applied to nodes immediately, they must be explicitly pushed

to nodes.

When changes are detected, a Push now button is displayed above the Secure

Provisioning Ul pages.

There are resource changes that have not yet been pushed to nodes. Push now

+" Details saved successfully

Resources may always be resynchronized by clicking CONFIGURE > Secure

Provisioning > Resource Distribution > Push Resources.

The push operation distributes resource bundles as configured, then as needed
restarts DHCP services on remote nodes. Push status is displayed above the

Secure Provisioning Ul pages.

You may also monitor the syslog output on Lighthouse for low-level output from the

Ansible playbook.

CLI BASED WORKFLOW

Advanced automation users may choose to manage device resources and resource

distribution with direct access to the central file repository on Lighthouse.
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All necessary resource and configuration files are uploaded to Lighthouse using the
Secure Copy protocol such as scp, WinScp or similar - or advanced users may

prefer to use git directly.

If you have adopted DevOps-style configuration management using your own
source repository (such as git, Mercurial or Subversion) and/or configuration
deployment using continuous integration (such as Jenkins or GitLab), this interface
also provides a convenient way to hook the Opengear system into these tools and
workflows. For example, a configuration commit in the upstream system could
automatically proliferate to the Lighthouse file repository, and then in turn to the

downstream nodes.

Note that changes pushed to nodes via the Lighthouse Ul or APl will override those
made by direct repository access, therefore Ul- based or CLI-based workflows

should be considered mutually exclusive modes of operation.
CREATE CONFIGURATION YAML

The first step is to assign resource files to specific device types (collectively known
as device resources), and to assign device resources to be deployed to specific

nodes.

Tip: The web Ul provides a convenient way to start provisioning managed
devices without needing to be fully familiar with YAML or git. The generated
YAML files that controls resource bundling and distributions is located on
Lighthouse, inside the central-dop container. You can view it by running the
following command:

sudo docker exec -it central-dop cat /srv/central-

ui/root/config.yml | less
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Use a YAML file to bundle device resources, and control the distribution of device

resources from Lighthouse to the nodes.

PROCEDURE
1. Create a new directory or folder of your choosing, for example: nom-prov
2. Inside the nom-prov directory, create a new directory or folder called: downloads.

3. Inthe nom-prov directory, create a file with the .yml or.yaml extension, using the

following format:

nom-prov.yml

device resources:
demo_ arista:
device type: arista
config file: 'demo arista.cfg'

image file: 'arista eos.swi'

node inventory:
MyNodes:
static:

- nodes-1
deployment:

MyNodes:

- demo_arista

Note:Note that indentation is meaningful in YAML, and you must use space

characters not tabs to indent.
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The device_resources list groups and assigns resource files to particular device

types (i.e. resource bundles).
4. Choose an identifier for each resource bundle item, for example:. demo_arista.

5. For each item, you must provide the device_type, as well as well as one or more

resources, ie. config_file or image_file.

» device_type matches this device resource item to all devices from the specified
vendor — it may be one of the folowing: Cisco, Cisco_xe, Cisco_xr, Cisco_nkx,

Juniper, Arista, Aruba, Huawei, Cumulus, Pica, Opengear.

» config_file is the initial configuration file for the device to load via ZTP, as

present in the downloads directory.

* image_file is the initial software image for the device to load via ZTP, as present

int he downloads directory.
Note:HPE/Aruba devices do not support the image upgrade via ZTP.

The Cisco Autoinstall process does not support image upgrade via
ZTP, to automate image upgrade you must supply a TCL script file

rather than a configuration file.

* mac_address optionally target this bundle at the listed MAC address(es), which
may be specified in full, using a wildcard (for example, 00:10:FA:C2:BF:*), or
negated to exclude from the match (for example, 101:23:45:67:89:AB)

* serial_number optionally target this bundle at the listed serial number(s)

Device resource items are then assigned to nodes using the deployment and
optionally the node_inventory lists. See Node Inventory for an overview of

available distribution methods.
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The node_inventory list defines groups of nodes.

Choose an identifier for each inventory, for example:. branchinventory or

labinventory _

DEFINE A STATIC INVENTORY:

1. Create a list named static.

2. List nodes by node ID, for example, nodes-1.

3. You can view node IDs by running the following command on Lighthouse: node-

info --all
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DEfiNE A DYNAMIC INVENTORY:

1. Create a Lighthouse Smart Group, as documented in the Creating Smart Groups

section of the Lighthouse User Guide.

2. Create a key named smartgroup with a value of the Smart Group name, this
Smart Group search is dynamically evaluated to a list of nodes each time

resources are pushed

The deployment list assigns device resources to the node inventories defined

above, or all nodes.

* Deployment identifiers correspond to node_inventory identifiers, for example,

branchinventory .

» Assign device resources by listing device resource items, for example, demo_

arista.

* You may have multiple device resources per deployment.
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A more comprehensive YAML file may look like:

more-devices.yml

device resources:
access_switch:
device type: juniper
config file: 'jn-switch35.config'
image file: 'Jjinstall-ex-4200-13.2Rl1.l1-domestic-signed.tgz’
mac_address:
- '00:00:0c:15:c0O0:*"
- '"!100:00:0c:15:c0:99"
branch router:
serial number:
- 'SAD15300D4wW'
- 'FOC1749N1BD'
- '"AVJ18163A52"
config file: 'branch xr.cfg'
device type: cisco_ xr
demo_ arista:
device type: arista
config file: 'demo arista.cfg'

image file: 'arista eos.swi'

node inventory:
branch inventory:
static:
- nodes-1

- nodes-2
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- nodes-10
lab inventory:

smartgroup: LabNodes

deployment:

lab inventory:

- demo_arista

- access_switch
branch_inventory:
- branch router

- access_switch

HOW Ul FIELDS CORRESPOND TO THE YAML FILE (EXAMPLE)

The following example YAML file contains line-by-line comments (blue text)

denoting the Ul page or field above each corresponding YAML element:

# CONFIGURE NODES > Secure Provisioning > Device Resources
device resources:
# Device Resource Details > Name
access_switch:
# Device Resource Details > Device Type
device type: juniper
# Device Resource Details > Configuration File
config file: 'jn-switch35.config'
# Device Resource Details > Image File
image file: 'Jjinstall-ex-4200-13.2R1.1-domestic-signed.tgz’
# Device Resource Details > MAC Addresses

mac_address:
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- '00:00:0c:15:c0:*"

= "10030030csl53c0899"

# Device Resource Details > Provision After
provision after:

- branch router

# Device Resource Details > Name

branch router:

# Device Resource Details > Device Type
device type: cisco xr
# Device Resource Details > Serial Numbers
serial number:
- 'SAD15300D4W’
- '"FOC1749N1BD'
- '"AVJ18163A52"

# Device Resource Details > Configuration File

config file: 'branch xr.cfg'

# Device Resource Details > Name
demo arista:

# Device Resource Details > Device Type
device type: arista
# Device Resource Details > Configuration File
config file: 'demo arista.cfg.j2'
# Device Resource Details > Image File
image file: 'arista eos.swi'
# Device Resource Details > Post-Provisioning Script

post provision script: arista fixups over ssh.py
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post provision script timeout: 900

# CONFIGURE NODES > Secure Provisioning > Resource Distribution
node inventory:

# Static Node Inventory List > Inventory Details > Name
BranchInventory:

# Inventory Details > Select Nodes

static:

- nodes-1

- nodes-2

- nodes-10

# Dynamic Node Inventory List > Inventory Details > Name
LabInventory:
# Inventory Details > Smart Group

smartgroup: LabNodes

# CONFIGURE NODES > Secure Provisioning > Resource Distribution
(mostly!)

deployment:

# CONFIGURE NODES > Secure Provisioning > Resource Distribution
Inventory Details > Resource Push

LabInventory:

- demo_arista

- branch router

- access_switch

# CONFIGURE NODES > Secure Provisioning > Resource Distribution >
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Inventory Details > Resource Distribution
BranchInventory:
- branch router

- access_switch

UPLOAD CONfiGURATION AND RESOURCES
1. Assemble device resources on your PC or laptop in preparation for upload.
2. Locate the nom-prov directory created in the previous section

3. Copy device resources into nom-prov/downloads.

Your locally assembled files will now look similar to that below:

L— nom-prov
F—— nom-prov.yml
L— downloads
}—— arista eos.swi

L— demo arista.cfg

You must now choose how you will upload files to the central Secure Provisioning

repository, using Secure Copy or git.
OPTION A. SECURE COPY METHOD

Secure copy the entire nom-prov directory to Lighthouse port 2222, to the
Isrvicentral-auto/ directory and authenticating as root, for example, using the scp

command:
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cd nom-prov

scp -P 2222 -rp ./* root@192.168.0.1:/srv/central-auto/

.. where 192.168.0.1 is the IP address of Lighthouse.

Secure Provisioning now automatically propagates the device resources to the
nodes specified by the YAML, it automatically configures and starts or restarts ZTP

services on the nodes.

At this point, target device will begin the ZTP process and become provisioned.
OPTION B. GIT METHOD

Advanced users may choose to access the Secure Provisioning git repository on
Lighthouse directly, rather than using scp. This has the advantage of supporting
commit messages and integrate with upstream git or other continuous integration

systems.

Example commands to initialize the repository for the first time:

ssh-copy-id root@192.168.0.1

cd nom-prov

git init

git remote add origin ssh://root@192.168.0.1:2222/srv/central
git add -A

git commit -a -m "Initial commit of ZTP resources"

git push origin master

.. where 192.168.0.1 is the IP address of Lighthouse.

Once the repository has been initialized, subsequent users can operate on it using

the clone command:
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ssh-copy-id root@192.168.0.1

git clone ssh://root@192.168.0.1:2222/srv/central nom-prov

cd nom-prov

echo >> nom-prov.yml

git commit -a -m "Whitespace change for testing, please ignore"

git push origin master

.. where 192.168.0.1 is the IP address of Lighthouse.
ADDITIONAL RESOURCE FILES AND DEVICE TYPE FILES

You may also provide additional resource files that are not explicitly part of Device
Resource Bundles, for example, final configuration files that may be conditionally

fetched and applied by the device's primary ZTP script.

You may also extend Secure Provisioning to support additional device types by

providing ISC DHCP configuration snippets, for example:

new-vendor.conf

class "new-vendor-class" {
match if (option vendor-class-identifier = "new-vendor";
option bootfile-name "new-vendor.cfg";

}

Additional files must be placed in the subdirectory named after the Node Inventory
they will be deployed to. Within this subdirectory, files must be placed in the

following:

* Resource files such as device configuration or image files are placed in the

downloads directory.

Enabling Advanced Functionality



\ LIGHTHOUSE

Access Portal

* Advanced: DHCP snippets may be placed in the dhcpd directory.

Directly added files are pushed together with YAML-generated files to the nodes. An
example local directory structure is shown below with a YAML config file from the

earlier example, as well as manual new-vendor files added to the my_inventory

directory:
L— nom-prov
|-—— nom-prov.yml

— downloads
| — demo arista.cfg
| — cumulus_interfaces
| — cumulus setup.sh
| L— arista eos.swi
L— my inventory
— downloads
| L— new-vendor.cfg
L— dhepd

L — new-vendor.conf

The files are uploaded to the central Secure Provisioning repository, using Secure

Copy or git, in the same way as the earlier example.

CONFIGURE DEVICE RESOURCES VIA ZTP

There are two factors that determine which resources are delivered to which devices
viaZTP:
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DEVICE RESOURCE BUNDLE MATCHING

As well as containing resource files themselves, each Resource Bundle itself has a
few extra parameters: device vendor, device MAC address(es) and device serial
number(s) (not supported by all vendors). Of these, only the device vendor is

mandatory.

When a managed device broadcasts a BOOTP/DHCP request to initiate ZTP, it
advertises its vendor ID string, MAC address, and in some cases serial number.
These values are compared to the values in each Resource Bundle contained on the

local node.

If there's a match, the local node provisions the device with the resource files in the

matching bundle.

RESOURCE DISTRIBUTION

Node Inventories are used to selectively control which Resource Bundles are

pushed to which nodes.

A node will only respond to a BOOTP/DHCP request on its local network if a

matched Resource Bundle has been pushed to it.

Note that resources are not distributed any nodes by default.

BASELINE VS FINAL DEVICE CONFIGURATION

Broadly speaking, there are two approaches to secure provisioning using ZTP.

You may use strict matching and distribution settings to provision specific devices

with unique, final configurations.
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Alternatively, you may use laxer matching and wider distribution settings to provision
many devices with a baseline configuration, for example, "just enough configuration"
to route to a central production configuration system for final configuration and

service provisioning.

You may also combine the two approaches, for example, use a reverse MAC
address match to opt a specific device or devices out of an otherwise general,

baseline configuration.

RUN A SCRIPT ON A NEWLY PROVISIONED DEVICE

Note:Post-provisioning scripting is an advanced feature only supported by

Operations Manager nodes.

It is possible to upload a script and associated with a device Resource Bundle, to be
run by remote Operations Manager node once a Managed Device is considered
provisioned. A device is considered to be in a provisioned state once has

downloaded all of the files in the Resource Bundle it is being provisioned with.

The script may be uploaded and associated via the Ul during Resource Bundle
creation using the Post-Provisioning Script option, or via git/scp and the "CLI

based WorkFLow" on page 351.

Scripts may be implemented in bash, Python 2 or Python 3, and must start with a

shebang —i.e. the first line must be one of:

#!/bin/bash
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#!/usr/bin/env python2

#!/usr/bin/env python3

» Scripts are run in a monitored background processes in the Secure Provisioning

container (remote-dop) on the node.

» Scripts have a default 15 minute timeout, this can be manually configured in the

YAML config (post_provision_script_timeout).

» Scripts may login to target device via the network using SSH key auth where
nom remote ssh pub key has been injected into the device config, or using

username/password with the sshpass command.

MONITOR THE ZTP PROGRESS OF A MANAGED DEVICE

The current provisioning state of managed devices can be monitored via syslog on

the Operations Manager (local devices only) or Lighthouse (all devices).

Each Secure Provisioning syslog message contains a prefix identifying the MAC

address of the device being provisioned, similar to:

[NetOps—-DOP device="01:23:45:67:89:AB"]

For example, here are sample messages showing an Opengear ACM7004 device

being provisioned:

Enabling Advanced Functionality



\ LIGHTHOUSE

Access Portal

[NetOps—-DOP device="00:13:C6:EF:00:08"] Received DHCP request from
device with vendor ID Opengear/ACM7004-5-LMR
[NetOps-DOP device="00:13:C6:EF:00:08"] Assigned DHCP address of

10.0.0.2 to device

[NetOps—-DOP device="00:13:C6:EF:00:08"] Provisioning device with

resource bundle my\ acm7004
[NetOps—-DOP device="00:13:C6:EF:00:08"] Device retrieved resource

file /files/acm7004-5-4.3.1.flash via HTTP/HTTPS

Syslog can be viewed from the CLI by running:

tail -F /var/log/messages | grep NetOps-DOP

WAN GATEWAY SERVICES

In addition to LAN provisioning, the node can utilize its built-in cellular connection to
act as a WAN gateway and provide a proxy to essential services for devices on day

one.
The node's DHCP server hands out the node's address as:
* NTP server

* This is a local service, synced to the node's system clock

e DNS server

* DNS lookups by devices are relayed via Lighthouse VPN, to the DNS server

that Lighthouse is configured to use
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» Syslog server

* Note that incoming syslog messages are dropped unless LogZilla for NetOps

Automation has been activated
* Default gateway

* When the node is configured in cellular router mode (i.e. with forwarding and
masquerading enabled), devices can route to external services, for example,

to enroll with third-party management systems for additional configuration.

ADVANCED OPTIONS
USING VARIABLES IN CONFIGURATION FILE TEMPLATES

In addition to static files, you may create templated ZTP configuration or script files.
This is useful if your file needs to reference site- specific values such as an assigned

IP addresses.

Any file uploaded via the web Ul, or into the downloads directly with a file suffix of .j2
(Jinja2) will be automatically templated. The .j2 suffix is stripped when serving

templated files to devices.
Available variables:

* {{nom_remote_server }}
* Address of provisioning interface on the node

* Example: 10.0.0.1
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* {{nom_remote_interface }}
* Name of provisioning interface on the node

* Example: net2

{{ nom_remote_netmask }}

* Netmask of provisioning interface on the node (and netmask assigned in
DHCP offers)

* Example: 255.255.255.0

{{ nomremotenetmaskcidr }}
» CIDR format netmask (prefix length) of provisioning interface on the node

* Example: 24

{{nom_remote _ntp_server }}

* Address of NTP server assigned in DHCP offers (same as nom_remote_

server)

* Example: 10.0.0.1

{{nom_remote_dns_server}}

* Address of DNS server assigned in DHCP offers (same as nom_remote__

server)

* Example: 10.0.0.1

{{ nom_device_ipv4_address }}
* This feature is only supported by Operations Manager nodes.
* DHCP address assigned to target device

* Example: 10.0.0.13
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+ {{ nomremotesshpubkey }}

* Public part of an auto-generated SSH keypair on the remote node, which may
be injected into device config to pre- authenticate the node for any post-

provisioning activities.

* Example: ssh-rsa
AAAAB3NzaC1yc2EAAAADAQABAAABAQDHO50MVT4A9NI7vjDIS+76LgD
BtEDm+J1gaQPNilV62CGA6cm5wASDiIddY/KZKHA

* root@platypus.employee.bne.opengear.com (example only).

{{ nom_device_hostname }}
* This feature is only supported by Operations Manager nodes.
* Hostname advertised by target device

* Example: router

{{nom_device_mac_address }}

Note:This feature is only supported by Operations Manager nodes.

MAC Address of target device

Example: 00:12:34:56:78:9A
For example, a basic Cumulus templated provisioning script may look like:

cumulus_setup.sh.j2

#!/bin/bash
curl tftp://{{nom remote server}}/cumulus interfaces >

/etc/network/interfaces
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POST-PROVISIONING SCRIPTS
Note:This feature is only supported by Operations Manager nodes.

It is possible to upload a script and associated with a device Resource Bundle, to be
run by remote Operations Manager node once a Managed Device is considered
provisioned. A device is considered to be in a provisioned state once has

downloaded all of the files in the Resource Bundle it is being provisioned with.

The script may be uploaded and associated via the Ul during Resource Bundle
creation using the Post-Provisioning Script option, or checked-in to the
downloads directly via g1t /scp and specified in the YAML configuration for the

device Resource Bundle:

demo_arista:

device type: arista

config file: 'demo arista.cfg'

image file: 'arista eos.swi'

post provision script: arista fixups over ssh.py

post provision script timeout: 900

Scripts may be implemented in bash, Python 2 or Python 3, and must start with a

shebang —i.e. the first line must be one of:

#!/bin/bash
#!/usr/bin/env python?2

#!/usr/bin/env python3

Notes:
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» Scripts are run in a monitored background processes in the Secure Provisioning

container (remote-dop) on the node

» Scripts have a default 15 minute timeout, this can be manually configured in the

YAML config (postprovisionscripttimeout_)

» Scripts may login to target device via the network using SSH key auth where
nomremotesshpubkey has been injected into the device config (see Templated

resource above), or using username/password with the sshpass command

ORDERED PROVISIONING
Note:This feature is only supported by Operations Manager nodes.

The Provision After option allows you to create basic dependency chains, to
enforce the order in which devices are provisioned. In certain scenarios it may be

advantageous to control the order in which devices are provisioned, for example:

* Ensure security infrastructure is provisioned ahead of systems that may other

become inadvertently exposed on the network.

* Bring the production WAN up early to allow devices to provision services in-band,

saving cellular data.

» Disallow local user access to the LAN until the network is fully up and running.

When a dependent Resource Bundle has the Provision After option set, the node
will not respond to ZTP requests for these resources until all required dependencies

have been met.

The Provision After property lists of one or more other, required Resource Bundles.
Each required Resource Bundle creates a dependency that at least one device has

been provisioned using the required bundle.
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If multiples of a particular required device must be provisioned before a dependent

device, simply specify the dependency multiple times in the list.
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You may configure this via the Ul during Resource Bundle creation using the
Provision After option, or directly via git/scp in the YAML configuration for the device

Resource Bundle:

access switch:

device type: juniper

config file: 'jn-switch35.config'

image file: 'jinstall-ex-4200-13.2Rl.l1-domestic-signed.tgz’
provision after:

- branch router

TROUBLESHOOTING SECURE PROVISIONING

Secure Provisioning consists of several Docker containers:

* The central-dop container runs on Lighthouse, hosting git repository
* The dop-ui container runs on Lighthouse, serving the Secure Provisioning web Ul

* The remote-dop container runs on Operations Manager nodes, running DHCP
and TFTP/HTTP ZTP services

Additionally, the deployment container runs on Lighthouse, orchestrates new

module installation on Lighthouse and nodes.

See the troubleshooting commands on the following page.
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TROUBLESHOOTING COMMANDS

The following are useful commands for troubleshooting issues with the NetOps

modules:
Command
docker ps

View running Docker containers.

docker exec -ti container-name bash

Spawn a bash shell inside a container.

docker logs container-name

View logs of a container.

docker exec -ti deployment ansible-playbook -vvv /ans-
ible/dop 2.0.0.yml

Manually run module deployment in verbose mode, on Lighthouse.

/etc/scripts/post-receive

Manually push ZTP resources from Lighthouse to Operations Manager nodes
(inside central-dop container).

/etc/scripts/netops ui handler
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If the Lighthouse Ul fails to display after an upgrade, it's possible a NetOps Ul
component is failing to load and may be able to recover by running this com-
mand.
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COMMAND LINE TOOLS

Lighthouse includes a web-based terminal. To access this bash shell instance:

1. Select MANAGE > LIGHTHOUSE > Local Terminal. A login prompt displays

2. Enter an administrator’'s username and press Return.

3. A password: prompt displays. Enter the administrator’s password and press
Return.

4. A bash shell prompt displays.

This shell supports most standard bash commands and also supports copy-and-

paste to and from the terminal.

Lighthouse-specific shell-based tools are listed below.

node—-command —--list-nodes
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EXAMPLE NODE-COMMAND OUTPUT

== node-command ID 2017-05-19T14:08:33.360164 29534 ==
14:08:33 [SUCCESS] BNE-RO1-ACM7004-5 192.168.128.2:22

OpenGear/ACM7004-5 Lighthouse 3b90d826 -- Tue May 9 13:42:16 EST 2017

14:08:33 [SUCCESS] BNE-R02-IM7216 192.168.128.3:22

OpenGear/IM72xx Lighthouse 3b90d826 —-- Tue Jul 5 13:42:16 EST 20167

NODE-INFO

node-info is a shell-based tool for pulling more detailed information from console

servers.
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EXAMPLE NODE-INFO OUTPUT

$ node-info -A
BNE-RO1-ACM7004-5

address: 192.168.128.2

id: nodes-1

ssh port: 22

description: Brisbane Rack 1

Enrollment status: Enrolled

connection status: Connected
BNE-R02-IM7216

address: 192.168.128.3

id: nodes-2

ssh port: 22

description: Brisbane Rack 2

Enrollment status: Enrolled

connection status: Connected

NODE-UPGRADE

node-upgrade is a tool for running firmware upgrades on multiple managed
console servers with a single command and returns the results in tabular form to

stdout.

node-upgrade accepts the following arguments:
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ST Long Argument

ment

-h --help

-q -—quiet

-V --verbose

- --list-nodes

-D --debug

| --ignore-version

-i --node-id=<id>

-n --node-name=<name>

-a --node-address-
s=<address>

-A --all

P —-product=<family>

Description

Display usage information and
exit

Suppress log messages

Display logs generated while
upgrading

Display nodes and their
upgradeable paths without
executing upgrade

Display detailed log messages,
implies -verbose

Ignore firmware version warn-
ings for upgrade

Select node by config ID

Select node by name

Select node by VPN address

Select all available nodes

Select node by product family
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ST Long Argument

ment

-g --smartgroup=<name>

-f -firmware-dir-
r=<directory>

-F —-firmware-file=<path>

-V --version=<version>

Description

Select nodes by smartgroup fil-
ter

The directory of the firmware
files(s)

The firmware image to use for
upgrade

The firmware version to
upgrade to

AN EXAMPLE NODE-UPGRADE RUN

The following is an example node-upgrade command. It sets /mnt/data/nvram/latest-

firmware as the directory node-upgrade looks to for the firmware image used as the

source for all the firmware upgrade attempts. Every console server being managed

from the active Lighthouse instance is targeted for an upgrade and the target

console servers are set to upgrade to firmware 4.11.0.

# node-upgrade --all --firmware-dir /mnt/data/nvram/latest-firmware/

--version 4.11.0

NODE (UUID) MODEL FAMILY ADDRESS VERSION RESULT

cm7116-2 (nodes-4) CM7116-2 CM71XX 192.168.128.5 4.11.0 SUCCESS
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im7208-2 (nodes-6) IM7208-2 IM72XX 192.168.128.7 4.10.0 SUCCESS
cm7196a-2 (nodes-5) CM7196A-2 CM7196 192.168.128.6 4.10.0 SUCCESS
acm7004-2 (nodes-2) ACM7004-2 ACM700X 192.168.128.3 4.11.0 SUCCESS
acm5508-2 (nodes-1) ACM5508-2 ACM550X 192.168.128.2 4.1.1u2 SUCCESS
acm7004-5 (nodes-3) ACM7004-5 ACM7004-5 192.168.128.4 4.11.0 SUCCESS
om2216-1 (nodes-8) OM2216-L OMXXXX 192.168.128.9 21.Q2.1
FileNotFoundError
oml208-8e (nodes-7) OM1208-8E OMXXXX 192.168.128.8 21.Q2.1

FileNotFoundError

* Version shows the device version prior to upgrade.

* Result shows whether the upgrade for each device succeeded, or returns an

error with more detail.

RESULTS AND ERROR MESSAGES IN NODE-UPGRADE

When the node-upgrade command is run with valid arguments and parameters, the
program will return exit status 0 and the following results and error messages may

be returned for each node listed.

Result Causes
SUCCESS Node upgrade succeeded
FileNotFoundError No upgrade file found matching provided

device family or version
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Result Causes
UpgradeError Device already has same or higher firm-
ware version

Network connection lost

IncompatibleFirmwareError Firmware file provided does not match the
product family

In addition, the following exit statuses may be returned.

Exit Status Description

0 Command exited normally

1 Invalid parameter

2 Unknown argument
CRON

The cron service can be used to schedule file execution at specific times. Daemon
can be managed viathe /etc/init.d/crond interface, and cron tables managed

via crontab.
Usage:

crontab [options] file
crontab [options]

crontab -n [hostname]
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Options:
Options Description
-u <user> define user
-€ edit user's crontab
-1 list user's crontab
- delete user's crontab
-1 prompt before deleting
-n <host> set host in cluster to run users' crontabs
-C get host in cluster to run users' crontabs
-x <mask>

enable debugging

To perform start/stop/restart on crond service:
/etc/init.d/crond start

To verify the current crond status:

/etc/init.d/crond status
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To check current cron jobs running with the following command to list all crontabs:
crontab -1
To edit or create a custom crontab file:

crontab -e

This opens a personal cron configuration file. Each line can contain one command

to run. The following format is used:

minute hour day-of-month month day-of-week command

For example, the following entry will run a the specified backup.sh script every day

at 3am:
0 3 * * * /etc/config/backup.sh

When finished, save and close the crontab file.

SYSFLASH

sysflash is a shell-based tool for upgrading a Lighthouse instance’s system.
Sysflash will warn you if you do not have enough available space to upgrade to,

though this is unlikely as space is reserved specifically for the upgrade process.
Basic syntax is as follows:

# sysflash [flags] [path/to/system-image.lg upg | Percent-

encoded URL to firmware-image.lg upg]

Note:URLs must be Percent-encoded and image filenames cannot include

spaces.
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sysflash includes eight flags which modify the standard upgrade behavior as well

as the -h or --help flag, which returns all the available flags and their effects:

Arguments Description

-b Override board name (currently lighthouse-vm)

--board-name <name>

-B Override board revision (currently 1.0)

--board-revision <version>

-V Override vendor (currently opengear)

--vendor <vendor>

-l Do not check software version for upgradability

--no-version-check

-m Do not migrate current config. Start fresh.
--no-migration

-v Increase verbosity (may repeat)

-verbose

0 Do not modify bootloader (implies --no-reboot)

--no-boot-once

-r Do not reboot after upgrading
-no-reboot

-h Print this help

-help
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SUPPORT FOR MOUNTING THE HARD DISKS WITH
OGCONFIG-CLI

Extra hard disks can be mounted in the Lighthouse VM by adding them to the
configuration. Each new disk must have a partition created and formatted. Partitions
can be created using fdisk or cfdisk, and should be formatted using the ext4

filesystem, using the mkfs.ext4 command:

root@lighthouse:~# mkfs.ext4 /dev/sdbl

The directory in which to mount the filesystem must be created. In general, new
filesystems should be mounted in the provided mountpoint of /mnt/au. Any
other filesystems should be mounted within the filesystem mounted here. The UUID
can be obtained by running b1 kid. This will output the UUID's of all the extra hard
disks on the system. When referencing the UUID, ensure the entire UUID is

enclosed within quote marks like this:

"UUID=33464920-f54f-46b6-bd84-12f76eeb%92da"
else the command will not run correctly.

Add the information to the configuration system using ogconfig-cl1i as follows,

modifying the path for the specific situation.

ogcfg> var m !append system.mountpoints map
{8435270-fb39-11e7-8£fcf-4fall570959}: Map <>

ogcfg> set {m}.node "UUID=33464920-f54f-46b6-bd84-12f76eeb92da"
{b8c37c6-fb39-11e7-971c-23517b19319}: String </dev/sdbl>

ogcfg> set {m}.path "/mnt/aux"
{1fb50d8-fb39-11e7-994c-0£10b09%cbd4}: String </mnt/aux>

ogcfg> push

OK
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SUPPORT FOR MULTIPLE INSTANCE LIGHTHOUSE
WITH OGCONFIG-CLI

Configuration system information can be displayed, searched, and set from both the
primary and secondary Lighthouse instances. To reference the primary instance,
use lighthouse configurations[0]. The secondary instance is reachable

with 1ighthouse configurations[1].

For example, to display nodes all network connections to the primary Lighthouse,

use:

ogcfg> print lighthouse configurations[0].system.net.conns

CLI SUPPORT FOR CONFIGURING NETWORK
TRAFFIC MIRRORING

traffic mirroringis a tool that allows network administrators to set up an
integration with their enterprise Intrusion Detection System (IDS). For more details

see "Configuring Lighthouse for Network traffic Mirroring" on page 224.

root@lighthouse:~# traffic mirroring --enable --destination-ip
10.97.100.1 --vlan-id 100

Configuring for Primary Lighthouse instance (Instance ID: 1).
Confirming that Traffic Mirroring is set up...

Traffic Mirroring successfully enabled.

root@lighthouse:~# traffic mirroring --status

Primary Lighthouse 1 has traffic mirroring enabled.

Mirroring Node VPN (tunO) -> 10.97.100.1 (VLAN 100)

Mirroring Multi Instance VPN (tunl) -> 10.97.100.1 (VLAN 100)
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root@lighthouse:~# traffic mirroring --test

Preparing to test Node VPN (tun0O) interface.

Pinging address '192.168.128.2"' on interface 'tunO'.

Preparing to test Multi Instance VPN (tunl) interface.

Pinging address '172.16.1.2"'" on interface 'tunl'.

Test complete. The pings sent across the VPN's should have been
mirrored.

root@lighthouse:~# traffic mirroring --disable

Traffic Mirroring disabled.

NETWORK TRAFFIC MIRRORING

Network Traffic Mirroring can only be configured by a network administrator with

sudo access. Only a command line interface is available for this feature.

These commands work on the primary Lighthouse to enable network traffic
mirroring, however secondary lighthouses can use --test and --status to check

if the network traffic mirroring is in use.
Command Argument Description

traffic mirroring --help Display usage
information and
exit

traffic mirroring --test Test the setup by
sending a single
ping on each
VPN and attempt
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Command Argument

traffic mirroring --disable

traffic mirroring --status

traffic mirroring --enable --destination-
ip <ip address>

traffic mirroring --enable --destination-
ip <ip address> --vlan-id <vlan number>

Command line tools

Description

to confirm that
the current setup
is valid, and the
correct rules and
interfaces exist,
and the des-
tination IP is
reachable.

Disable network
traffic mirroring

Get the current
status of the
traffic mirroring
config

Enable network
traffic mirroring
and configure the
destination IP
address where
mirrored packets
will be sent to
(for example,
IDS).

Enable network
traffic mirroring,
configure the des-
tination IP
address, and con-
figure the VLAN
tag for all
mirrored packets.
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Command Argument

traffic mirroring --enable --destination-
ip <ip address> --vlan-id <vlan number> --
ignore-multi-instance

traffic mirroring --enable --destination-
ip <ip address> --vlan-id <vlan number> --
instance-id <lighthouse instance id>

Command line tools

Description

Enable network
traffic mirroring,
configure the des-
tination IP
address, con-
figures the VLAN
tag and not mir-
ror traffic
between multi-
instances Light-
houses.

Enable network
traffic mirroring,
configure the des-
tination IP
address, con-
figure the VLAN
tag, and con-
figure the
instance ID of the
lighthouse for
which to con-
figure traffic mir-
roring. If —-
instance-idis
omitted, then all
Lighthouses in a
multi-instances
will be configured
for traffic mir-
roring.
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GLOSSARY

Terms used in this guide to define Lighthouse elements and concepts are listed

below.

Term Definition

AUTHDOWNLOCAL When AUTHDOWNLOCAL authentication

(RADIUS/LDAP/TACAS) option is selected, if remote authentication
fails because the user does not exist on the
remote AAA server, the user is denied
access.

AUTHLOCAL When AUTHLOCAL authentication option is

(RADIUS/LDAP/TACAS) selected, if remote authentication fails
because the user does not exist on the
remote AAA server, Lighthouse tries to
authenticate the user using a local account.

CELLULAR HEALTH Status of the cellular connection of a node.

DARK MODE Changes the user interface to display
mostly dark colors, reducing the light emit-
ted by device screens.

DOCKER An open platform for developing, shipping,

and running applications. Docker enables
you to separate your applications from your
infrastructure so you can deliver software

quickly.
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ENROLLMENT

ENROLLMENT BUNDLE

ENROLLED NODE

ENROLLMENT TOKEN

INSTANCE

INTRUSION
DETECTION SYSTEM

LIGHT MODE

Docker powers the NetOps platform within

the Lighthouse product.

Connecting a node to Lighthouse.

Used to assign a number of tags to a set of
nodes when they are enrolled. During
Enroliment, the bundle is specified using its
name, and a bundle-specific Enroliment

token.

A Node that has been connected to

Lighthouse and is ready for use.

A password that authorizes the node with
Lighthouse. Used when performing Node-
based, or ZTP Enrollment.

A single running Lighthouse.

An Intrusion Detection System (IDS) is a net-
work security technology built for detecting
vulnerability exploits against a target applic-
ation.

Changes the user interface to display
mostly light colors. This is the default Ul set-
ting.
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LIGHTHOUSE

LIGHTHOUSE ENTERPRISE

LIGHTHOUSE VPN

LOCALAUTH
(RADIUS/LDAP/AAA)

MANAGED DEVICE

MULTIPLE INSTANCE

NODE

System for accessing, managing and

monitoring Opengear console servers.

Offers an elevated centralized management
solution with additional functionality. It sup-
ports growing trends such as edge com-
puting and SD-WAN with High Availability
and Remote IP Access.

The OpenVPN based connections that the
Lighthouse instance has with the nodes it is
managing

When LOCALAUTH authentication option
is selected, if local authentication fails,
Lighthouse tries to authenticate the user

using a remote AAA server.

A device that is managed via a node
through a serial, USB, or network

connection.

Access nodes through multiple Lighthouse
instances at the same time.

A device that can be enrolled with Light-
house, allowing it to be accessed, managed,
and monitored. Currently, Opengear console
servers are supported on a standard license,
with support for other vendors Console Serv-
ers available as an add-on.
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PASSWORD POLICY

PENDING NODE

PRIMARY INSTANCE

REMOTE LOGGING/REMOTE
SYSLOG

REPLICATION

ROLE

SECONDARY/DEPENDENT
INSTANCES

Administrative users can define rules for
Lighthouse user passwords including
length, types of characters, reuse, and expir-
ation period.

A node that has been connected to Light-
house and has been configured with a VPN
Tunnel, but which has not yet been
approved for access, monitoring, or man-
agement. The approval operation can be
automated by configuring Lighthouse to
auto- approve nodes.

The main instance of Lighthouse used for
updating configuration and node enroll-
ment.

The ability to send logs to a remote server,
for the offsite storage and review of logs.

Automatic copying of the primary Light-
house database to any connected depend-
ent instances. Replication ensures that
these instances mirror the same inform-
ation and maintains connections to the
same nodes.

A set of access rights for a particular group.
Three roles are defined within Lighthouse:
Lighthouse Administrator, Node Admin-
istrator, and Node User.

Redundant instances of Lighthouse that are
used to access Lighthouse information and
connected nodes.
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SMART GROUP

TAG

Dynamic filter used to search for particular
nodes, or for defining the access rights of a
group of users. Smart Groups use node
properties, as well as tags defined by users.

User-defined attribute and value that is
assigned to one or more nodes or ports.
Tags are used when creating Smart Groups
for filtering views or access to nodes and
ports.
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